debian/patches/debian/kernelvariables.patch: Fix header architecture setup.

svn path=/dists/trunk/linux-2.6/; revision=12018
This commit is contained in:
Bastian Blank 2008-08-10 09:54:20 +00:00
parent ea4ccc213b
commit 291bc33e75
1 changed files with 9 additions and 11 deletions

View File

@ -1,10 +1,8 @@
Postpone architecture dependant definitions.
Makes it possible to overwrite arch, compiler and things like cflags in one
place.
diff --git a/Makefile b/Makefile
index f3e2065..3cc474a 100644
--- a/Makefile
+++ b/Makefile
@@ -193,25 +193,6 @@
@@ -193,25 +193,6 @@ export KBUILD_BUILDHOST := $(SUBARCH)
ARCH ?= $(SUBARCH)
CROSS_COMPILE ?=
@ -30,9 +28,9 @@ place.
KCONFIG_CONFIG ?= .config
# SHELL used by kbuild
@@ -340,6 +326,27 @@
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
KERNELVERSION = $(VERSION).$(PATCHLEVEL).$(SUBLEVEL)$(EXTRAVERSION)
@@ -329,6 +310,27 @@ CFLAGS_KERNEL =
AFLAGS_KERNEL =
+-include .kernelvariables
+
@ -55,6 +53,6 @@ place.
+ hdr-arch := $(SRCARCH)
+endif
+
export VERSION PATCHLEVEL SUBLEVEL KERNELRELEASE KERNELVERSION
export ARCH SRCARCH CONFIG_SHELL HOSTCC HOSTCFLAGS CROSS_COMPILE AS LD CC
export CPP AR NM STRIP OBJCOPY OBJDUMP MAKE AWK GENKSYMS PERL UTS_MACHINE
# Use LINUXINCLUDE when you must reference the include/ directory.
# Needed to be compatible with the O= option
LINUXINCLUDE := -Iinclude \