Update to 4.17.12

This updates the debian changelog for listing changes of this stable
update. It also removes patches that have been applied upstream.
This commit is contained in:
Romain Perier 2018-08-03 12:57:50 +02:00
parent 4bbc6ce6f3
commit 281dea527f
4 changed files with 319 additions and 104 deletions

320
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.17.11-1) UNRELEASED; urgency=medium
linux (4.17.12-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.17.9
@ -205,6 +205,324 @@ linux (4.17.11-1) UNRELEASED; urgency=medium
table load
- driver core: Partially revert "driver core: correct device's shutdown
order"
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.17.12
- Input: elan_i2c - add ACPI ID for lenovo ideapad 330
- Input: i8042 - add Lenovo LaVie Z to the i8042 reset list
- Input: elan_i2c - add another ACPI ID for Lenovo Ideapad 330-15AST
- mm: disallow mappings that conflict for devm_memremap_pages()
- kvm, mm: account shadow page tables to kmemcg
- delayacct: fix crash in delayacct_blkio_end() after delayacct init failure
- tracing: Fix double free of event_trigger_data
- tracing: Fix possible double free in event_enable_trigger_func()
- kthread, tracing: Don't expose half-written comm when creating kthreads
- tracing/kprobes: Fix trace_probe flags on enable_trace_kprobe() failure
- tracing: Quiet gcc warning about maybe unused link variable
- [arm64] fix vmemmap BUILD_BUG_ON() triggering on !vmemmap setups
- [x86] drm/i915/glk: Add Quirk for GLK NUC HDMI port issues.
- kcov: ensure irq code sees a valid area
- mm: check for SIGKILL inside dup_mmap() loop
- drm/amd/powerplay: Set higher SCLK&MCLK frequency than dpm7 in OD (v2)
- xen/netfront: raise max number of slots in xennet_get_responses()
- [x86] hv_netvsc: fix network namespace issues with VF support
- skip LAYOUTRETURN if layout is invalid
- ixgbe: Fix setting of TC configuration for macvlan case
- ALSA: emu10k1: add error handling for snd_ctl_add
- ALSA: fm801: add error handling for snd_ctl_add
- NFSv4.1: Fix the client behaviour on NFS4ERR_SEQ_FALSE_RETRY
- nfsd: fix error handling in nfs4_set_delegation()
- nfsd: fix potential use-after-free in nfsd4_decode_getdeviceinfo
- vfio: platform: Fix reset module leak in error path
- vfio/mdev: Check globally for duplicate devices
- vfio/type1: Fix task tracking for QEMU vCPU hotplug
- kernel/hung_task.c: show all hung tasks before panic
- mem_cgroup: make sure moving_account, move_lock_task and stat_cpu in the
same cacheline
- mm: /proc/pid/pagemap: hide swap entries from unprivileged users
- mm: vmalloc: avoid racy handling of debugobjects in vunmap
- mm/slub.c: add __printf verification to slab_err()
- rtc: ensure rtc_set_alarm fails when alarms are not supported
- rxrpc: Fix terminal retransmission connection ID to include the channel
- [arm64] net: hns3: Fix for VF mailbox cannot receiving PF response
- perf tools: Fix pmu events parsing rule
- netfilter: ipset: forbid family for hash:mac sets
- netfilter: ipset: List timing out entries with "timeout 1" instead of zero
- printk: drop in_nmi check from printk_safe_flush_on_panic()
- [armhf] bpf: fix inconsistent naming about emit_a32_lsr_{r64,i64}
- ceph: fix alignment of rasize
- ceph: fix use-after-free in ceph_statfs()
- e1000e: Ignore TSYNCRXCTL when getting I219 clock attributes
- infiniband: fix a possible use-after-free bug (CVE-2018-14734)
- [powerpc*] lib: Adjust .balign inside string functions for PPC32
- [powerpc*] 64s: Add barrier_nospec
- [powerpc*] eeh: Fix use-after-release of EEH driver
- [powerpc*] 64s: Fix compiler store ordering to SLB shadow area
- [arm64] net: hns3: Fix for phy not link up problem after resetting
- [arm64] net: hns3: Fix for service_task not running problem after
resetting
- RDMA/mad: Convert BUG_ONs to error flows
- lightnvm: fix partial read error path
- lightnvm: proper error handling for pblk_bio_add_pages
- lightnvm: pblk: warn in case of corrupted write buffer
- netfilter: nf_tables: check msg_type before nft_trans_set(trans)
- pnfs: Don't release the sequence slot until we've processed layoutget on
open
- NFS: Fix up nfs_post_op_update_inode() to force ctime updates
- disable loading f2fs module on PAGE_SIZE > 4KB
- f2fs: fix error path of move_data_page
- f2fs: don't drop dentry pages after fs shutdown
- f2fs: fix to don't trigger writeback during recovery
- f2fs: fix to wait page writeback during revoking atomic write
- f2fs: Fix deadlock in shutdown ioctl
- f2fs: fix missing clear FI_NO_PREALLOC in some error case
- f2fs: fix to detect failure of dquot_initialize
- f2fs: fix race in between GC and atomic open
- block, bfq: remove wrong lock in bfq_requests_merged
- usbip: usbip_detach: Fix memory, udev context and udev leak
- usbip: dynamically allocate idev by nports found in sysfs
- [x86] perf/x86/intel/uncore: Correct fixed counter index check in
generic code
- [x86] perf/x86/intel/uncore: Correct fixed counter index check for NHM
- PCI: Fix devm_pci_alloc_host_bridge() memory leak
- btrfs: balance dirty metadata pages in btrfs_finish_ordered_io
- iwlwifi: pcie: fix race in Rx buffer allocator
- iwlwifi: mvm: open BA session only when sta is authorized
- Bluetooth: hci_qca: Fix "Sleep inside atomic section" warning
- drm/amd/display: Do not program interrupt status on disabled crtc
- Bluetooth: btusb: Add a new Realtek 8723DE ID 2ff8:b011
- ASoC: dpcm: fix BE dai not hw_free and shutdown
- mfd: cros_ec: Fail early if we cannot identify the EC
- mwifiex: handle race during mwifiex_usb_disconnect
- wlcore: sdio: check for valid platform device data before suspend
- [arm64] net: hns3: Fixes initalization of RoCE handle and makes it
conditional
- [arm64] net: hns3: Fixes the init of the VALID BD info in the descriptor
- media: tw686x: Fix incorrect vb2_mem_ops GFP flags
- media: cec-pin-error-inj: avoid a false-positive Spectre detection
- media: videobuf2-core: don't call memop 'finish' when queueing
- Btrfs: don't return ino to ino cache if inode item removal fails
- Btrfs: don't BUG_ON() in btrfs_truncate_inode_items()
- btrfs: add barriers to btrfs_sync_log before log_commit_wait wakeups
- btrfs: qgroup: Finish rescan when hit the last leaf of extent tree
- [x86] microcode: Make the late update update_lock a raw lock for RT
- PM / wakeup: Make s2idle_lock a RAW_SPINLOCK
- PCI: Prevent sysfs disable of device while driver is attached
- [arm64] soc: qcom: qmi: fix a buffer sizing bug
- [arm64] soc: qcom: smem: fix qcom_smem_set_global_partition()
- [arm64] soc: qcom: smem: byte swap values properly
- nvme-rdma: stop admin queue before freeing it
- nvme-pci: Fix AER reset handling
- ath: Add regulatory mapping for : FCC3_ETSIC, ETSI8_WORLD, APL13_WORLD,
APL2_FCCA, Uganda, Tanzania, Serbia, Bermuda and Bahamas
- sched/cpufreq: Modify aggregate utilization to always include blocked FAIR
utilization
- [powerpc*] Add a missing include header
- [powerpc*] chrp/time: Make some functions static, add missing header
include
- [powerpc*] powermac: Add missing prototype for note_bootable_part()
- [powerpc*] powermac: Mark variable x as unused
- powerpc: Add __printf verification to prom_printf
- [x86] KVM: prevent integer overflows in KVM_MEMORY_ENCRYPT_REG_REGION
- [powerpc*] 8xx: fix invalid register expression in head_8xx.S
- [arm64] pinctrl: msm: fix gpio-hog related boot issues
- bpf: fix multi-function JITed dump obtained via syscall
- [powerpc*] bpf: pad function address loads with NOPs
- PCI: pciehp: Request control of native hotplug only if supported
- mwifiex: correct histogram data with appropriate index
- ima: based on policy verify firmware signatures (pre-allocated buffer)
- spi: Add missing pm_runtime_put_noidle() after failed get
- [arm64] net: hns3: Fix for CMDQ and Misc. interrupt init order problem
- [arm64] net: hns3: Fix the missing client list node initialization
- [arm64] net: hns3: Fix for hns3 module is loaded multiple times problem
- fscrypt: use unbound workqueue for decryption
- [armhf, arm64] net: mvpp2: Add missing VLAN tag detection
- scsi: ufs: ufshcd: fix possible unclocked register access
- scsi: ufs: fix exception event handling
- [s390x] scsi: zfcp: assert that the ERP lock is held when tracing a
recovery trigger
- drm/nouveau: remove fence wait code from deferred client work handler
- drm/nouveau/gem: lookup VMAs for buffers referenced by pushbuf ioctl
- drm/nouveau/fifo/gk104-: poll for runlist update completion
- Bluetooth: btusb: add ID for LiteOn 04ca:301a
- rtc: tps6586x: fix possible race condition
- rtc: vr41xx: fix possible race condition
- rtc: tps65910: fix possible race condition
- ALSA: emu10k1: Rate-limit error messages about page errors
- regulator: pfuze100: add .is_enable() for pfuze100_swb_regulator_ops
- md/raid1: add error handling of read error from FailFast device
- md: fix NULL dereference of mddev->pers in remove_and_add_spares()
- ixgbevf: fix MAC address changes through ixgbevf_set_mac()
- gpu: host1x: Acquire a reference to the IOVA cache
- media: smiapp: fix timeout checking in smiapp_read_nvm
- PCI/DPC: Clear interrupt status in interrupt handler top half
- clocksource: Move inline keyword to the beginning of function declarations
- net: ethernet: ti: cpsw-phy-sel: check bus_find_device() ret value
- ALSA: usb-audio: Apply rate limit to warning messages in URB complete
callback
- [arm64] net: hns3: Fix for fiber link up problem
- media: atomisp: ov2680: don't declare unused vars
- media: staging: atomisp: Comment out several unused sensor resolutions
- [arm64] cmpwait: Clear event register before arming exclusive monitor
- HID: hid-plantronics: Re-resend Update to map button for PTT products
- drm/amd/display: remove need of modeset flag for overlay planes (V2)
- drm/radeon: fix mode_valid's return type
- drm/amdgpu: Remove VRAM from shared bo domains.
- drm/amd/display: Fix dim display on DCE11
- IB: Fix RDMA_RXE and INFINIBAND_RDMAVT dependencies for DMA_VIRT_OPS
- [powerpc*] embedded6xx/hlwd-pic: Prevent interrupts from being handled by
Starlet
- HID: i2c-hid: check if device is there before really probing
- rsi: Add null check for virtual interfaces in wowlan config
- nvmem: properly handle returned value nvmem_reg_read
- [armhf] ARM: dts: imx53: Fix LDB OF graph warning
- i40e: free the skb after clearing the bitlock
- tty: Fix data race in tty_insert_flip_string_fixed_flag
- dma-iommu: Fix compilation when !CONFIG_IOMMU_DMA
- net: phy: phylink: Release link GPIO
- media: rcar_jpu: Add missing clk_disable_unprepare() on error in
jpu_open()
- libata: Fix command retry decision
- ACPI / LPSS: Only call pwm_add_table() for Bay Trail PWM if PMIC HRV is 2
- media: media-device: fix ioctl function types
- media: saa7164: Fix driver name in debug output
- media: em28xx: Fix DualHD broken second tuner
- mtd: rawnand: fsl_ifc: fix FSL NAND driver to read all ONFI parameter
pages
- brcmfmac: Add support for bcm43364 wireless chipset
- [s390x] cpum_sf: Add data entry sizes to sampling trailer entry
- perf: fix invalid bit in diagnostic entry
- net: phy: sfp: handle cases where neither BR, min nor BR, max is given
- bnxt_en: Check unsupported speeds in bnxt_update_link() on PF only.
- bnxt_en: Always forward VF MAC address to the PF.
- mm, powerpc, x86: define VM_PKEY_BITx bits if CONFIG_ARCH_HAS_PKEYS is
enabled
- staging: most: cdev: fix chrdev_region leak
- scsi: 3w-9xxx: fix a missing-check bug
- scsi: 3w-xxxx: fix a missing-check bug
- scsi: megaraid: silence a static checker bug
- scsi: hisi_sas: config ATA de-reset as an constrained command for v3 hw
- soc/tegra: pmc: Don't allocate struct tegra_powergate on stack
- scsi: qedf: Set the UNLOADING flag when removing a vport
- dma-direct: try reallocation with GFP_DMA32 if possible
- staging: lustre: o2iblnd: fix race at kiblnd_connect_peer
- staging: lustre: o2iblnd: Fix FastReg map/unmap for MLX5
- thermal: exynos: fix setting rising_threshold for Exynos5433
- regulator: add dummy function of_find_regulator_by_node
- bpf: fix references to free_bpf_prog_info() in comments
- f2fs: avoid fsync() failure caused by EAGAIN in writepage()
- media: em28xx: fix a regression with HVR-950
- media: siano: get rid of __le32/__le16 cast warnings
- mt76x2: fix avg_rssi estimation
- drm/atomic: Handling the case when setting old crtc for plane
- mmc: sdhci-omap: Fix when capabilities are obtained from
SDHCI_CAPABILITIES reg
- f2fs: check cap_resource only for data blocks
- mlxsw: spectrum_router: Return an error for non-default FIB rules
- ALSA: hda/ca0132: fix build failure when a local macro is defined
- mmc: dw_mmc: update actual clock for mmc debugfs
- mmc: pwrseq: Use kmalloc_array instead of stack VLA
- [arm64] dt-bindings: pinctrl: meson: add support for the Meson8m2 SoC
- [armhf] spi: meson-spicc: Fix error handling in meson_spicc_probe()
- [arm64] net: hns3: Fixes the out of bounds access in hclge_map_tqp
- dt-bindings: net: meson-dwmac: new compatible name for AXG SoC
- i40e: Add advertising 10G LR mode
- i40e: avoid overflow in i40e_ptp_adjfreq()
- mt76: add rcu locking around tx scheduling
- backlight: pwm_bl: Don't use GPIOF_* with gpiod_get_direction
- stop_machine: Use raw spinlocks
- delayacct: Use raw_spinlocks
- ath10k: fix kernel panic while reading tpc_stats
- memory: tegra: Do not handle spurious interrupts
- memory: tegra: Apply interrupts mask per SoC
- nvme: lightnvm: add granby support
- ASoC: fsl_ssi: Use u32 variable type when using regmap_read()
- ASoC: compress: Only call free for components which have been opened
- igb: Fix queue selection on MAC filters on i210
- qtnfmac: pearl: pcie: fix memory leak in qtnf_fw_work_handler
- drm/gma500: fix psb_intel_lvds_mode_valid()'s return type
- ipconfig: Correctly initialise ic_nameservers
- rsi: Fix 'invalid vdd' warning in mmc
- rsi: fix nommu_map_sg overflow kernel panic
- audit: allow not equal op for audit by executable
- [armhf, arm64] drm/rockchip: analogix_dp: Do not call Analogix code before
bind
- [x86] platform/x86: dell-smbios: Match on www.dell.com in OEM strings too
- staging: vchiq_core: Fix missing semaphore release in error case
- staging: lustre: llite: correct removexattr detection
- staging: lustre: ldlm: free resource when ldlm_lock_create() fails.
- staging: ks7010: fix error handling in ks7010_upload_firmware
- serial: core: Make sure compiler barfs for 16-byte earlycon names
- soc: imx: gpcv2: Do not pass static memory as platform data
- microblaze: Fix simpleImage format generation
- usb: hub: Don't wait for connect state at resume for powered-off ports
- crypto: authencesn - don't leak pointers to authenc keys
- crypto: authenc - don't leak pointers to authenc keys
- y2038: ipc: Use ktime_get_real_seconds consistently
- media: rc: mce_kbd decoder: low timeout values cause double keydowns
- media: omap3isp: fix unbalanced dma_iommu_mapping
- regulator: Don't return or expect -errno from of_map_mode()
- ath10k: search all IEs for variant before falling back
- drm/stm: ltdc: fix warning in ltdc_crtc_update_clut()
- scsi: scsi_dh: replace too broad "TP9" string with the exact models
- scsi: megaraid_sas: Increase timeout by 1 sec for non-RAID fastpath IOs
- scsi: cxlflash: Synchronize reset and remove ops
- scsi: cxlflash: Avoid clobbering context control register value
- PCI/ASPM: Disable ASPM L1.2 Substate if we don't have LTR
- media: atomisp: compat32: fix __user annotations
- media: cec: fix smatch error
- media: si470x: fix __be16 annotations
- net: socionext: reset hardware in ndo_stop
- ASoC: topology: Fix bclk and fsync inversion in set_link_hw_format()
- ASoC: topology: Add missing clock gating parameter when parsing hw_configs
- [armhf] ARM: dts: imx6qdl-wandboard: Let the codec control MCLK pinctrl
- drm: Add DP PSR2 sink enable bit
- drm/atomic-helper: Drop plane->fb references only for
drm_atomic_helper_shutdown()
- drm/dp/mst: Fix off-by-one typo when dump payload table
- drm/amdgpu: Avoid reclaim while holding locks taken in MMU notifier
- block: bio_iov_iter_get_pages: fix size of last iovec
- blkdev: __blkdev_direct_IO_simple: fix leak in error case
- block: reset bi_iter.bi_done after splitting bio
- nvmet-fc: fix target sgl list on large transfers
- i2c: rcar: handle RXDMA HW behaviour on Gen3
- random: mix rdrand with entropy sent in from userspace
- squashfs: be more careful about metadata corruption
- ext4: fix false negatives *and* false positives in
ext4_check_descriptors()
- ext4: fix inline data updates with checksums enabled
- ext4: check for allocation block validity with block group locked
- ext4: fix check to prevent initializing reserved inodes
- gpio: of: Handle fixed regulator flags properly
- gpio: uniphier: set legitimate irq trigger type in .to_irq hook
- RDMA/uverbs: Protect from attempts to create flows on unsupported QP
- net: dsa: qca8k: Force CPU port to its highest bandwidth
- net: dsa: qca8k: Enable RXMAC when bringing up a port
- net: dsa: qca8k: Add QCA8334 binding documentation
- net: dsa: qca8k: Allow overwriting CPU port setting
- ipv4: remove BUG_ON() from fib_compute_spec_dst
- netdevsim: don't leak devlink resources
- net: ena: Fix use of uninitialized DMA address bits field
- net: fix amd-xgbe flow-control issue
- net: lan78xx: fix rx handling before first packet is send
- net: mdio-mux: bcm-iproc: fix wrong getter and setter pair
- NET: stmmac: align DMA stuff to largest cache line length
- RDS: RDMA: Fix the NULL-ptr deref in rds_ib_get_mr
- tcp_bbr: fix bw probing to raise in-flight data for very small BDPs
- virtio_net: Fix incosistent received bytes counter
- xen-netfront: wait xenbus state change when load module manually
- cxgb4: Added missing break in ndo_udp_tunnel_{add/del}
- net: rollback orig value on failure of dev_qdisc_change_tx_queue_len
- netlink: Do not subscribe to non-existent groups
- netlink: Don't shift with UB on nlk->ngroups
- tcp: do not force quickack when receiving out-of-order packets
- tcp: add max_quickacks param to tcp_incr_quickack and
tcp_enter_quickack_mode
- tcp: do not aggressively quick ack after ECN events
- tcp: refactor tcp_ecn_check_ce to remove sk type cast
- tcp: add one more quick ack after after ECN events
- tcp: ack immediately when a cwr packet arrives
- ACPI / LPSS: Avoid PM quirks on suspend and resume from hibernation
- [x86, arm64] ACPICA: AML Parser: ignore control method status in
module-level code
[ Ben Hutchings ]
* [armhf] gpu: host1x: Drop my build fix in favour of upstream fix:

View File

@ -1,52 +0,0 @@
From: Theodore Ts'o <tytso@mit.edu>
Date: Sun, 8 Jul 2018 19:35:02 -0400
Subject: ext4: fix false negatives *and* false positives in
ext4_check_descriptors()
Origin: https://git.kernel.org/pub/scm/linux/kernel/git/tytso/ext4.git/commit?id=44de022c4382541cebdd6de4465d1f4f465ff1dd
Bug-Debian: https://bugs.debian.org/903838
Ext4_check_descriptors() was getting called before s_gdb_count was
initialized. So for file systems w/o the meta_bg feature, allocation
bitmaps could overlap the block group descriptors and ext4 wouldn't
notice.
For file systems with the meta_bg feature enabled, there was a
fencepost error which would cause the ext4_check_descriptors() to
incorrectly believe that the block allocation bitmap overlaps with the
block group descriptor blocks, and it would reject the mount.
Fix both of these problems.
Signed-off-by: Theodore Ts'o <tytso@mit.edu>
Cc: stable@vger.kernel.org
---
fs/ext4/super.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
--- a/fs/ext4/super.c
+++ b/fs/ext4/super.c
@@ -2307,7 +2307,7 @@ static int ext4_check_descriptors(struct
struct ext4_sb_info *sbi = EXT4_SB(sb);
ext4_fsblk_t first_block = le32_to_cpu(sbi->s_es->s_first_data_block);
ext4_fsblk_t last_block;
- ext4_fsblk_t last_bg_block = sb_block + ext4_bg_num_gdb(sb, 0) + 1;
+ ext4_fsblk_t last_bg_block = sb_block + ext4_bg_num_gdb(sb, 0);
ext4_fsblk_t block_bitmap;
ext4_fsblk_t inode_bitmap;
ext4_fsblk_t inode_table;
@@ -4050,14 +4050,13 @@ static int ext4_fill_super(struct super_
goto failed_mount2;
}
}
+ sbi->s_gdb_count = db_count;
if (!ext4_check_descriptors(sb, logical_sb_block, &first_not_zeroed)) {
ext4_msg(sb, KERN_ERR, "group descriptors corrupted!");
ret = -EFSCORRUPTED;
goto failed_mount2;
}
- sbi->s_gdb_count = db_count;
-
timer_setup(&sbi->s_err_report, print_daily_error_info, 0);
/* Register extent status tree shrinker */

View File

@ -1,49 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 9 May 2018 22:31:41 +0100
Subject: IB: Fix RDMA_RXE and INFINIBAND_RDMAVT dependencies for DMA_VIRT_OPS
DMA_VIRT_OPS requires that dma_addr_t is at least as wide as a
pointer, which is expressed as a dependency on !64BIT ||
ARCH_DMA_ADDR_T_64BIT.
For parisc64 this is not true, and if these IB modules are enabled,
kconfig warns:
WARNING: unmet direct dependencies detected for DMA_VIRT_OPS
Depends on [n]: HAS_DMA [=y] && (!64BIT [=y] || ARCH_DMA_ADDR_T_64BIT)
Selected by [m]:
- INFINIBAND_RDMAVT [=m] && INFINIBAND [=m] && 64BIT [=y] && PCI [=y]
- RDMA_RXE [=m] && INET [=y] && PCI [=y] && INFINIBAND [=m]
Add dependencies to fix this.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/infiniband/sw/rdmavt/Kconfig | 2 +-
drivers/infiniband/sw/rxe/Kconfig | 1 +
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/infiniband/sw/rdmavt/Kconfig b/drivers/infiniband/sw/rdmavt/Kconfig
index 2b5513da7e83..98e798007f75 100644
--- a/drivers/infiniband/sw/rdmavt/Kconfig
+++ b/drivers/infiniband/sw/rdmavt/Kconfig
@@ -1,6 +1,6 @@
config INFINIBAND_RDMAVT
tristate "RDMA verbs transport library"
- depends on 64BIT
+ depends on 64BIT && ARCH_DMA_ADDR_T_64BIT
depends on PCI
select DMA_VIRT_OPS
---help---
diff --git a/drivers/infiniband/sw/rxe/Kconfig b/drivers/infiniband/sw/rxe/Kconfig
index bad4a576d7cf..67ae960ab523 100644
--- a/drivers/infiniband/sw/rxe/Kconfig
+++ b/drivers/infiniband/sw/rxe/Kconfig
@@ -1,6 +1,7 @@
config RDMA_RXE
tristate "Software RDMA over Ethernet (RoCE) driver"
depends on INET && PCI && INFINIBAND
+ depends on !64BIT || ARCH_DMA_ADDR_T_64BIT
select NET_UDP_TUNNEL
select CRYPTO_CRC32
select DMA_VIRT_OPS

View File

@ -94,7 +94,6 @@ bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
debian/revert-objtool-fix-config_stack_validation-y-warning.patch
bugfix/all/i40e-build-for-64-bit-targets-only.patch
bugfix/all/ib-fix-rdma_rxe-and-infiniband_rdmavt-dependencies-f.patch
bugfix/all/block-really-disable-runtime-pm-for-blk-mq.patch
bugfix/all/Partially-revert-block-fail-op_is_write-requests-to-.patch
@ -141,7 +140,6 @@ features/all/lockdown/arm64-add-kernel-config-option-to-lock-down-when.patch
# Security fixes
debian/i386-686-pae-pci-set-pci-nobios-by-default.patch
bugfix/all/jfs-fix-inconsistency-between-memory-allocation-and-.patch
bugfix/all/ext4-fix-false-negatives-and-false-positives-in-ext4.patch
# Fix exported symbol versions
bugfix/all/module-disable-matching-missing-version-crc.patch