[armel] ARM: dts: orion5x-linkstation-lschl

- Fix model name
- More consistent naming on linkstation series
This commit is contained in:
Roger Shimizu 2017-01-31 02:11:17 +09:00
parent 855efa4b7b
commit 28002f99bf
4 changed files with 82 additions and 0 deletions

6
debian/changelog vendored
View File

@ -1,5 +1,6 @@
linux (4.9.6-4) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* Bump ABI to 2
* [or1k] Remove configuration, as the port has been abandoned
* [arm64] Enable KEXEC (Closes: #852747)
@ -9,6 +10,11 @@ linux (4.9.6-4) UNRELEASED; urgency=medium
USB_CONFIGFS_F_{LB_SS,LS,UAC1,UAC2,MIDI,HID,UVC,PRINTER}, USB_ETH_RNDIS,
USB_FUNCTIONFS_{ETH,RNDIS,GENERIC} (thanks to Riku Voipio)
[ Roger Shimizu ]
* [armel] ARM: dts: orion5x-lschl: Fix model name
* [armel] ARM: dts: orion5x-lschl: More consistent naming on linkstation
series
-- Ben Hutchings <ben@decadent.org.uk> Fri, 27 Jan 2017 18:14:31 +0000
linux (4.9.6-3) unstable; urgency=medium

View File

@ -0,0 +1,43 @@
From: Roger Shimizu <rogershimizu@gmail.com>
Date: Mon, 30 Jan 2017 20:07:29 +0900
Subject: [PATCH 1/2] ARM: dts: orion5x-lschl: Fix model name
Origin: http://git.infradead.org/linux-mvebu.git/d566a78ab13abded6b4acdc9b3fafa8c46f3ed09
Model name should be consistent with legacy device file, so that user
can migrate their system from legacy device support to device-tree
safely.
Legacy device file is currently removed, but it can be found on 4.8
or previous version of linux:
arch/arm/mach-orion5x/ls-chl-setup.c
Fixes: f94f268979a2 ("ARM: dts: orion5x: convert ls-chl to FDT")
Cc: Ashley Hughes <ashley.hughes@blueyonder.co.uk>
Signed-off-by: Roger Shimizu <rogershimizu@gmail.com>
Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com>
---
arch/arm/boot/dts/orion5x-lschl.dts | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/boot/dts/orion5x-lschl.dts b/arch/arm/boot/dts/orion5x-lschl.dts
index 7c999b092e06..ee751995c8d0 100644
--- a/arch/arm/boot/dts/orion5x-lschl.dts
+++ b/arch/arm/boot/dts/orion5x-lschl.dts
@@ -2,7 +2,7 @@
* Device Tree file for Buffalo Linkstation LS-CHLv3
*
* Copyright (C) 2016 Ash Hughes <ashley.hughes@blueyonder.co.uk>
- * Copyright (C) 2015, 2016
+ * Copyright (C) 2015-2017
* Roger Shimizu <rogershimizu@gmail.com>
*
* This file is dual-licensed: you can use it either under the terms
@@ -52,7 +52,7 @@
#include <dt-bindings/gpio/gpio.h>
/ {
- model = "Buffalo Linkstation Live v3 (LS-CHL)";
+ model = "Buffalo Linkstation LiveV3 (LS-CHL)";
compatible = "buffalo,lschl", "marvell,orion5x-88f5182", "marvell,orion5x";
memory { /* 128 MB */

View File

@ -0,0 +1,31 @@
From: Roger Shimizu <rogershimizu@gmail.com>
Date: Mon, 30 Jan 2017 20:07:30 +0900
Subject: [PATCH 2/2] ARM: dts: orion5x-lschl: More consistent naming on
linkstation series
Origin: http://git.infradead.org/linux-mvebu.git/56ba99b01308c360df5d18c6127f38b287550965
DTS files, which includes orion5x-linkstation.dtsi, are named:
orion5x-linkstation-*.dts
So we rename the file below:
arch/arm/boot/dts/orion5x-lschl.dts
to the new name:
arch/arm/boot/dts/orion5x-linkstation-lschl.dts
Because DTS conversion of this device was just introduced in 4.9, Debian
is still using legacy device support, other distros are the same,
so here we won't expect any impact actually.
Fixes: f94f268979a2 ("ARM: dts: orion5x: convert ls-chl to FDT")
Cc: Ashley Hughes <ashley.hughes@blueyonder.co.uk>
Signed-off-by: Roger Shimizu <rogershimizu@gmail.com>
Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com>
---
arch/arm/boot/dts/{orion5x-lschl.dts => orion5x-linkstation-lschl.dts} | 0
1 file changed, 0 insertions(+), 0 deletions(-)
rename arch/arm/boot/dts/{orion5x-lschl.dts => orion5x-linkstation-lschl.dts} (100%)
diff --git a/arch/arm/boot/dts/orion5x-lschl.dts b/arch/arm/boot/dts/orion5x-linkstation-lschl.dts
similarity index 100%
rename from arch/arm/boot/dts/orion5x-lschl.dts
rename to arch/arm/boot/dts/orion5x-linkstation-lschl.dts

View File

@ -58,6 +58,8 @@ features/arm/arm-dts-add-support-for-turris-omnia.patch
features/arm/arm-dts-turris-omnia-add-support-for-ethernet-switch.patch
features/arm/ARM-dts-orion5x-convert-ls-chl-to-FDT.patch
features/arm64/dts-meson-gx-add-firmware-reserved-memory-zone.patch
features/arm/ARM-dts-orion5x-lschl-Fix-model-name.patch
features/arm/ARM-dts-orion5x-lschl-More-consistent-naming-on-link.patch
# Miscellaneous bug fixes
bugfix/all/kbuild-use-nostdinc-in-compile-tests.patch