cpupower: Fix turbo frequency reporting for pre-Sandy Bridge cores (Closes: #859978)

This commit is contained in:
Ben Hutchings 2017-04-11 00:59:38 +01:00
parent 5547db97a6
commit 263f51b136
3 changed files with 34 additions and 0 deletions

2
debian/changelog vendored
View File

@ -10,6 +10,8 @@ linux (4.9.18-2) UNRELEASED; urgency=medium
(Closes: #859641)
* drm/nouveau/disp/mcp7x: disable dptmds workaround (Closes: #850219)
* [powerpc/powerpc64,ppc64*] target: Enable SCSI_IBMVSCSIS as module
* cpupower: Fix turbo frequency reporting for pre-Sandy Bridge cores
(Closes: #859978)
[ Salvatore Bonaccorso ]
* ping: implement proper locking (CVE-2017-2671)

View File

@ -0,0 +1,31 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 10 Apr 2017 17:44:13 +0100
Subject: cpupower: Fix turbo frequency reporting for pre-Sandy Bridge cores
Bug-Debian: https://bugs.debian.org/859978
Forwarded: https://marc.info/?l=linux-pm&m=149186698809229&w=2
The switch that conditionally sets CPUPOWER_CAP_HAS_TURBO_RATIO and
CPUPOWER_CAP_IS_SNB flags is missing a break, so all cores get both
flags set and an assumed base clock of 100 MHz for turbo values.
Reported-by: GSR <gsr.bugs@infernal-iceberg.com>
Tested-by: GSR <gsr.bugs@infernal-iceberg.com>
References: https://bugs.debian.org/859978
Fixes: 8fb2e440b223 ("cpupower: Show Intel turbo ratio support via ...")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
tools/power/cpupower/utils/helpers/cpuid.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/tools/power/cpupower/utils/helpers/cpuid.c b/tools/power/cpupower/utils/helpers/cpuid.c
index 93b0aa74ca03..39c2c7d067bb 100644
--- a/tools/power/cpupower/utils/helpers/cpuid.c
+++ b/tools/power/cpupower/utils/helpers/cpuid.c
@@ -156,6 +156,7 @@ int get_cpu_info(unsigned int cpu, struct cpupower_cpu_info *cpu_info)
*/
case 0x2C: /* Westmere EP - Gulftown */
cpu_info->caps |= CPUPOWER_CAP_HAS_TURBO_RATIO;
+ break;
case 0x2A: /* SNB */
case 0x2D: /* SNB Xeon */
case 0x3A: /* IVB */

View File

@ -170,3 +170,4 @@ bugfix/all/liblockdep-enable-wall-by-default.patch
bugfix/all/liblockdep-fix-unused-value-warnings.patch
bugfix/all/liblockdep-fix-set-but-not-used-warnings.patch
bugfix/all/liblockdep-fix-defined-but-not-used-warning-for-init.patch
bugfix/x86/cpupower-fix-turbo-frequency-reporting-for-pre-sandy.patch