sched: Build with SCHED_AUTOGROUP, but do not enable autogrouping by default

svn path=/dists/trunk/linux-2.6/; revision=17071
This commit is contained in:
Ben Hutchings 2011-03-16 03:17:06 +00:00
parent f19ec8c57e
commit 25e71bd239
4 changed files with 17 additions and 0 deletions

2
debian/changelog vendored
View File

@ -12,6 +12,8 @@ linux-2.6 (2.6.38-1) UNRELEASED; urgency=low
- hpfs: Disable HPFS_FS
* ext4: Disable FS_IOC_FIEMAP ioctl temporarily (together with fixes
for btrfs in 2.6.38, closes: #615035)
* sched: Build with SCHED_AUTOGROUP, but do not enable autogrouping by
default (use sysctl kernel.sched_autogroup_enabled=1)
[ Aurelien Jarno]
* mips/malta-[45]kc:

View File

@ -3448,6 +3448,7 @@ CONFIG_IPC_NS=y
CONFIG_USER_NS=y
CONFIG_PID_NS=y
CONFIG_NET_NS=y
CONFIG_SCHED_AUTOGROUP=y
# CONFIG_SYSFS_DEPRECATED is not set
# CONFIG_SYSFS_DEPRECATED_V2 is not set
CONFIG_RELAY=y

View File

@ -0,0 +1,13 @@
diff --git a/kernel/sched_autogroup.c b/kernel/sched_autogroup.c
index 9fb6562..96abaaf 100644
--- a/kernel/sched_autogroup.c
+++ b/kernel/sched_autogroup.c
@@ -5,7 +5,7 @@
#include <linux/kallsyms.h>
#include <linux/utsname.h>
-unsigned int __read_mostly sysctl_sched_autogroup_enabled = 1;
+unsigned int __read_mostly sysctl_sched_autogroup_enabled = 0;
static struct autogroup autogroup_default;
static atomic_t autogroup_seq_nr;

View File

@ -56,3 +56,4 @@
+ features/all/staging-usbip-convert-to-kthread.patch
+ features/all/ufs-remove-the-BKL.patch
+ debian/ext4-Disable-FS_IOC_FIEMAP-ioctl-temporarily.patch
+ debian/sched-autogroup-disabled.patch