aufs: Update to aufs3.10-20130826

With a minor security fix to it:
aufs: mvdown, don't let unprivileged users provoke a WARNING

svn path=/dists/sid/linux/; revision=20535
This commit is contained in:
Ben Hutchings 2013-08-31 17:52:31 +00:00
parent c72912f8a1
commit 253f2f8516
7 changed files with 1212 additions and 475 deletions

2
debian/changelog vendored
View File

@ -53,6 +53,8 @@ linux (3.10.10-1) UNRELEASED; urgency=low
- simple-wait: Fix a race condition with swait wakeups vs adding items
to the list
- rcu: Use swait_wake_all() in rcu_nocb_gp_cleanup()
* aufs: Update to aufs3.10-20130826
* aufs: mvdown, don't let unprivileged users provoke a WARNING
-- Ben Hutchings <ben@decadent.org.uk> Fri, 30 Aug 2013 02:31:22 +0100

View File

@ -0,0 +1,38 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 31 Aug 2013 18:34:51 +0100
Subject: aufs: mvdown, don't let unprivileged users provoke a WARNING
Forwarded:
Move the WARN_ONCE() about mvdown after the capability check.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
fs/aufs/ioctl.c | 1 -
fs/aufs/mvdown.c | 2 ++
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/fs/aufs/ioctl.c b/fs/aufs/ioctl.c
index 628d627..1ac7688 100644
--- a/fs/aufs/ioctl.c
+++ b/fs/aufs/ioctl.c
@@ -152,7 +152,6 @@ long aufs_ioctl_nondir(struct file *file, unsigned int cmd, unsigned long arg)
switch (cmd) {
case AUFS_CTL_MVDOWN:
- WARN_ONCE(1, "move-down is still testing...\n");
err = au_mvdown(file->f_dentry, (void __user *)arg);
break;
diff --git a/fs/aufs/mvdown.c b/fs/aufs/mvdown.c
index e68002e..5f56645 100644
--- a/fs/aufs/mvdown.c
+++ b/fs/aufs/mvdown.c
@@ -489,6 +489,8 @@ int au_mvdown(struct dentry *dentry, struct aufs_mvdown __user *uarg)
if (unlikely(!capable(CAP_SYS_ADMIN)))
goto out;
+ WARN_ONCE(1, "move-down is still testing...\n");
+
err = -ENOMEM;
args = kmalloc(sizeof(*args), GFP_NOFS);
if (unlikely(!args))

File diff suppressed because it is too large Load Diff

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Wed Jul 3 13:35:19 2013 +0900
Subject: aufs3.10 base patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/a1069fdacd4c7e2650d1616c172465c74260600f/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/20e965e7cd385ace8c9c36e64673479eeefe379e/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Wed Jul 3 13:35:19 2013 +0900
Subject: aufs3.10 kbuild patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/a1069fdacd4c7e2650d1616c172465c74260600f/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/20e965e7cd385ace8c9c36e64673479eeefe379e/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Wed Jul 3 13:35:19 2013 +0900
Subject: aufs3.10 standalone patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/a1069fdacd4c7e2650d1616c172465c74260600f/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/20e965e7cd385ace8c9c36e64673479eeefe379e/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch

View File

@ -28,6 +28,8 @@ features/all/aufs3/aufs3-add.patch
debian/aufs3-mark-as-staging.patch
# hide broken config option
debian/AUFS_PROC_MAP-is-BROKEN.patch
# security fix
features/all/aufs3/aufs-mvdown-don-t-let-unprivileged-users-provoke-a-W.patch
# Change some defaults for security reasons
features/all/sysrq-mask.patch