[mips*] io: Define ioremap_uc (fixes FTBFS)

This commit is contained in:
Ben Hutchings 2015-10-06 22:00:43 +01:00
parent 8418beadb6
commit 25353e24ef
3 changed files with 29 additions and 0 deletions

1
debian/changelog vendored
View File

@ -2,6 +2,7 @@ linux (4.3~rc3-1~exp2) UNRELEASED; urgency=medium
* [armhf] dts: Fix Makefile target for sun4i-a10-itead-iteaduino-plus
(fixes FTBFS)
* [mips*] io: Define ioremap_uc (fixes FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Tue, 06 Oct 2015 00:01:29 +0100

View File

@ -0,0 +1,27 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 6 Oct 2015 00:17:04 +0100
Subject: MIPS: io: Define ioremap_uc
Forwarded: http://mid.gmane.org/1444089416.2956.2.camel@decadent.org.uk
All architectures must now define ioremap_uc(), but MIPS currently
only has ioremap_nocache().
Fixes: 4c73e8926623 ("arch/*/io.h: Add ioremap_uc() to all architectures")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
Cc: Luis R. Rodriguez <mcgrof@suse.com>
---
arch/mips/include/asm/io.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/arch/mips/include/asm/io.h b/arch/mips/include/asm/io.h
index 9e777cd..d10fd80 100644
--- a/arch/mips/include/asm/io.h
+++ b/arch/mips/include/asm/io.h
@@ -256,6 +256,7 @@ static inline void __iomem * __ioremap_mode(phys_addr_t offset, unsigned long si
*/
#define ioremap_nocache(offset, size) \
__ioremap_mode((offset), (size), _CACHE_UNCACHED)
+#define ioremap_uc ioremap_nocache
/*
* ioremap_cachable - map bus memory into CPU space

View File

@ -83,3 +83,4 @@ features/all/grsecurity/grkernsec_perf_harden.patch
bugfix/all/media-uvcvideo-disable-hardware-timestamps-by-defaul.patch
bugfix/arm/arm-dts-fix-makefile-target-for-sun4i-a10-itead-itea.patch
bugfix/mips/mips-io-define-ioremap_uc.patch