aufs: Update for 2.6.39 (Closes: #627837)

svn path=/dists/sid/linux-2.6/; revision=17588
This commit is contained in:
Ben Hutchings 2011-06-03 05:30:22 +00:00
parent 60dacc517f
commit 23d1b96096
8 changed files with 3706 additions and 3714 deletions

1
debian/changelog vendored
View File

@ -12,6 +12,7 @@ linux-2.6 (2.6.39-2) UNRELEASED; urgency=low
'Celeron M' models do not.
* Update Swedish debconf template translation (Martin Bagge)
(Closes: #628932)
* aufs: Update for 2.6.39 (Closes: #627837)
[ maximilian attems ]
* Add stable 2.6.39.1-rc1, including:

View File

@ -1,31 +0,0 @@
Date: Thu, 24 Feb 2011 09:40:31 -0800
From: John Johansen <john.johansen@canonical.com>
Subject: [natty] Fix aufs calling of security_path_mknod
Fix aufs calling of security_path_mknod
BugLink: http://launchpad.net/bugs/724456
The security_path_mknod hook requires an encoded 'dev' for its 'dev' paramet
but aufs is calling security_path_mknod with a 'dev' that was already
converted by 'new_decode_dev(dev)'. However security_path_mknod and its
consumer TOMOYO is expecting 'dev' rather than 'new_decode_dev(dev)'.
This will result in TOMOYO doing new_decode_dev(new_decode_dev(dev))
(which is wrong) when security_path_mknod() is called from aufs' vfsub_mknod
Signed-off-by: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>
Signed-off-by: John Johansen <john.johansen@canonical.com>
[bwh: Change source paths for Debian]
--- a/fs/aufs/vfsub.c
+++ b/fs/aufs/vfsub.c
@@ -276,7 +276,7 @@ int vfsub_mknod(struct inode *dir, struct path *path, int mo
d = path->dentry;
path->dentry = d->d_parent;
- err = security_path_mknod(path, d, mode, dev);
+ err = security_path_mknod(path, d, mode, new_encode_dev(dev));
path->dentry = d;
if (unlikely(err))
goto out;

File diff suppressed because it is too large Load Diff

View File

@ -1,10 +1,10 @@
aufs2.1 base patch for linux-2.6.
diff --git a/fs/namei.c b/fs/namei.c
index 0087cf9..cd39cdf 100644
index e6cd611..27d7dc7 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1841,12 +1841,12 @@ out:
@@ -1768,7 +1768,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
* needs parent already locked. Doesn't follow mounts.
* SMP-safe.
*/
@ -13,17 +13,11 @@ index 0087cf9..cd39cdf 100644
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
-static int __lookup_one_len(const char *name, struct qstr *this,
+int __lookup_one_len(const char *name, struct qstr *this,
struct dentry *base, int len)
{
unsigned long hash;
diff --git a/fs/splice.c b/fs/splice.c
index 50a5d97..886e942 100644
index 50a5d978..886e942 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -1081,8 +1081,8 @@ EXPORT_SYMBOL_GPL(generic_splice_sendpage);
@@ -1081,8 +1081,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
/*
* Attempt to initiate a splice from pipe to file.
*/
@ -48,16 +42,14 @@ index 50a5d97..886e942 100644
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/include/linux/namei.h b/include/linux/namei.h
index f276d4f..4eb5fcb 100644
index eba45ea..21ed6c9 100644
--- a/include/linux/namei.h
+++ b/include/linux/namei.h
@@ -79,6 +79,9 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
@@ -82,6 +82,7 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry *dentry,
int (*open)(struct inode *, struct file *));
+extern struct dentry *lookup_hash(struct nameidata *nd);
+extern int __lookup_one_len(const char *name, struct qstr *this,
+ struct dentry *base, int len);
extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
extern int follow_down_one(struct path *);

View File

@ -1,10 +1,10 @@
aufs2.1 kbuild patch for linux-2.6.
diff --git a/fs/Kconfig b/fs/Kconfig
index 3db9caa..c9e1f11 100644
index f3aa9b0..d0eaf6e 100644
--- a/fs/Kconfig
+++ b/fs/Kconfig
@@ -190,6 +190,7 @@ source "fs/romfs/Kconfig"
@@ -191,6 +191,7 @@ source "fs/pstore/Kconfig"
source "fs/sysv/Kconfig"
source "fs/ufs/Kconfig"
source "fs/exofs/Kconfig"
@ -13,16 +13,16 @@ index 3db9caa..c9e1f11 100644
endif # MISC_FILESYSTEMS
diff --git a/fs/Makefile b/fs/Makefile
index a7f7cef..95dd4d3 100644
index fb68c2b..c031a85 100644
--- a/fs/Makefile
+++ b/fs/Makefile
@@ -121,3 +121,4 @@ obj-$(CONFIG_BTRFS_FS) += btrfs/
obj-$(CONFIG_GFS2_FS) += gfs2/
@@ -124,3 +124,4 @@ obj-$(CONFIG_GFS2_FS) += gfs2/
obj-$(CONFIG_EXOFS_FS) += exofs/
obj-$(CONFIG_CEPH_FS) += ceph/
obj-$(CONFIG_PSTORE) += pstore/
+obj-$(CONFIG_AUFS_FS) += aufs/
diff --git a/include/linux/Kbuild b/include/linux/Kbuild
index b0ada6f..5cb5837 100644
index 75cf611..f9f42b5 100644
--- a/include/linux/Kbuild
+++ b/include/linux/Kbuild
@@ -64,6 +64,7 @@ header-y += atmppp.h

View File

@ -1,10 +1,10 @@
aufs2.1 standalone patch for linux-2.6.
diff --git a/fs/file_table.c b/fs/file_table.c
index eb36b6b..12f2809 100644
index 01e4c1e..0e800e2 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -393,6 +393,8 @@ void file_sb_list_del(struct file *file)
@@ -443,6 +443,8 @@ void file_sb_list_del(struct file *file)
}
}
@ -14,22 +14,22 @@ index eb36b6b..12f2809 100644
/*
diff --git a/fs/inode.c b/fs/inode.c
index da85e56..b3dc5d8 100644
index 33c963d..e31e8d5 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -82,6 +82,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
* the i_state of an inode while it is in use..
*/
DEFINE_SPINLOCK(inode_lock);
+EXPORT_SYMBOL_GPL(inode_lock);
@@ -112,6 +112,7 @@ static DEFINE_SPINLOCK(inode_lru_lock);
__cacheline_aligned_in_smp DEFINE_SPINLOCK(inode_sb_list_lock);
__cacheline_aligned_in_smp DEFINE_SPINLOCK(inode_wb_list_lock);
+EXPORT_SYMBOL_GPL(inode_sb_list_lock);
/*
* iprune_sem provides exclusion between the kswapd or try_to_free_pages
* iprune_sem provides exclusion between the icache shrinking and the
diff --git a/fs/namei.c b/fs/namei.c
index cd39cdf..db4290c 100644
index 27d7dc7..3c72fd5 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -353,6 +353,7 @@ int deny_write_access(struct file * file)
@@ -364,6 +364,7 @@ int deny_write_access(struct file * file)
return 0;
}
@ -37,27 +37,19 @@ index cd39cdf..db4290c 100644
/**
* path_get - get a reference to a path
@@ -1845,6 +1846,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
@@ -1772,6 +1773,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
+EXPORT_SYMBOL_GPL(lookup_hash);
int __lookup_one_len(const char *name, struct qstr *this,
struct dentry *base, int len)
@@ -1867,6 +1869,7 @@ int __lookup_one_len(const char *name, struct qstr *this,
this->hash = end_name_hash(hash);
return 0;
}
+EXPORT_SYMBOL_GPL(__lookup_one_len);
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
index 7b0b953..b304f68 100644
index 7dba2ed..d7570d1 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -1465,6 +1465,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
@@ -1524,6 +1524,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -91,10 +83,10 @@ index d309f38..f0e9568 100644
}
+EXPORT_SYMBOL_GPL(fsnotify_alloc_group);
diff --git a/fs/notify/mark.c b/fs/notify/mark.c
index 325185e..adede09 100644
index 252ab1f..2199b9b 100644
--- a/fs/notify/mark.c
+++ b/fs/notify/mark.c
@@ -113,6 +113,7 @@ void fsnotify_put_mark(struct fsnotify_mark *mark)
@@ -112,6 +112,7 @@ void fsnotify_put_mark(struct fsnotify_mark *mark)
if (atomic_dec_and_test(&mark->refcnt))
mark->free_mark(mark);
}
@ -102,7 +94,7 @@ index 325185e..adede09 100644
/*
* Any time a mark is getting freed we end up here.
@@ -190,6 +191,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark)
@@ -189,6 +190,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark)
if (unlikely(atomic_dec_and_test(&group->num_marks)))
fsnotify_final_destroy_group(group);
}
@ -110,7 +102,7 @@ index 325185e..adede09 100644
void fsnotify_set_mark_mask_locked(struct fsnotify_mark *mark, __u32 mask)
{
@@ -277,6 +279,7 @@ err:
@@ -276,6 +278,7 @@ err:
return ret;
}
@ -118,7 +110,7 @@ index 325185e..adede09 100644
/*
* clear any marks in a group in which mark->flags & flags is true
@@ -332,6 +335,7 @@ void fsnotify_init_mark(struct fsnotify_mark *mark,
@@ -331,6 +334,7 @@ void fsnotify_init_mark(struct fsnotify_mark *mark,
atomic_set(&mark->refcnt, 1);
mark->free_mark = free_mark;
}
@ -127,7 +119,7 @@ index 325185e..adede09 100644
static int fsnotify_mark_destroy(void *ignored)
{
diff --git a/fs/open.c b/fs/open.c
index 5a2c6eb..f0fa5b2 100644
index b52cf01..c1b341c 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -60,6 +60,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
@ -159,10 +151,10 @@ index 886e942..9a77a3e 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/security/commoncap.c b/security/commoncap.c
index 64c2ed9..e58b5d8 100644
index f20e984..d39acd9 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -929,3 +929,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
@@ -976,3 +976,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
}
return ret;
}
@ -180,18 +172,10 @@ index 8d9c48f..29108aa 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
index 7b7308a..140afc7 100644
index 1011423..3bb850b 100644
--- a/security/security.c
+++ b/security/security.c
@@ -359,6 +359,7 @@ int security_path_mkdir(struct path *dir, struct dentry *dentry, int mode)
return 0;
return security_ops->path_mkdir(dir, dentry, mode);
}
+EXPORT_SYMBOL_GPL(security_path_mkdir);
int security_path_rmdir(struct path *dir, struct dentry *dentry)
{
@@ -366,6 +367,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
@@ -373,6 +373,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
return 0;
return security_ops->path_rmdir(dir, dentry);
}
@ -199,15 +183,7 @@ index 7b7308a..140afc7 100644
int security_path_unlink(struct path *dir, struct dentry *dentry)
{
@@ -373,6 +375,7 @@ int security_path_unlink(struct path *dir, struct dentry *dentry)
return 0;
return security_ops->path_unlink(dir, dentry);
}
+EXPORT_SYMBOL_GPL(security_path_unlink);
int security_path_symlink(struct path *dir, struct dentry *dentry,
const char *old_name)
@@ -381,6 +384,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
@@ -389,6 +390,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
return 0;
return security_ops->path_symlink(dir, dentry, old_name);
}
@ -215,7 +191,7 @@ index 7b7308a..140afc7 100644
int security_path_link(struct dentry *old_dentry, struct path *new_dir,
struct dentry *new_dentry)
@@ -389,6 +393,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
@@ -397,6 +399,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
return 0;
return security_ops->path_link(old_dentry, new_dir, new_dentry);
}
@ -223,15 +199,7 @@ index 7b7308a..140afc7 100644
int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
struct path *new_dir, struct dentry *new_dentry)
@@ -399,6 +404,7 @@ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
return security_ops->path_rename(old_dir, old_dentry, new_dir,
new_dentry);
}
+EXPORT_SYMBOL_GPL(security_path_rename);
int security_path_truncate(struct path *path)
{
@@ -406,6 +412,7 @@ int security_path_truncate(struct path *path)
@@ -415,6 +418,7 @@ int security_path_truncate(struct path *path)
return 0;
return security_ops->path_truncate(path);
}
@ -239,7 +207,7 @@ index 7b7308a..140afc7 100644
int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
mode_t mode)
@@ -414,6 +421,7 @@ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
@@ -423,6 +427,7 @@ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
return 0;
return security_ops->path_chmod(dentry, mnt, mode);
}
@ -247,7 +215,7 @@ index 7b7308a..140afc7 100644
int security_path_chown(struct path *path, uid_t uid, gid_t gid)
{
@@ -421,6 +429,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
@@ -430,6 +435,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
return 0;
return security_ops->path_chown(path, uid, gid);
}
@ -255,7 +223,7 @@ index 7b7308a..140afc7 100644
int security_path_chroot(struct path *path)
{
@@ -497,6 +506,7 @@ int security_inode_readlink(struct dentry *dentry)
@@ -506,6 +512,7 @@ int security_inode_readlink(struct dentry *dentry)
return 0;
return security_ops->inode_readlink(dentry);
}
@ -263,15 +231,15 @@ index 7b7308a..140afc7 100644
int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
{
@@ -511,6 +521,7 @@ int security_inode_permission(struct inode *inode, int mask)
@@ -520,6 +527,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return security_ops->inode_permission(inode, mask);
return security_ops->inode_permission(inode, mask, 0);
}
+EXPORT_SYMBOL_GPL(security_inode_permission);
int security_inode_exec_permission(struct inode *inode, unsigned int flags)
{
@@ -619,6 +630,7 @@ int security_file_permission(struct file *file, int mask)
@@ -628,6 +636,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@ -279,7 +247,7 @@ index 7b7308a..140afc7 100644
int security_file_alloc(struct file *file)
{
@@ -646,6 +658,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
@@ -655,6 +664,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
return ret;
return ima_file_mmap(file, prot);
}

View File

@ -4,3 +4,9 @@
+ features/all/rt2800usb-Add-seven-new-USB-IDs.patch
+ features/all/rt2x00-Linksys-WUSB600N-rev2-is-a-RT3572-device.patch
+ bugfix/all/stable/2.6.39.1-rc1
+ features/all/aufs2/aufs2-base.patch
+ features/all/aufs2/aufs2-standalone.patch
+ features/all/aufs2/aufs2-kbuild.patch
+ features/all/aufs2/aufs2-add.patch
+ features/all/aufs2/mark-as-staging.patch

View File

@ -14,8 +14,6 @@
#+ features/all/aufs2/aufs2-add.patch
# mark as staging/crap
#+ features/all/aufs2/mark-as-staging.patch
# fix not upstream yet
#+ features/all/aufs2/Fix-aufs-calling-of-security_path_mknod.patch
+ bugfix/ia64/hardcode-arch-script-output.patch
+ bugfix/mips/disable-advansys.patch