[sh] Fix up store queue code for subsys_interface changes (Closes: #680025)

svn path=/dists/sid/linux/; revision=19236
This commit is contained in:
Ben Hutchings 2012-07-03 05:03:29 +00:00
parent 74ce5845ea
commit 230325e109
3 changed files with 51 additions and 0 deletions

1
debian/changelog vendored
View File

@ -2,6 +2,7 @@ linux (3.2.21-4) UNRELEASED; urgency=low
* linux-libc-dev: Fix redundant 'GNU glibc' in description (Closes: #631228)
* README.source: Correct name of main patch series file
* [sh] Fix up store queue code for subsys_interface changes (Closes: #680025)
-- Ben Hutchings <ben@decadent.org.uk> Fri, 29 Jun 2012 15:01:22 +0100

View File

@ -0,0 +1,49 @@
From: Paul Mundt <lethal@linux-sh.org>
Date: Tue, 10 Jan 2012 16:24:11 +0900
Subject: sh: Fix up store queue code for subsys_interface changes.
commit 33dc5c1000c193084a70ffd8f3bd9c67d19f9159 upstream.
Fixes up a number of build and section mismatch errors introduced by the
subsys_interface conversion.
Signed-off-by: Paul Mundt <lethal@linux-sh.org>
---
arch/sh/kernel/cpu/sh4/sq.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/arch/sh/kernel/cpu/sh4/sq.c b/arch/sh/kernel/cpu/sh4/sq.c
index a8140f0..0a47bd3 100644
--- a/arch/sh/kernel/cpu/sh4/sq.c
+++ b/arch/sh/kernel/cpu/sh4/sq.c
@@ -337,7 +337,7 @@ static struct kobj_type ktype_percpu_entry = {
.default_attrs = sq_sysfs_attrs,
};
-static int __devinit sq_dev_add(struct device *dev)
+static int sq_dev_add(struct device *dev, struct subsys_interface *sif)
{
unsigned int cpu = dev->id;
struct kobject *kobj;
@@ -355,7 +355,7 @@ static int __devinit sq_dev_add(struct device *dev)
return error;
}
-static int __devexit sq_dev_remove(struct device *dev)
+static int sq_dev_remove(struct device *dev, struct subsys_interface *sif)
{
unsigned int cpu = dev->id;
struct kobject *kobj = sq_kobject[cpu];
@@ -365,10 +365,10 @@ static int __devexit sq_dev_remove(struct device *dev)
}
static struct subsys_interface sq_interface = {
- .name = "sq"
+ .name = "sq",
.subsys = &cpu_subsys,
.add_dev = sq_dev_add,
- .remove_dev = __devexit_p(sq_dev_remove),
+ .remove_dev = sq_dev_remove,
};
static int __init sq_api_init(void)

View File

@ -348,6 +348,7 @@ features/all/cpu-devices/Partially-revert-cpufreq-Add-support-for-x86-cpuinfo.pa
features/all/cpu-devices/cpufreq-gx-Fix-the-compile-error.patch
features/all/cpu-devices/tracing-mm-Move-include-of-trace-events-kmem.h-out-o.patch
features/all/cpu-devices/driver-core-remove-__must_check-from-device_create_f.patch
features/all/cpu-devices/sh-Fix-up-store-queue-code-for-subsys_interface-chan.patch
features/arm/kirkwood-add-dreamplug-fdt-support.patch
features/arm/kirkwood-fdt-convert-uart0-to-devicetree.patch