aufs: Update support patchset to aufs4.15-20180219 (no functional change)

This commit is contained in:
Ben Hutchings 2018-02-22 19:26:49 +01:00
parent 809a0521f8
commit 22f6a669a8
4 changed files with 31 additions and 30 deletions

1
debian/changelog vendored
View File

@ -7,6 +7,7 @@ linux (4.15.4-2) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* aufs: gen-patch: Fix Subject generation to skip SPDX-License-Identifier
* aufs: Update support patchset to aufs4.15-20180219 (no functional change)
-- Salvatore Bonaccorso <carnil@debian.org> Tue, 20 Feb 2018 21:51:39 +0100

View File

@ -1,19 +1,19 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat Dec 16 15:29:33 2017 +0900
Subject: SPDX-License-Identifier: GPL-2.0
Origin: https://github.com/sfjro/aufs4-standalone/tree/8b9c1be851f351af1104f55952e211ae541695ee
Date: Sun Feb 18 15:24:12 2018 +0900
Subject: aufs4.15 base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/caea84a33dce187ad77f9ee524d7ec46acc69c63
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.x-rcN base patch
aufs4.15 base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 82ad0ea..7d8b461 100644
index 845fc25..7dc2813 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2478,6 +2478,19 @@ F: include/linux/audit.h
@@ -2486,6 +2486,19 @@ F: include/linux/audit.h
F: include/uapi/linux/audit.h
F: kernel/audit*
@ -34,7 +34,7 @@ index 82ad0ea..7d8b461 100644
M: Miguel Ojeda Sandonis <miguel.ojeda.sandonis@gmail.com>
W: http://miguelojeda.es/auxdisplay.htm
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index bc8e615..e51a59d 100644
index d5fe720..c292afa 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -691,6 +691,24 @@ static inline int is_loop_device(struct file *file)
@ -111,7 +111,7 @@ index 03102d6..517883c 100644
int (*update_time)(struct inode *, struct timespec *, int);
diff --git a/fs/namespace.c b/fs/namespace.c
index e158ec6..312bdbd8 100644
index 9d1374a..26ef600 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -846,6 +846,12 @@ static inline int check_mnt(struct mount *mnt)
@ -263,10 +263,10 @@ index 511fbaa..96e05b3 100644
extern const struct file_operations def_blk_fops;
extern const struct file_operations def_chr_fops;
diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h
index a842551..453e941 100644
index 3251d9c..0360952 100644
--- a/include/linux/lockdep.h
+++ b/include/linux/lockdep.h
@@ -406,6 +406,8 @@ static inline int lockdep_match_key(struct lockdep_map *lock,
@@ -313,6 +313,8 @@ static inline int lockdep_match_key(struct lockdep_map *lock,
return lock->key == key;
}
@ -275,7 +275,7 @@ index a842551..453e941 100644
/*
* Acquire a lock.
*
@@ -535,6 +537,7 @@ struct lockdep_map { };
@@ -442,6 +444,7 @@ struct lockdep_map { };
#define lockdep_depth(tsk) (0)
@ -318,10 +318,10 @@ index 74b4911..19789fb 100644
+ unsigned int flags);
#endif
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index 670d8d7..2cd0282 100644
index 5216590..8b5f44d 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -156,7 +156,7 @@ static struct lock_list list_entries[MAX_LOCKDEP_ENTRIES];
@@ -140,7 +140,7 @@ static struct lock_list list_entries[MAX_LOCKDEP_ENTRIES];
unsigned long nr_lock_classes;
static struct lock_class lock_classes[MAX_LOCKDEP_KEYS];
@ -330,7 +330,7 @@ index 670d8d7..2cd0282 100644
{
if (!hlock->class_idx) {
/*
@@ -167,6 +167,7 @@ static inline struct lock_class *hlock_class(struct held_lock *hlock)
@@ -151,6 +151,7 @@ static inline struct lock_class *hlock_class(struct held_lock *hlock)
}
return lock_classes + hlock->class_idx - 1;
}

View File

@ -1,13 +1,13 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat Dec 16 15:29:33 2017 +0900
Subject: SPDX-License-Identifier: GPL-2.0
Origin: https://github.com/sfjro/aufs4-standalone/tree/8b9c1be851f351af1104f55952e211ae541695ee
Date: Sun Feb 18 15:24:12 2018 +0900
Subject: aufs4.15 mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/caea84a33dce187ad77f9ee524d7ec46acc69c63
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.x-rcN mmap patch
aufs4.15 mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index 60316b5..ce5314e 100644
@ -133,7 +133,7 @@ index cfd0ac4..135e11c 100644
atomic_long_t swap_readahead_info;
diff --git a/kernel/fork.c b/kernel/fork.c
index 432eadf..8b2ba5b 100644
index 2295fc6..80e1fee 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -676,7 +676,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
@ -172,7 +172,7 @@ index ee83baa..7677d13 100644
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/mmap.c b/mm/mmap.c
index a4d5468..cb06cbd 100644
index 9efdc021..d77f01f 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -171,7 +171,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)

View File

@ -1,13 +1,13 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat Dec 16 15:29:33 2017 +0900
Subject: SPDX-License-Identifier: GPL-2.0
Origin: https://github.com/sfjro/aufs4-standalone/tree/8b9c1be851f351af1104f55952e211ae541695ee
Date: Sun Feb 18 15:24:12 2018 +0900
Subject: aufs4.15 standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/caea84a33dce187ad77f9ee524d7ec46acc69c63
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.x-rcN standalone patch
aufs4.15 standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index 019f14b..10c1a6d 100644
@ -30,7 +30,7 @@ index 019f14b..10c1a6d 100644
/**
* d_ancestor - search for an ancestor
diff --git a/fs/exec.c b/fs/exec.c
index 6be2aa0..1e003f9 100644
index 7eb8d21..56d7985 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -109,6 +109,7 @@ bool path_noexec(const struct path *path)
@ -102,7 +102,7 @@ index 517883c..5cece5e 100644
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index 312bdbd8..a5baeb5 100644
index 26ef600..a4b9707 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -517,6 +517,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
@ -302,10 +302,10 @@ index 61cd28b..35570cd 100644
ssize_t
__vfs_getxattr(struct dentry *dentry, struct inode *inode, const char *name,
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index 2cd0282..af59768 100644
index 8b5f44d..979db63 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -167,6 +167,7 @@ inline struct lock_class *lockdep_hlock_class(struct held_lock *hlock)
@@ -151,6 +151,7 @@ inline struct lock_class *lockdep_hlock_class(struct held_lock *hlock)
}
return lock_classes + hlock->class_idx - 1;
}
@ -323,10 +323,10 @@ index 0fef395..83fb1ec 100644
}
+EXPORT_SYMBOL_GPL(task_work_run);
diff --git a/security/commoncap.c b/security/commoncap.c
index 4f8e093..f1e0544 100644
index 48620c9..4981104 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -1333,12 +1333,14 @@ int cap_mmap_addr(unsigned long addr)
@@ -1330,12 +1330,14 @@ int cap_mmap_addr(unsigned long addr)
}
return ret;
}