[i386] cpufreq/gx: Fix the compile error

svn path=/dists/sid/linux/; revision=19184
This commit is contained in:
Ben Hutchings 2012-06-23 19:19:24 +00:00
parent 7cd8a087b6
commit 221e81adfe
3 changed files with 35 additions and 0 deletions

6
debian/changelog vendored
View File

@ -1,3 +1,9 @@
linux (3.2.21-2) UNRELEASED; urgency=low
* [i386] cpufreq/gx: Fix the compile error
-- Ben Hutchings <ben@decadent.org.uk> Sat, 23 Jun 2012 20:19:15 +0100
linux (3.2.21-1) unstable; urgency=low
* New upstream stable update:

View File

@ -0,0 +1,28 @@
From: Alan Cox <alan@linux.intel.com>
Date: Mon, 30 Jan 2012 14:47:28 +0000
Subject: cpufreq/gx: Fix the compile error
commit b3012e12cdc5825f93367cc6294419e7ab1f00cc upstream.
Someone forgot to test this one it seems.
Signed-off-by: Alan Cox <alan@linux.intel.com>
Acked-by: Andi Kleen <ak@linux.intel.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
---
drivers/cpufreq/gx-suspmod.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/cpufreq/gx-suspmod.c b/drivers/cpufreq/gx-suspmod.c
index 5a06c0b..456bee0 100644
--- a/drivers/cpufreq/gx-suspmod.c
+++ b/drivers/cpufreq/gx-suspmod.c
@@ -172,7 +172,7 @@ static struct pci_device_id gx_chipset_tbl[] __initdata = {
{ PCI_VDEVICE(CYRIX, PCI_DEVICE_ID_CYRIX_5510), },
{ 0, },
};
-MODULE_DEVICE_TABLE(gx_chipset_tbl);
+MODULE_DEVICE_TABLE(pci, gx_chipset_tbl);
static void gx_write_byte(int reg, int value)
{

View File

@ -340,6 +340,7 @@ features/all/cpu-devices/powernow-k7-Fix-CPU-family-number.patch
features/all/cpu-devices/powernow-k6-Really-enable-auto-loading.patch
features/all/cpu-devices/intel_idle-Revert-change-of-auto_demotion_disable_fl.patch
features/all/cpu-devices/Partially-revert-cpufreq-Add-support-for-x86-cpuinfo.patch
features/all/cpu-devices/cpufreq-gx-Fix-the-compile-error.patch
features/arm/kirkwood-add-dreamplug-fdt-support.patch
features/arm/kirkwood-fdt-convert-uart0-to-devicetree.patch