Update to 4.18.7

This updates the debian changelog for listing changes of this stable
update. It also removes patches that have been applied upstream.
This commit is contained in:
Romain Perier 2018-09-11 19:44:08 +02:00 committed by Ben Hutchings
parent a4453abd32
commit 21f4f386c3
3 changed files with 145 additions and 46 deletions

146
debian/changelog vendored
View File

@ -1,4 +1,148 @@
linux (4.18.6-2) UNRELEASED; urgency=medium
linux (4.18.7-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.18.7
- rcu: Make expedited GPs handle CPU 0 being offline
- net: 6lowpan: fix reserved space for single frames
- net: mac802154: tx: expand tailroom if necessary
- 9p/net: Fix zero-copy path in the 9p virtio transport
- spi: pxa2xx: Add support for Intel Ice Lake
- spi: spi-fsl-dspi: Fix imprecise abort on VF500 during probe
- spi: cadence: Change usleep_range() to udelay(), for atomic context
- mmc: block: Fix unsupported parallel dispatch of requests
- readahead: stricter check for bdi io_pages
- block: fix infinite loop if the device loses discard capability
- block: blk_init_allocated_queue() set q->fq as NULL in the fail case
- block: really disable runtime-pm for blk-mq
- blkcg: Introduce blkg_root_lookup()
- block: Introduce blk_exit_queue()
- block: Ensure that a request queue is dissociated from the cgroup
controller
- apparmor: fix bad debug check in apparmor_secid_to_secctx()
- dma-buf: Move BUG_ON from _add_shared_fence to _add_shared_inplace
- libertas: fix suspend and resume for SDIO connected cards
- media: Revert "[media] tvp5150: fix pad format frame height"
- mailbox: xgene-slimpro: Fix potential NULL pointer dereference
- Replace magic for trusting the secondary keyring with #define
- Fix kexec forbidding kernels signed with keys in the secondary keyring to
boot
- [powerpc*] fadump: handle crash memory ranges array index overflow
- [powerpc*] 64s: Fix page table fragment refcount race vs speculative
references
- [powerpc*] pseries: Fix endianness while restoring of r3 in MCE handler.
- [powerpc*] pkeys: Give all threads control of their key permissions
- [powerpc*] pkeys: Deny read/write/execute by default
- [powerpc*] pkeys: key allocation/deallocation must not change pkey
registers
- [powerpc*] pkeys: Save the pkey registers before fork
- [powerpc*] pkeys: Fix calculation of total pkeys.
- [powerpc*] pkeys: Preallocate execute-only key
- [powerpc*] nohash: fix pte_access_permitted()
- [powerpc64] ftrace: Include ftrace.h needed for enable/disable calls
- [powerpc*] powernv/pci: Work around races in PCI bridge enabling
- cxl: Fix wrong comparison in cxl_adapter_context_get()
- ocxl: Fix page fault handler in case of fault on dying process
- IB/mlx5: Honor cnt_set_id_valid flag instead of set_id
- IB/mlx5: Fix leaking stack memory to userspace
- IB/srpt: Fix srpt_cm_req_recv() error path (1/2)
- IB/srpt: Fix srpt_cm_req_recv() error path (2/2)
- IB/srpt: Support HCAs with more than two ports
- RDMA/mlx5: Fix shift overflow in mlx5_ib_create_wq
- ib_srpt: Fix a use-after-free in srpt_close_ch()
- ib_srpt: Fix a use-after-free in __srpt_close_all_ch()
- RDMA/rxe: Set wqe->status correctly if an unexpected response is received
- 9p: fix multiple NULL-pointer-dereferences
- fs/9p/xattr.c: catch the error of p9_client_clunk when setting xattr
failed
- 9p/virtio: fix off-by-one error in sg list bounds check
- net/9p/client.c: version pointer uninitialized
- net/9p/trans_fd.c: fix race-condition by flushing workqueue before the
kfree()
- dm integrity: change 'suspending' variable from bool to int
- dm thin: stop no_space_timeout worker when switching to write-mode
- dm cache metadata: save in-core policy_hint_size to on-disk superblock
- dm cache metadata: set dirty on all cache blocks after a crash
- dm crypt: don't decrease device limits
- dm writecache: fix a crash due to reading past end of dirty_bitmap
- uart: fix race between uart_put_char() and uart_shutdown()
- Drivers: hv: vmbus: Fix the offer_in_progress in vmbus_process_offer()
- Drivers: hv: vmbus: Reset the channel callback in vmbus_onoffer_rescind()
- iio: ad9523: Fix displayed phase
- iio: ad9523: Fix return value for ad952x_store()
- extcon: Release locking when sending the notification of connector state
- vmw_balloon: fix inflation of 64-bit GFNs
- vmw_balloon: do not use 2MB without batching
- vmw_balloon: VMCI_DOORBELL_SET does not check status
- vmw_balloon: fix VMCI use when balloon built into kernel
- [armhf] rtc: omap: fix resource leak in registration error path
- [armhf] rtc: omap: fix potential crash on power off
- tracing: Do not call start/stop() functions when tracing_on does not
change
- tracing/blktrace: Fix to allow setting same value
- printk/tracing: Do not trace printk_nmi_enter()
- livepatch: Validate module/old func name length
- uprobes: Use synchronize_rcu() not synchronize_sched()
- mfd: hi655x: Fix regmap area declared size for hi655x
- ovl: fix wrong use of impure dir cache in ovl_iterate()
- [x86, arm64] ACPICA: AML Parser: skip opcodes that open a scope upon parse
failure
- [x86, arm64] ACPICA: Clear status of all events when entering sleep states
- drivers/block/zram/zram_drv.c: fix bug storing backing_dev
- sched: idle: Avoid retaining the tick when it has been stopped
- cpuidle: menu: Handle stopped tick more aggressively
- cpufreq: governor: Avoid accessing invalid governor_data
- PM / sleep: wakeup: Fix build error caused by missing SRCU support
- ALSA: ac97: fix device initialization in the compat layer
- ALSA: ac97: fix check of pm_runtime_get_sync failure
- ALSA: ac97: fix unbalanced pm_runtime_enable
- [x86, arm64] i2c: designware: Re-init controllers with pm_disabled set on
resume
- [x86] KVM: VMX: fixes for vmentry_l1d_flush module parameter
- [powerpc*] KVM: Book3S: Fix guest DMA when guest partially backed by
THP pages
- block, bfq: return nbytes and not zero from struct cftype .write() method
- pnfs/blocklayout: off by one in bl_map_stripe()
- nfsd: fix leaked file lock with nfs exported overlayfs
- NFSv4 client live hangs after live data migration recovery
- NFSv4: Fix locking in pnfs_generic_recover_commit_reqs
- NFSv4: Fix a sleep in atomic context in nfs4_callback_sequence()
- [armhf] ARM: dts: am57xx-idk: Enable dual role for USB2 port
- [armhf] pwm: omap-dmtimer: Return -EPROBE_DEFER if no dmtimer platform
data
- mm/tlb: Remove tlb_remove_table() non-concurrent condition
- [x86] iommu/vt-d: Add definitions for PFSID
- [x86] iommu/vt-d: Fix dev iotlb pfsid use
- sys: don't hold uts_sem while accessing userspace memory
- ubifs: Fix memory leak in lprobs self-check
- Revert "UBIFS: Fix potential integer overflow in allocation"
- ubifs: Check data node size before truncate
- ubifs: xattr: Don't operate on deleted inodes
- ubifs: Fix directory size calculation for symlinks
- ubifs: Fix synced_i_size calculation for xattr inodes
- [armhf] pwm: tiehrpwm: Don't use emulation mode bits to control PWM output
- [armhf] pwm: tiehrpwm: Fix disabling of output of PWMs
- fb: fix lost console when the user unplugs a USB adapter
- udlfb: fix semaphore value leak
- udlfb: fix display corruption of the last line
- udlfb: don't switch if we are switching to the same videomode
- udlfb: set optimal write delay
- udlfb: make a local copy of fb_ops
- udlfb: handle allocation failure
- udlfb: set line_length in dlfb_ops_set_par
- getxattr: use correct xattr length
- libnvdimm: Use max contiguous area for namespace size
- libnvdimm: fix ars_status output length calculation
- bcache: release dc->writeback_lock properly in bch_writeback_thread()
- cap_inode_getsecurity: use d_find_any_alias() instead of d_find_alias()
- mm, dev_pagemap: Do not clear ->mapping on final put
- perf auxtrace: Fix queue resize
- [x86] crypto: vmx - Fix sleep-in-atomic bugs
- [x86] crypto: aesni - Use unaligned loads from gcm_context_data
- [arm64] crypto: arm64/sm4-ce - check for the right CPU feature bit
- fs/quota: Fix spectre gadget in do_quotactl
- udf: Fix mounting of Win7 created UDF filesystems
- cpuidle: menu: Retain tick when shallow state is selected
- [arm64] mm: always enable CONFIG_HOLES_IN_ZONE
[ Ben Hutchings ]
* [x86] wireless: Enable R8822BE as module (Closes: #908330)

View File

@ -1,44 +0,0 @@
From: Ming Lei <ming.lei@redhat.com>
Subject: block: really disable runtime-pm for blk-mq
Date: Mon, 30 Jul 2018 20:02:19 +0800
Origin: https://patchwork.kernel.org/patch/10548975/
Bug-Debian: https://bugs.debian.org/904441
Runtime PM isn't ready for blk-mq yet, and commit 765e40b675a9 ("block:
disable runtime-pm for blk-mq") tried to disable it. Unfortunately,
it can't take effect in that way since user space still can switch
it on via 'echo auto > /sys/block/sdN/device/power/control'.
This patch disables runtime-pm for blk-mq really by pm_runtime_disable()
and fixes all kinds of PM related kernel crash.
Cc: Christoph Hellwig <hch@lst.de>
Cc: Patrick Steinhardt <ps@pks.im>
Cc: Bart Van Assche <Bart.VanAssche@wdc.com>
Cc: Tomas Janousek <tomi@nomi.cz>
Cc: Przemek Socha <soprwa@gmail.com>
Cc: Alan Stern <stern@rowland.harvard.edu>
Cc: <stable@vger.kernel.org>
Signed-off-by: Ming Lei <ming.lei@redhat.com>
Reviewed-by: Bart Van Assche <bart.vanassche@wdc.com>
Reviewed-by: Christoph Hellwig <hch@lst.de>
---
block/blk-core.c | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
--- a/block/blk-core.c
+++ b/block/blk-core.c
@@ -3784,9 +3784,11 @@ EXPORT_SYMBOL(blk_finish_plug);
*/
void blk_pm_runtime_init(struct request_queue *q, struct device *dev)
{
- /* not support for RQF_PM and ->rpm_status in blk-mq yet */
- if (q->mq_ops)
+ /* Don't enable runtime PM for blk-mq until it is ready */
+ if (q->mq_ops) {
+ pm_runtime_disable(dev);
return;
+ }
q->dev = dev;
q->rpm_status = RPM_ACTIVE;

View File

@ -97,7 +97,6 @@ bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
debian/revert-objtool-fix-config_stack_validation-y-warning.patch
bugfix/all/i40e-build-for-64-bit-targets-only.patch
bugfix/all/netfilter-ipvs-Fix-invalid-bytes-in-IP_VS_MH_TAB_IND.patch
bugfix/all/block-really-disable-runtime-pm-for-blk-mq.patch
bugfix/all/mac80211-don-t-update-the-PM-state-of-a-peer-upon-a-.patch
# Miscellaneous features