Add stable 2.6.32.15

Reverts two bogus changes, one of which we already reverted and one in code
that we don't build.

svn path=/dists/sid/linux-2.6/; revision=15822
This commit is contained in:
Ben Hutchings 2010-06-02 03:03:01 +00:00
parent 37731eba5d
commit 219331eabc
3 changed files with 38 additions and 0 deletions

4
debian/changelog vendored
View File

@ -1,8 +1,12 @@
linux-2.6 (2.6.32-16) UNRELEASED; urgency=low
[ dann frazier ]
* [hppa] clear floating point exception flag on SIGFPE signal
(Closes: #559406)
[ Ben Hutchings ]
* Add stable 2.6.32.15
-- dann frazier <dannf@debian.org> Tue, 01 Jun 2010 09:23:57 -0600
linux-2.6 (2.6.32-15) unstable; urgency=low

View File

@ -0,0 +1,32 @@
diff --git a/Makefile b/Makefile
index 47866f8..36fead3 100644
diff --git a/kernel/lockdep.c b/kernel/lockdep.c
index f672d51..9af5672 100644
--- a/kernel/lockdep.c
+++ b/kernel/lockdep.c
@@ -591,9 +591,9 @@ static int static_obj(void *obj)
* percpu var?
*/
for_each_possible_cpu(i) {
- start = (unsigned long) per_cpu_ptr(&__per_cpu_start, i);
- end = (unsigned long) per_cpu_ptr(&__per_cpu_start, i)
- + PERCPU_ENOUGH_ROOM;
+ start = (unsigned long) &__per_cpu_start + per_cpu_offset(i);
+ end = (unsigned long) &__per_cpu_start + PERCPU_ENOUGH_ROOM
+ + per_cpu_offset(i);
if ((addr >= start) && (addr < end))
return 1;
diff --git a/kernel/module.c b/kernel/module.c
index a4aae35..dfa33e8 100644
--- a/kernel/module.c
+++ b/kernel/module.c
@@ -555,7 +555,7 @@ static void percpu_modcopy(void *pcpudest, const void *from, unsigned long size)
int cpu;
for_each_possible_cpu(cpu)
- memcpy(per_cpu_ptr(pcpudest, cpu), from, size);
+ memcpy(pcpudest + per_cpu_offset(cpu), from, size);
}
#else /* ... !CONFIG_SMP */

View File

@ -1 +1,3 @@
+ bugfix/parisc/clear-fp-exception-flag-on-SIGFPE.patch
- bugfix/all/revert-percpu-stable-changes-2.patch
+ bugfix/all/stable/2.6.32.15.patch