Export symbol for MOL again.

* debian/changelog: Update.
* debian/patches/bugfix/powerpc/mm-mol.patch: Add.
* debian/patches/series/1~experimental.1: Add new patch.

svn path=/dists/trunk/linux-2.6/; revision=11886
This commit is contained in:
Bastian Blank 2008-07-23 16:47:38 +00:00
parent ac797b278e
commit 216f7e5748
3 changed files with 14 additions and 0 deletions

1
debian/changelog vendored
View File

@ -121,6 +121,7 @@ linux-2.6 (2.6.26-1~experimental.1) UNRELEASED; urgency=low
* Bump yaird dependencies to at least 0.0.13.
* Reenable SECCOMP. There is no longer additional overhead.
(closes: #474648)
* Export symbol required for MOL again. (closes: #460667)
[ Christian T. Steigies ]
* [m68k] enable SERIAL_CONSOLE for amiga and atari

View File

@ -0,0 +1,12 @@
diff --git a/arch/powerpc/kernel/ppc_ksyms.c b/arch/powerpc/kernel/ppc_ksyms.c
index c6b1aa3..455fb38 100644
--- a/arch/powerpc/kernel/ppc_ksyms.c
+++ b/arch/powerpc/kernel/ppc_ksyms.c
@@ -189,6 +189,7 @@ EXPORT_SYMBOL(set_context);
extern long mol_trampoline;
EXPORT_SYMBOL(mol_trampoline); /* For MOL */
EXPORT_SYMBOL(flush_hash_pages); /* For MOL */
+EXPORT_SYMBOL(handle_mm_fault); /* For MOL */
#ifdef CONFIG_SMP
extern int mmu_hash_lock;
EXPORT_SYMBOL(mmu_hash_lock); /* For MOL */

View File

@ -55,3 +55,4 @@
#+ features/all/0001-iwlwifi-Set-monitor-mode-for-3945.patch
+ features/all/xen/tip-x86.patch
+ bugfix/all/x86-acpi-sleep-x61s.patch
+ bugfix/powerpc/mm-mol.patch