Resolve remaining ABI changes

Restore a #include dropped from fs/proc/generic.c which perturbed genksyms.

Ignore the removal of exported static functions from
snd-hda-controller which shouldn't be used OOT (they were only ever
meant for use by other modules in that directory).

svn path=/dists/sid/linux/; revision=22486
This commit is contained in:
Ben Hutchings 2015-04-06 23:34:58 +00:00
parent 2669f99824
commit 1ec90dfaed
4 changed files with 26 additions and 0 deletions

1
debian/changelog vendored
View File

@ -198,6 +198,7 @@ linux (3.16.7-ckt9-1) UNRELEASED; urgency=medium
* [x86] Disable X86_VERBOSE_BOOTUP (Closes: #781953)
* eMMC: Don't initialize partitions on RPMB flagged areas (Closes: #782038)
* [x86] powercap / RAPL: change domain detection message (Closes: #781418)
* procfs: Avoid ABI change in 3.16.7-ckt8
-- Ian Campbell <ijc@debian.org> Wed, 18 Mar 2015 21:07:15 +0000

View File

@ -7,6 +7,11 @@ ignore-changes:
module:drivers/net/wireless/iwlwifi/iwlwifi
module:sound/i2c/other/snd-ak4113
module:sound/i2c/other/snd-ak4114
azx_alloc_cmd_io
azx_free_cmd_io
azx_get_response
azx_init_cmd_io
azx_send_cmd
# Apparently not used OOT
__add_pages
__remove_pages

View File

@ -0,0 +1,18 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 07 Apr 2015 00:20:38 +0100
Subject: procfs: Avoid ABI change in 3.16.7-ckt8
genksyms is perturbed by removing this #include even though none of
its definitions are needed by exported functions...
---
--- a/fs/proc/generic.c
+++ b/fs/proc/generic.c
@@ -19,6 +19,7 @@
#include <linux/mount.h>
#include <linux/init.h>
#include <linux/idr.h>
+#include <linux/namei.h>
#include <linux/bitops.h>
#include <linux/spinlock.h>
#include <linux/completion.h>

View File

@ -575,3 +575,5 @@ bugfix/x86/drm-i915-add-limited-color-range-readout-for-hdmi-dp.patch
bugfix/all/hid-thingm-fix-workqueue-race-on-remove.patch
debian/emmc-don-t-initialize-partitions-on-rpmb-flagged-areas.patch
bugfix/x86/powercap-rapl-change-domain-detection-message.patch
debian/procfs-avoid-abi-change-in-3.16.7-ckt8.patch