Update to 4.19.118

Cleanup debian/changelog file

Refresh "firmware: Remove redundant log messages from drivers" for context changes in 4.19.118
This commit is contained in:
Salvatore Bonaccorso 2020-04-23 10:58:20 +02:00
parent 37343cff01
commit 1e0b8b17f3
2 changed files with 60 additions and 11 deletions

54
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.19.117-1) UNRELEASED; urgency=medium
linux (4.19.118-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.99
@ -1746,6 +1746,56 @@ linux (4.19.117-1) UNRELEASED; urgency=medium
- wil6210: make sure Rx ring sizes are correlated
- wil6210: remove reset file from debugfs
- mm/vmalloc.c: move 'area->pages' after if statement
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.118
- [armel,armhf] bpf: Fix offset overflow for BPF_MEM BPF_DW
- scsi: sg: add sg_remove_request in sg_common_write
- ext4: use non-movable memory for superblock readahead
- [arm64,armhf] watchdog: sp805: fix restart handler
- [armel,armhf] arm, bpf: Fix bugs with ALU64 {RSH, ARSH} BPF_K shift by 0
- netfilter: nf_tables: report EOPNOTSUPP on unsupported flags/object type
- [arm64] irqchip/mbigen: Free msi_desc on device teardown
- ALSA: hda: Don't release card at firmware loading error
- of: overlay: kmemleak in dup_and_fixup_symbol_prop()
- [x86] Hyper-V: Report crash register data or kmsg before running crash
kernel
- rbd: avoid a deadlock on header_rwsem when flushing notifies
- rbd: call rbd_dev_unprobe() after unwatching and flushing notifies
- xsk: Add missing check on user supplied headroom size
- [x86] Hyper-V: Unload vmbus channel in hv panic callback
- [x86] Hyper-V: Free hv_panic_page when fail to register kmsg dump
- [x86] Hyper-V: Trigger crash enlightenment only once during system
crash.
- [x86] Hyper-V: Report crash register data when sysctl_record_panic_msg
is not set
- [x86] Hyper-V: Report crash data in die() when panic_on_oops is set
- power: supply: bq27xxx_battery: Silence deferred-probe error
- [arm64,armhf] clk: tegra: Fix Tegra PMC clock out parents
- [armhf] soc: imx: gpc: fix power up sequencing
- NFSv4/pnfs: Return valid stateids in nfs_layout_find_inode_by_stateid()
- NFS: direct.c: Fix memory leak of dreq when nfs_get_lock_context fails
- [s390x] cpuinfo: fix wrong output when CPU0 is offline
- [s390x] cpum_sf: Fix wrong page count in error message
- ext4: do not commit super on read-only bdev
- cifs: Allocate encryption header through kmalloc
- include/linux/swapops.h: correct guards for non_swap_entry()
- percpu_counter: fix a data race at vm_committed_as
- [s390x] KVM: vsie: Fix possible race when shadowing region 3 tables
- [x86] ACPI: fix CPU hotplug deadlock
- [amd64] drm/amdkfd: kfree the wrong pointer
- NFS: Fix memory leaks in nfs_pageio_stop_mirroring()
- f2fs: fix NULL pointer dereference in f2fs_write_begin()
- [arm*] drm/vc4: Fix HDMI mode validation
- [amd64] iommu/vt-d: Fix mm reference leak
- power: supply: axp288_fuel_gauge: Broaden vendor check for Intel Compute
Sticks.
- libnvdimm: Out of bounds read in __nd_ioctl()
- f2fs: fix to wait all node page writeback
- [armhf] net: dsa: bcm_sf2: Fix overflow checks
- fbdev: potential information leak in do_fb_ioctl()
- mtd: lpddr: Fix a double free in probe()
- mtd: phram: fix a double free issue in error path
- KEYS: Don't write out to userspace while holding key semaphore
- bpf: fix buggy r0 retval refinement for tracing helpers
[ Salvatore Bonaccorso ]
* Refresh "Revert "objtool: Fix CONFIG_STACK_VALIDATION=y warning for
@ -1760,6 +1810,8 @@ linux (4.19.117-1) UNRELEASED; urgency=medium
RT"
* [rt] Refresh "pci/switchtec: Don't use completion's wait queue" for
context changes in 4.19.116
* Refresh "firmware: Remove redundant log messages from drivers" for context
changes in 4.19.118
[ Ben Hutchings ]
* [x86] Drop "Add a SysRq option to lift kernel lockdown" (Closes: #947021)

View File

@ -2748,18 +2748,15 @@ Index: linux/sound/pci/hda/hda_intel.c
===================================================================
--- linux.orig/sound/pci/hda/hda_intel.c
+++ linux/sound/pci/hda/hda_intel.c
@@ -2075,10 +2075,8 @@ static void azx_firmware_cb(const struct
struct azx *chip = card->private_data;
struct pci_dev *pci = chip->pci;
@@ -2079,8 +2079,6 @@ static void azx_firmware_cb(const struct
- if (!fw) {
- dev_err(card->dev, "Cannot load firmware, aborting\n");
+ if (!fw)
goto error;
- }
chip->fw = fw;
if (fw)
chip->fw = fw;
- else
- dev_err(card->dev, "Cannot load firmware, continue without patching\n");
if (!chip->disabled) {
/* continue probing */
azx_probe_continue(chip);
Index: linux/sound/pci/korg1212/korg1212.c
===================================================================
--- linux.orig/sound/pci/korg1212/korg1212.c