firmware_class: Refer to Debian wiki page when logging missing firmware

Closes: #888405
This commit is contained in:
Ben Hutchings 2018-03-12 01:21:33 +00:00
parent bc264fd9ed
commit 1cf87c07e9
3 changed files with 31 additions and 0 deletions

2
debian/changelog vendored
View File

@ -13,6 +13,8 @@ linux (4.15.4-2) UNRELEASED; urgency=medium
SND_SOC_INTEL_HASWELL, SND_SOC_INTEL_BAYTRAIL, SND_SST_ATOM_HIFI2_PLATFORM,
SND_SOC_INTEL_SKYLAKE as modules; re-enable dependent board drivers
(Closes: #892629)
* firmware_class: Refer to Debian wiki page when logging missing firmware
(Closes: #888405)
-- Salvatore Bonaccorso <carnil@debian.org> Tue, 20 Feb 2018 21:51:39 +0100

View File

@ -0,0 +1,28 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 12 Mar 2018 01:14:03 +0000
Subject: firmware_class: Refer to Debian wiki page when logging missing firmware
Bug-Debian: https://bugs.debian.org/888405
Forwarded: not-needed
If firmware loading fails due to a missing file, log a second error
message referring to our wiki page about firmware. This will explain
why some firmware is in non-free, or can't be packaged at all. Only
do this once per boot.
---
--- a/drivers/base/firmware_class.c
+++ b/drivers/base/firmware_class.c
@@ -430,9 +430,12 @@ fw_get_filesystem_firmware(struct device
}
__putname(path);
- if (rc)
+ if (rc) {
dev_err(device, "firmware: failed to load %s (%d)\n",
buf->fw_id, rc);
+ if (rc == -ENOENT)
+ pr_err_once("See https://wiki.debian.org/Firmware for information about missing firmware\n");
+ }
return rc;
}

View File

@ -15,6 +15,7 @@ debian/tools-perf-install.patch
features/all/drivers-media-dvb-usb-af9005-request_firmware.patch
debian/iwlwifi-do-not-request-unreleased-firmware.patch
bugfix/all/firmware_class-log-every-success-and-failure.patch
debian/firmware_class-refer-to-debian-wiki-firmware-page.patch
bugfix/all/firmware-remove-redundant-log-messages-from-drivers.patch
bugfix/all/radeon-firmware-is-required-for-drm-and-kms-on-r600-onward.patch