[powerpc*] Fix missing CRC for _mcount

This commit is contained in:
Ben Hutchings 2017-02-01 22:30:01 +00:00
parent 000457eb03
commit 1ca7f0fad2
2 changed files with 4 additions and 1 deletions

1
debian/changelog vendored
View File

@ -6,6 +6,7 @@ linux (4.10~rc6-1~exp2) UNRELEASED; urgency=medium
(might fix FTBFS)
* [powerpc*] Fix various build failures:
- Revert the initial stack protector support
- Fix missing CRC for _mcount
-- Ben Hutchings <ben@decadent.org.uk> Wed, 01 Feb 2017 22:13:06 +0000

View File

@ -6,6 +6,7 @@ Forwarded: https://lkml.kernel.org/r/20161202023837.GK2697@decadent.org.uk
Add declarations for:
- __mfdcr, __mtdcr (if CONFIG_PPC_DCR_NATIVE=y; through <asm/dcr.h>)
- switch_mmu_context (if CONFIG_PPC_BOOK3S_64=n; through <asm/mmu_context.h>)
- _mcount (if CONFIG_FUNCTION_TRACER=y; though <asm/ftrace.h>)
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
@ -14,12 +15,13 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
--- a/arch/powerpc/include/asm/asm-prototypes.h
+++ b/arch/powerpc/include/asm/asm-prototypes.h
@@ -17,6 +17,8 @@
@@ -17,6 +17,9 @@
#include <asm/checksum.h>
#include <linux/uaccess.h>
#include <asm/epapr_hcalls.h>
+#include <asm/dcr.h>
+#include <asm/mmu_context.h>
+#include <asm/ftrace.h>
#include <uapi/asm/ucontext.h>