* debian/changelog: Update.

* debian/config/defines: Ignore remaining ABI changes.
* debian/patches/bugfix/all/stable/2.6.29.3-abi-1.patch: Add.
* debian/patches/series/5: Add new patch.

svn path=/dists/sid/linux-2.6/; revision=13618
This commit is contained in:
Bastian Blank 2009-05-15 22:12:47 +00:00
parent 1cbfc8995b
commit 1c6ef58442
4 changed files with 25 additions and 0 deletions

1
debian/changelog vendored
View File

@ -71,6 +71,7 @@ linux-2.6 (2.6.29-5) UNRELEASED; urgency=low
- mac80211: Fix bug in getting rx status for frames pending in reorder
buffer
- forcedeth: Fix resume from hibernation regression.
* Ignore ABI change.
-- dann frazier <dannf@debian.org> Mon, 04 May 2009 13:40:51 -0600

View File

@ -1,5 +1,7 @@
[abi]
abiname: 2
ignore-changes:
copy_fs_struct exit_fs
[base]
arches:

View File

@ -0,0 +1,21 @@
diff --git a/include/linux/fs_struct.h b/include/linux/fs_struct.h
index 78a05bf..818ff7e 100644
--- a/include/linux/fs_struct.h
+++ b/include/linux/fs_struct.h
@@ -4,11 +4,14 @@
#include <linux/path.h>
struct fs_struct {
- int users;
+ atomic_t count;
rwlock_t lock;
int umask;
- int in_exec;
struct path root, pwd;
+#ifndef __GENKSYMS__
+ int users;
+ int in_exec;
+#endif
};
extern struct kmem_cache *fs_cachep;

View File

@ -5,3 +5,4 @@
+ bugfix/all/mvsdio-platform.patch
- bugfix/all/drm-intel.git-f544847fbaf099278343f875987a983f2b913134.patch
+ bugfix/all/stable/2.6.29.3.patch
+ bugfix/all/stable/2.6.29.3-abi-1.patch