* debian/changelog: Set version to 3.1.3-1.

* debian/patches: Remove merged patches.

svn path=/dists/sid/linux-2.6/; revision=18326
This commit is contained in:
Bastian Blank 2011-11-27 19:50:33 +00:00
parent 01f077e6d8
commit 1c05df2344
4 changed files with 2 additions and 102 deletions

3
debian/changelog vendored
View File

@ -1,7 +1,8 @@
linux-2.6 (3.1.2-1) UNRELEASED; urgency=low
linux-2.6 (3.1.3-1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.1.2
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.1.3
[ Martin Michlmayr ]
* [armel] Set the priority of pata-modules to standard since the

View File

@ -1,53 +0,0 @@
Date: Wed, 26 Oct 2011 13:29:42 +0200
From: Bart Hartgers <bart.hartgers@gmail.com>
Subject: [PATCH] ark3116 initialisation fix
Hi,
This patch for the usb serial ark3116 driver fixes an initialisation
ordering bug that gets triggered on hotplug when using at least recent
debian/ubuntu userspace. Without it, ark3116 serial cables don't work.
Patch is against 3.1.
Groeten,
Bart
Signed-off-by: Bart Hartgers <bart.hartgers@gmail.com>
Tested-by: law_ence.dev@ntlworld.com
---
diff -ur linux-3.1.orig//drivers/usb/serial/ark3116.c linux-3.1/drivers/usb/serial/ark3116.c
--- linux-3.1.orig//drivers/usb/serial/ark3116.c 2011-10-24 09:10:05.000000000 +0200
+++ linux-3.1/drivers/usb/serial/ark3116.c 2011-10-26 09:16:41.776874595 +0200
@@ -42,7 +42,7 @@
* Version information
*/
-#define DRIVER_VERSION "v0.6"
+#define DRIVER_VERSION "v0.7"
#define DRIVER_AUTHOR "Bart Hartgers <bart.hartgers+ark3116@gmail.com>"
#define DRIVER_DESC "USB ARK3116 serial/IrDA driver"
#define DRIVER_DEV_DESC "ARK3116 RS232/IrDA"
@@ -380,10 +380,6 @@
goto err_out;
}
- /* setup termios */
- if (tty)
- ark3116_set_termios(tty, port, NULL);
-
/* remove any data still left: also clears error state */
ark3116_read_reg(serial, UART_RX, buf);
@@ -406,6 +402,10 @@
/* enable DMA */
ark3116_write_reg(port->serial, UART_FCR, UART_FCR_DMA_SELECT);
+ /* setup termios */
+ if (tty)
+ ark3116_set_termios(tty, port, NULL);
+
err_out:
kfree(buf);
return result;

View File

@ -1,46 +0,0 @@
From: Mikulas Patocka <mpatocka@redhat.com>
Date: Mon, 31 Oct 2011 17:08:57 -0700
Subject: [PATCH] vmscan: fix shrinker callback bug in fs/super.c
commit 09f363c7363eb10cfb4b82094bd7064e5608258b upstream.
The callback must not return -1 when nr_to_scan is zero. Fix the bug in
fs/super.c and add this requirement to the callback specification.
Signed-off-by: Mikulas Patocka <mpatocka@redhat.com>
Cc: Dave Chinner <david@fromorbit.com>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
---
fs/super.c | 2 +-
include/linux/shrinker.h | 1 +
2 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/fs/super.c b/fs/super.c
index 3f56a26..32a81f3 100644
--- a/fs/super.c
+++ b/fs/super.c
@@ -61,7 +61,7 @@ static int prune_super(struct shrinker *shrink, struct shrink_control *sc)
return -1;
if (!grab_super_passive(sb))
- return -1;
+ return !sc->nr_to_scan ? 0 : -1;
if (sb->s_op && sb->s_op->nr_cached_objects)
fs_objects = sb->s_op->nr_cached_objects(sb);
diff --git a/include/linux/shrinker.h b/include/linux/shrinker.h
index 790651b..a83833a 100644
--- a/include/linux/shrinker.h
+++ b/include/linux/shrinker.h
@@ -20,6 +20,7 @@ struct shrink_control {
* 'nr_to_scan' entries and attempt to free them up. It should return
* the number of objects which remain in the cache. If it returns -1, it means
* it cannot do any scanning at this time (eg. there is a risk of deadlock).
+ * The callback must not return -1 if nr_to_scan is zero.
*
* The 'gfpmask' refers to the allocation we are currently trying to
* fulfil.
--
1.7.7.2

View File

@ -43,7 +43,6 @@
+ bugfix/ia64/ia64-gpio-GENERIC_GPIO-default-must-be-n.patch
+ features/x86/libertas-prioritize-usb8388_olpc.bin-firmware-on-OLPC-machines.patch
+ bugfix/arm/ARM-ixp4xx-gpiolib-support.patch
+ bugfix/all/ark3116-initialisation-fix.patch
+ bugfix/all/xfs-fix-memory-corruption-in-xfs_readlink.patch
+ bugfix/all/xfs-fix-memory-corruption-in-xfs_readlink-2.patch
+ bugfix/all/oom-fix-integer-overflow-of-points-in-oom_badness.patch
@ -56,7 +55,6 @@
+ bugfix/all/Fix-build-break-when-freezer-not-configured.patch
+ bugfix/all/PM-Freezer-Reimplement-wait_event_freezekillable-usi.patch
+ bugfix/all/hfs-fix-hfs_find_init-sb-ext_tree-NULL-ptr-oops.patch
+ bugfix/all/vmscan-fix-shrinker-callback-bug-in-fs-super.c.patch
+ features/x86/x86-Add-amilo-rfkill-driver-for-some-Fujitsu-Siemens.patch
# Defer until we're sure about the system call number