[arm64] Backport DTB support for Rasperry Pi Compute Module 3.

Tested-by: Charles Fendt <charles.fendt@me.com>
Signed-off-by: Cyril Brulebois <cyril@debamax.com>
(cherry picked from commit de7501857cae4892f52d8c56c2184be548709052)
This commit is contained in:
Cyril Brulebois 2019-07-15 22:43:42 +02:00
parent 10dd2b634c
commit 1b40f700ac
4 changed files with 71 additions and 0 deletions

1
debian/changelog vendored
View File

@ -13,6 +13,7 @@ linux (4.19.67-2) UNRELEASED; urgency=medium
[ Cyril Brulebois ]
* [arm] Backport DTB support for Rasperry Pi Compute Module 3.
* [arm64] Backport DTB support for Rasperry Pi Compute Module 3.
-- Ben Hutchings <ben@decadent.org.uk> Wed, 21 Aug 2019 23:37:56 +0100

View File

@ -0,0 +1,36 @@
From: Stefan Wahren <stefan.wahren@i2se.com>
Date: Mon, 27 Aug 2018 19:33:28 +0200
Subject: arm64: dts: broadcom: Add reference to Compute Module IO Board V3
Origin: https://git.kernel.org/linus/a7eb26392b893bff92b1eb6483f4af3d2eb19510
This adds a reference to the dts of the Compute Module IO Board V3 in arm,
so we don't need to maintain the content in arm64.
Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
---
arch/arm64/boot/dts/broadcom/Makefile | 3 ++-
arch/arm64/boot/dts/broadcom/bcm2837-rpi-cm3-io3.dts | 2 ++
2 files changed, 4 insertions(+), 1 deletion(-)
create mode 100644 arch/arm64/boot/dts/broadcom/bcm2837-rpi-cm3-io3.dts
diff --git a/arch/arm64/boot/dts/broadcom/Makefile b/arch/arm64/boot/dts/broadcom/Makefile
index 1193a9e34bbb..3d98f5f5ab88 100644
--- a/arch/arm64/boot/dts/broadcom/Makefile
+++ b/arch/arm64/boot/dts/broadcom/Makefile
@@ -1,6 +1,7 @@
# SPDX-License-Identifier: GPL-2.0
dtb-$(CONFIG_ARCH_BCM2835) += bcm2837-rpi-3-b.dtb \
- bcm2837-rpi-3-b-plus.dtb
+ bcm2837-rpi-3-b-plus.dtb \
+ bcm2837-rpi-cm3-io3.dts
subdir-y += northstar2
subdir-y += stingray
diff --git a/arch/arm64/boot/dts/broadcom/bcm2837-rpi-cm3-io3.dts b/arch/arm64/boot/dts/broadcom/bcm2837-rpi-cm3-io3.dts
new file mode 100644
index 000000000000..b1c4ab212c64
--- /dev/null
+++ b/arch/arm64/boot/dts/broadcom/bcm2837-rpi-cm3-io3.dts
@@ -0,0 +1,2 @@
+// SPDX-License-Identifier: GPL-2.0
+#include "arm/bcm2837-rpi-cm3-io3.dts"

View File

@ -0,0 +1,32 @@
From: Liviu Dudau <liviu@dudau.co.uk>
Date: Mon, 24 Sep 2018 11:22:28 +0100
Subject: arm64: dts: broadcom: Use the .dtb name in the rule, rather than .dts
Origin: https://git.kernel.org/linus/74cf77e8be35795b4cc57b7010bc348295e421b9
Commit a7eb26392b893 ("arm64: dts: broadcom: Add reference to Compute
Module IO Board V3") adds the bcm2837-rpi-cm3-io3.dts file as a target
in the Makefile, rather than the .dtb name. This will skip the
generation of the .dtb file at compile time and will fail the dtbs_install
target.
Fixes: a7eb26392b893 ("arm64: dts: broadcom: Add reference to Compute Module IO Board V3")
Signed-off-by: Liviu Dudau <liviu@dudau.co.uk>
Acked-by: Stefan Wahren <stefan.wahren@i2se.com>
Signed-off-by: Olof Johansson <olof@lixom.net>
---
arch/arm64/boot/dts/broadcom/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm64/boot/dts/broadcom/Makefile b/arch/arm64/boot/dts/broadcom/Makefile
index 3d98f5f5ab88..667ca989c11b 100644
--- a/arch/arm64/boot/dts/broadcom/Makefile
+++ b/arch/arm64/boot/dts/broadcom/Makefile
@@ -1,7 +1,7 @@
# SPDX-License-Identifier: GPL-2.0
dtb-$(CONFIG_ARCH_BCM2835) += bcm2837-rpi-3-b.dtb \
bcm2837-rpi-3-b-plus.dtb \
- bcm2837-rpi-cm3-io3.dts
+ bcm2837-rpi-cm3-io3.dtb
subdir-y += northstar2
subdir-y += stingray

View File

@ -250,6 +250,8 @@ bugfix/arm64/huawei-taishan/0033-scsi-hisi_sas-fix-calls-to-dma_set_mask_and_coh
# Backported DTB support for Raspberry Pi Compute Module 3 from 4.20-rc1:
features/arm/ARM-dts-add-Raspberry-Pi-Compute-Module-3-and-IO-boa.patch
features/arm64/arm64-dts-broadcom-Add-reference-to-Compute-Module-I.patch
features/arm64/arm64-dts-broadcom-Use-the-.dtb-name-in-the-rule-rat.patch
# ABI maintenance
debian/abi/powerpc-avoid-abi-change-for-disabling-tm.patch