[alpha] wire up accept4 syscall, thanks to Michael Cree

svn path=/dists/trunk/linux-2.6/; revision=18232
This commit is contained in:
Ben Hutchings 2011-11-04 15:07:20 +00:00
parent e51f5752b0
commit 1b2eec8411
3 changed files with 60 additions and 0 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux-2.6 (3.1.0-1~experimental.2) experimental; urgency=low
[ Ben Hutchings ]
* [alpha] wire up accept4 syscall, thanks to Michael Cree
-- Ben Hutchings <ben@decadent.org.uk> Fri, 04 Nov 2011 15:05:47 +0000
linux-2.6 (3.1.0-1~experimental.1) experimental; urgency=low
* New upstream release: http://kernelnewbies.org/Linux_3.1

View File

@ -0,0 +1,52 @@
From: Michael Cree <mcree@orcon.net.nz>
Date: Mon, 31 Oct 2011 17:09:49 -0700
Subject: [PATCH] alpha: wire up accept4 syscall
commit 0a8c384ebe4cc1c462076732dbffb595e7e81d5c upstream.
Somehow wiring up the accept4 syscall on Alpha was missed long ago.
This commit rectifies that oversight.
Signed-off-by: Michael Cree <mcree@orcon.net.nz>
Reviewed-by: Matt Turner <mattst88@gmail.com>
Cc: Richard Henderson <rth@twiddle.net>
Cc: Ivan Kokshaysky <ink@jurassic.park.msu.ru>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
---
arch/alpha/include/asm/unistd.h | 3 ++-
arch/alpha/kernel/systbls.S | 1 +
2 files changed, 3 insertions(+), 1 deletions(-)
diff --git a/arch/alpha/include/asm/unistd.h b/arch/alpha/include/asm/unistd.h
index 4ac48a0..1fbfd64 100644
--- a/arch/alpha/include/asm/unistd.h
+++ b/arch/alpha/include/asm/unistd.h
@@ -457,10 +457,11 @@
#define __NR_clock_adjtime 499
#define __NR_syncfs 500
#define __NR_setns 501
+#define __NR_accept4 502
#ifdef __KERNEL__
-#define NR_SYSCALLS 502
+#define NR_SYSCALLS 503
#define __ARCH_WANT_IPC_PARSE_VERSION
#define __ARCH_WANT_OLD_READDIR
diff --git a/arch/alpha/kernel/systbls.S b/arch/alpha/kernel/systbls.S
index 6acea1f..53d0ce2 100644
--- a/arch/alpha/kernel/systbls.S
+++ b/arch/alpha/kernel/systbls.S
@@ -520,6 +520,7 @@ sys_call_table:
.quad sys_clock_adjtime
.quad sys_syncfs /* 500 */
.quad sys_setns
+ .quad sys_accept4
.size sys_call_table, . - sys_call_table
.type sys_call_table, @object
--
1.7.7

View File

@ -0,0 +1 @@
+ bugfix/alpha/alpha-wire-up-accept4-syscall.patch