arm/ixp4xx: Add patch to fix used_sram_bitmap corruption in

qmgr_release_queue(). This patch has been submitted upstream.

svn path=/dists/trunk/linux-2.6/; revision=11143
This commit is contained in:
Gordon Farquharson 2008-04-23 14:10:55 +00:00
parent 5bf4f9cb09
commit 1aed43b170
3 changed files with 20 additions and 0 deletions

1
debian/changelog vendored
View File

@ -72,6 +72,7 @@ linux-2.6 (2.6.25-1~experimental.1) UNRELEASED; urgency=low
* [arm/iop32x] Do not build the ARTOP PATA driver (PATA_ARTOP).
* [arm/iop32x] Register the F75375 device in the GLAN Tank platform code.
* Prevent physmap from calling request_module() too early.
* [arm/ixp4xx] Fix used_sram_bitmap corruption in qmgr_release_queue().
[ Aurelien Jarno ]
* [mips/mipsel] Enable CONFIG_NO_HZ, CONFIG_HIGH_RES_TIMERS for dynticks

View File

@ -0,0 +1,18 @@
IXP4xx: fix used_sram_bitmap corruption in qmgr_release_queue()
Signed-off-by: Krzysztof Hałasa <khc@pm.waw.pl>
---
diff --git a/arch/arm/mach-ixp4xx/ixp4xx_qmgr.c b/arch/arm/mach-ixp4xx/ixp4xx_qmgr.c
index e833013..fab94ea 100644
--- a/arch/arm/mach-ixp4xx/ixp4xx_qmgr.c
+++ b/arch/arm/mach-ixp4xx/ixp4xx_qmgr.c
@@ -184,6 +184,8 @@ void qmgr_release_queue(unsigned int queue)
case 3: mask[0] = 0xFF; break;
}
+ mask[1] = mask[2] = mask[3] = 0;
+
while (addr--)
shift_mask(mask);

View File

@ -43,3 +43,4 @@
+ bugfix/all/rtc-x1205-new-style-conversion-checkpatch-fixes.patch
+ bugfix/all/mtd-prevent-physmap-from-causing-request_module-runaway-loop-modprobe-net-pf-1.patch
+ features/all/firewire-git.patch
+ bugfix/arm/fix-ixp4xx_qmgr-used_sram_bitmap-corruption.patch