rt2860sta: Fix argument to linux_pci_unmap_single() (Closes: #575726)

svn path=/dists/sid/linux-2.6/; revision=15454
This commit is contained in:
Ben Hutchings 2010-03-29 00:33:41 +00:00
parent d330957536
commit 1a18a4a036
3 changed files with 45 additions and 0 deletions

1
debian/changelog vendored
View File

@ -13,6 +13,7 @@ linux-2.6 (2.6.32-11) UNRELEASED; urgency=low
since it disconnects the wrong device (Closes: #573607)
* linux-headers-*: Support postinst hooks in /etc/kernel/header_postinst.d,
thanks to Michael Gilbert (Closes: #569724)
* rt2860sta: Fix argument to linux_pci_unmap_single() (Closes: #575726)
[ maximilian attems]
* [alpha, hppa] Disable oprofile as tracing code is unsupported here.

View File

@ -0,0 +1,43 @@
Subject: [PATCH] rt2860sta: Fix argument to linux_pci_unmap_single()
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 29 Mar 2010 01:09:17 +0100
John Halton wrote in <http://bugs.debian.org/575726>:
> Whenever wpa_supplicant is deactivated (whether by killing the process or
> during a normal shutdown) I am getting a kerneloops that prevents the
> computer from completing shutdown. Here is the relevant syslog output:
The backtrace points to an incorrect call from RTMPFreeTxRxRingMemory()
into linux_pci_unmap_single(). This appears to have been fixed in Linux
2.6.33 by this change:
commit ca97b8388838ee9ea4b4bad04948f8f7f8a607a3
Author: Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
Date: Tue Sep 22 20:44:07 2009 +0200
Staging: rt28x0: updates from vendor's V2.1.0.0 drivers
For stable-2.6.32, just fix this one function call.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/staging/rt2860/common/2860_rtmp_init.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/staging/rt2860/common/2860_rtmp_init.c b/drivers/staging/rt2860/common/2860_rtmp_init.c
index 0bc0fb9..98b0f8e 100644
--- a/drivers/staging/rt2860/common/2860_rtmp_init.c
+++ b/drivers/staging/rt2860/common/2860_rtmp_init.c
@@ -716,7 +716,7 @@ VOID RTMPFreeTxRxRingMemory(
{
if ((pAd->RxRing.Cell[index].DmaBuf.AllocVa) && (pAd->RxRing.Cell[index].pNdisPacket))
{
- PCI_UNMAP_SINGLE(pObj->pci_dev, pAd->RxRing.Cell[index].DmaBuf.AllocPa, pAd->RxRing.Cell[index].DmaBuf.AllocSize, PCI_DMA_FROMDEVICE);
+ PCI_UNMAP_SINGLE(pAd, pAd->RxRing.Cell[index].DmaBuf.AllocPa, pAd->RxRing.Cell[index].DmaBuf.AllocSize, PCI_DMA_FROMDEVICE);
RELEASE_NDIS_PACKET(pAd, pAd->RxRing.Cell[index].pNdisPacket, NDIS_STATUS_SUCCESS);
}
}
--
1.7.0.3

View File

@ -6,3 +6,4 @@
+ bugfix/x86/eeepc-laptop-disable-wireless-hotplug-for-1201N.patch
+ bugfix/x86/eeepc-laptop-disable-wireless-hotplug-for-1005PE.patch
+ bugfix/all/ssb_check_for_sprom.patch
+ bugfix/all/rt2860sta-Fix-argument-to-linux_pci_unmap_single.patch