[powerpc] Remove SMP warning from PowerMac cpufreq (Closes: #554124).

Logged under Bastian's name since the patch is from him.

svn path=/dists/sid/linux-2.6/; revision=14534
This commit is contained in:
Ben Hutchings 2009-11-03 02:16:20 +00:00
parent 0ada151cfa
commit 19ac3d26c1
3 changed files with 54 additions and 0 deletions

3
debian/changelog vendored
View File

@ -12,6 +12,9 @@ linux-2.6 (2.6.31-2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* postinst: Accept absolute paths in modules.dep generated by the
lenny version of module-init-tools (Closes: #552610)
[ Bastian Blank ]
* [powerpc] Remove SMP warning from PowerMac cpufreq (Closes: #554124)
-- Martin Michlmayr <tbm@cyrius.com> Tue, 27 Oct 2009 21:18:29 +0800

View File

@ -0,0 +1,50 @@
From 6fdc31a2b86cf1f98e3eed896578ad9659eeb0f8 Mon Sep 17 00:00:00 2001
From: Bastian Blank <bastian@waldi.eu.org>
Date: Wed, 12 Aug 2009 23:30:45 +0000
Subject: [PATCH] powerpc: Remove SMP warning from PowerMac cpufreq
On Thu, Aug 13, 2009 at 04:14:58PM +1000, Benjamin Herrenschmidt wrote:
> On Tue, 2009-08-11 at 11:39 +0200, Bastian Blank wrote:
> > This patch just disables this driver on SMP kernels, as it is obviously
> > not supported.
> Why not remove the #error instead ? :-) I don't think it's still
> meaningful, especially since we use the timebase for delays nowadays
> which doesn't depend on the CPU frequency...
Your call. Take this one:
The build of a PowerMac 32bit kernel currently fails with
error: #warning "WARNING, CPUFREQ not recommended on SMP kernels"
Thie patch removes the not longer applicable SMP warning from the
PowerMac cpufreq code.
Signed-off-by: Bastian Blank <waldi@debian.org>
Signed-off-by: Benjamin Herrenschmidt <benh@kernel.crashing.org>
---
arch/powerpc/platforms/powermac/cpufreq_32.c | 8 --------
1 files changed, 0 insertions(+), 8 deletions(-)
diff --git a/arch/powerpc/platforms/powermac/cpufreq_32.c b/arch/powerpc/platforms/powermac/cpufreq_32.c
index 65c585b..08d94e4 100644
--- a/arch/powerpc/platforms/powermac/cpufreq_32.c
+++ b/arch/powerpc/platforms/powermac/cpufreq_32.c
@@ -44,14 +44,6 @@
*/
#undef DEBUG_FREQ
-/*
- * There is a problem with the core cpufreq code on SMP kernels,
- * it won't recalculate the Bogomips properly
- */
-#ifdef CONFIG_SMP
-#warning "WARNING, CPUFREQ not recommended on SMP kernels"
-#endif
-
extern void low_choose_7447a_dfs(int dfs);
extern void low_choose_750fx_pll(int pll);
extern void low_sleep_handler(void);
--
1.6.5.2

View File

@ -1,2 +1,3 @@
+ bugfix/mips/fix-build-vmlinuxlds.patch
+ features/arm/openrd-client.patch
+ bugfix/powerpc/Remove-SMP-warning-from-PowerMac-cpufreq.patch