3w-sas: Really undo the queue depth code change

svn path=/dists/trunk/linux-2.6/; revision=15021
This commit is contained in:
Ben Hutchings 2010-01-26 22:59:12 +00:00
parent 7543fafd65
commit 182c7b1e03
1 changed files with 6 additions and 10 deletions

View File

@ -1,4 +1,4 @@
From bc8548932ca011c384ca7ccd6572a305911195ff Mon Sep 17 00:00:00 2001
From 90f851a3806e331d295d20fd2c9cec5186077416 Mon Sep 17 00:00:00 2001
From: adam radford <aradford@gmail.com>
Date: Fri, 23 Oct 2009 14:52:33 -0700
Subject: [PATCH] [SCSI] 3w-sas: Add new driver for LSI 3ware 9750
@ -10,20 +10,20 @@ commit f619106bdd9d197c947f07108af57946f19a7f7e upstream
Signed-off-by: Adam Radford <aradford@gmail.com>
Signed-off-by: James Bottomley <James.Bottomley@suse.de>
---
drivers/scsi/3w-sas.c | 1924 +++++++++++++++++++++++++++++++++++++++++++++++++
drivers/scsi/3w-sas.c | 1920 +++++++++++++++++++++++++++++++++++++++++++++++++
drivers/scsi/3w-sas.h | 396 ++++++++++
drivers/scsi/Kconfig | 11 +
drivers/scsi/Makefile | 1 +
4 files changed, 2332 insertions(+), 0 deletions(-)
4 files changed, 2328 insertions(+), 0 deletions(-)
create mode 100644 drivers/scsi/3w-sas.c
create mode 100644 drivers/scsi/3w-sas.h
diff --git a/drivers/scsi/3w-sas.c b/drivers/scsi/3w-sas.c
new file mode 100644
index 0000000..4d314d7
index 0000000..aa5a304
--- /dev/null
+++ b/drivers/scsi/3w-sas.c
@@ -0,0 +1,1924 @@
@@ -0,0 +1,1920 @@
+/*
+ 3w-sas.c -- LSI 3ware SAS/SATA-RAID Controller device driver for Linux.
+
@ -217,12 +217,8 @@ index 0000000..4d314d7
+} /* End twl_show_stats() */
+
+/* This function will set a devices queue depth */
+static int twl_change_queue_depth(struct scsi_device *sdev, int queue_depth,
+ int reason)
+static int twl_change_queue_depth(struct scsi_device *sdev, int queue_depth)
+{
+ if (reason != SCSI_QDEPTH_DEFAULT)
+ return -EOPNOTSUPP;
+
+ if (queue_depth > TW_Q_LENGTH-2)
+ queue_depth = TW_Q_LENGTH-2;
+ scsi_adjust_queue_depth(sdev, MSG_ORDERED_TAG, queue_depth);