rsync with 2.6.38-5 changes

this add the per arch abi feature.
the m68k and security patches seem all merged.

svn path=/dists/trunk/linux-2.6/; revision=17346
This commit is contained in:
Maximilian Attems 2011-05-09 15:42:48 +00:00
parent cdb98e5e8c
commit 1573c3f22e
6 changed files with 92 additions and 4 deletions

View File

@ -41,6 +41,13 @@ class Gencontrol(Base):
self._setup_makeflags(self.arch_makeflags, makeflags, config_base)
def do_arch_packages(self, packages, makefile, arch, vars, makeflags, extra):
if self.version.linux_modifier is None:
try:
vars['abiname'] = '-%s' % self.config['abi', arch]['abiname']
except KeyError:
vars['abiname'] = self.abiname
makeflags['ABINAME'] = vars['abiname']
headers_arch = self.templates["control.headers.arch"]
packages_headers_arch = self.process_packages(headers_arch, vars)

49
debian/changelog vendored
View File

@ -65,6 +65,55 @@ linux-2.6 (2.6.39~rc4-1~experimental.1) experimental; urgency=low
-- Ben Hutchings <ben@decadent.org.uk> Sun, 24 Apr 2011 03:21:31 +0100
linux-2.6 (2.6.38-5) unstable; urgency=medium
[ Thorsten Glaser ]
* [m68k] atari: Enable and compile in generic RTC
* [m68k] Backport the most urgent fixes from 2.6.39
- Add helper functions to handle kernel faults, traps and
exceptions better (used by the other patches below)
- Add improved support for running under the ARAnyM emulator
(its native features interface) and emulated hardware
+ block access (similar to virtio-block)
+ console access (redirection to stdout)
+ network access (Ethernet) (Closes: #599121)
* [m68k] Add patch from queue fixing atarifb console output on
machines with a lot of FastRAM by reserving some ST-RAM early
* [m68k] Add patch from mm mailing list to fix SLUB breakage
[ Aurelien Jarno ]
* [mips/octeon] Disable CONFIG_HOTPLUG_CPU.
[ Ben Hutchings ]
* rt2800pci, rt2800usb: Enable experimental support for more recent
chips (Closes: #623808)
* [x86] staging: Enable EASYCAP as module (Closes: #624505)
* Add stable 2.6.38.5, including:
- p54: Initialize extra_len in p54_tx_80211
- nfsd4: Fix filp leak (regression introduced in 2.6.38.3)
- radeon: PLL tweaks for R7xx
- nouveau: Fix notifier memory corruption bug
- radeon: Fix bad shift in atom iio table parser
- [x86] i915: Sanitize the output registers after resume
- [x86] ideapad: Read brightness setting on brightness key notify
- ath9k_hw: Partially revert "fix dma descriptor rx error bit parsing"
- [s390] pfault: fix token handling
- ACPI/PM: Avoid infinite recurrence while registering power resources
- [hppa] slub: Disable use with DISCONTIGMEM && !NUMA
- vfs: avoid large kmalloc()s for the fdtable
- agp: Fix arbitrary kernel memory writes (CVE-2011-1745)
- agp: Fix OOM and buffer overflow (CVE-2011-1746)
For the complete list of changes, see:
http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.38.5
* [hppa] Bump ABI to 2a
* mpt2sas: Prevent heap overflows and unchecked reads
(CVE-2011-1494, CVE-2011-1495)
* [armel] Prevent heap corruption in OABI semtimedop
* can: Add missing socket check in can/bcm release (CVE-2011-1598)
* ldm: Disable broken support for VBLK fragments (CVE-2011-1017)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 07 May 2011 21:24:55 +0100
linux-2.6 (2.6.38-4) unstable; urgency=low
* usb-audio: Define another USB ID for a buggy USB MIDI cable

View File

@ -1956,11 +1956,13 @@ CONFIG_RT2400PCI=m
CONFIG_RT2500PCI=m
CONFIG_RT61PCI=m
CONFIG_RT2800PCI=m
# CONFIG_RT2800PCI_RT35XX is not set
CONFIG_RT2800PCI_RT33XX=y
CONFIG_RT2800PCI_RT35XX=y
CONFIG_RT2500USB=m
CONFIG_RT73USB=m
CONFIG_RT2800USB=m
# CONFIG_RT2800USB_RT35XX is not set
CONFIG_RT2800USB_RT33XX=y
CONFIG_RT2800USB_RT35XX=y
# CONFIG_RT2800USB_UNKNOWN is not set
# CONFIG_RT2X00_DEBUG is not set

View File

@ -46,8 +46,8 @@ CONFIG_PRINTER=m
# CONFIG_LP_CONSOLE is not set
# CONFIG_PPDEV is not set
CONFIG_NVRAM=y
CONFIG_RTC=m
CONFIG_GEN_RTC=m
CONFIG_RTC=y
CONFIG_GEN_RTC=y
##
## file: drivers/ide/Kconfig
@ -115,6 +115,7 @@ CONFIG_PARPORT_ATARI=m
## file: drivers/rtc/Kconfig
##
CONFIG_RTC_CLASS=y
CONFIG_RTC_DRV_GENERIC=y
##
## file: drivers/scsi/Kconfig

View File

@ -0,0 +1,28 @@
From 4fb027f4664b0571b41bd22a8921940b4b5bfb4b Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 7 May 2011 04:26:50 +0100
Subject: [PATCH] slub: Reenable for m68k
Following commit 4aac0b4815ba592052758f4b468f253d383dc9d6
'm68k/mm: Set all online nodes in N_NORMAL_MEMORY', SLUB should
actually work.
---
init/Kconfig | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/init/Kconfig b/init/Kconfig
index 47dd02f..f108e91 100644
--- a/init/Kconfig
+++ b/init/Kconfig
@@ -1209,7 +1209,7 @@ config SLAB
per cpu and per node queues.
config SLUB
- depends on BROKEN || NUMA || !DISCONTIGMEM
+ depends on BROKEN || NUMA || !DISCONTIGMEM || M68K
bool "SLUB (Unqueued Allocator)"
help
SLUB is a slab allocator that minimizes cache line usage
--
1.7.4.4

View File

@ -44,3 +44,4 @@
+ bugfix/all/rt2800-disable-powersaving-as-default.patch
+ bugfix/powerpc/powerpc-kexec-Fix-build-failure-on-32-bit-SMP.patch
+ bugfix/all/xhci-hcd-Include-linux-slab.h-in-xhci-pci.c.patch
+ debian/slub-Reenable-for-m68k.patch