Update to 4.2-rc6

Refresh perf patches.
Add a newly needed type to scripts/mod/types.h.
This commit is contained in:
Ben Hutchings 2015-08-13 20:52:14 +02:00
parent 094026e778
commit 1561e3da38
5 changed files with 20 additions and 12 deletions

View File

@ -142,7 +142,7 @@ class Main(object):
'Makefile',
'arch/*/include/',
'arch/*/Makefile',
'arch/x86/syscalls/',
'arch/x86/entry/syscalls/',
'arch/x86/lib/memcpy_64.S',
'arch/x86/lib/memset_64.S',
'arch/x86/tools/',

View File

@ -3,4 +3,7 @@ typedef unsigned char __u8;
typedef unsigned short __u16;
typedef unsigned int __u32;
typedef unsigned long long __u64;
typedef struct {
__u8 b[16];
} uuid_le;
#define offsetof(a,b) __builtin_offsetof(a,b)

5
debian/changelog vendored
View File

@ -1,5 +1,8 @@
linux-tools (4.1.4-3) UNRELEASED; urgency=medium
linux-tools (4.2~rc6-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate
[ Ben Hutchings ]
* Adjust for migration to git:
- Update .gitignore files
- debian/control: Update Vcs-* fields

View File

@ -7,7 +7,7 @@ Forwarded: no
--- a/tools/perf/Makefile.perf
+++ b/tools/perf/Makefile.perf
@@ -484,8 +484,8 @@ endif
@@ -510,8 +510,8 @@ endif
ifndef NO_LIBPERL
$(call QUIET_INSTALL, perl-scripts) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/Perf-Trace-Util/lib/Perf/Trace'; \
@ -18,7 +18,7 @@ Forwarded: no
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/bin'; \
$(INSTALL) scripts/perl/bin/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/bin'
endif
@@ -493,18 +493,18 @@ ifndef NO_LIBPYTHON
@@ -519,20 +519,20 @@ ifndef NO_LIBPYTHON
$(call QUIET_INSTALL, python-scripts) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/Perf-Trace-Util/lib/Perf/Trace'; \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/bin'; \
@ -32,6 +32,8 @@ Forwarded: no
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d'; \
- $(INSTALL) perf-completion.sh '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf_$(VERSION)'
+ $(INSTALL) -m 644 perf-completion.sh '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf_$(VERSION)'
install-tests: all install-gtk
$(call QUIET_INSTALL, tests) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'; \
- $(INSTALL) tests/attr.py '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'; \
@ -40,5 +42,5 @@ Forwarded: no
- $(INSTALL) tests/attr/* '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr'
+ $(INSTALL) -m 644 tests/attr/* '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr'
install: install-bin try-install-man install-traceevent-plugins
install-bin: install-tools install-tests

View File

@ -9,8 +9,8 @@ version-dependent name. And do the same for trace.]
--- a/tools/perf/Makefile.perf
+++ b/tools/perf/Makefile.perf
@@ -465,18 +465,18 @@ install-gtk:
install-bin: all install-gtk
@@ -491,18 +491,18 @@ install-gtk:
install-tools: all install-gtk
$(call QUIET_INSTALL, binaries) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)'; \
- $(INSTALL) $(OUTPUT)perf '$(DESTDIR_SQ)$(bindir_SQ)'; \
@ -34,16 +34,16 @@ version-dependent name. And do the same for trace.]
$(call QUIET_INSTALL, perf-archive) \
$(INSTALL) $(OUTPUT)perf-archive -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)'
$(call QUIET_INSTALL, perf-with-kcore) \
@@ -499,7 +499,7 @@ ifndef NO_LIBPYTHON
@@ -525,7 +525,7 @@ ifndef NO_LIBPYTHON
endif
$(call QUIET_INSTALL, perf_completion-script) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d'; \
- $(INSTALL) perf-completion.sh '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf'
+ $(INSTALL) perf-completion.sh '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf_$(VERSION)'
install-tests: all install-gtk
$(call QUIET_INSTALL, tests) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'; \
$(INSTALL) tests/attr.py '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'; \
@@ -513,7 +513,7 @@ install-python_ext:
@@ -543,7 +543,7 @@ install-python_ext:
# 'make install-doc' should call 'make -C Documentation install'
$(INSTALL_DOC_TARGETS):
@ -79,7 +79,7 @@ version-dependent name. And do the same for trace.]
--- a/tools/perf/util/Build
+++ b/tools/perf/util/Build
@@ -127,6 +127,7 @@ CFLAGS_find_next_bit.o += -Wno-unused-pa
@@ -130,6 +130,7 @@ CFLAGS_find_next_bit.o += -Wno-unused-pa
CFLAGS_rbtree.o += -Wno-unused-parameter -DETC_PERFCONFIG="BUILD_STR($(ETC_PERFCONFIG_SQ))"
CFLAGS_hweight.o += -Wno-unused-parameter -DETC_PERFCONFIG="BUILD_STR($(ETC_PERFCONFIG_SQ))"
CFLAGS_parse-events.o += -Wno-redundant-decls