aufs: Update to aufs3.2-20120109 (fixes FTBFS on m68k)

svn path=/dists/trunk/linux-2.6/; revision=18630
This commit is contained in:
Ben Hutchings 2012-01-25 04:20:39 +00:00
parent 996dcea551
commit 13bf7925f6
5 changed files with 221 additions and 276 deletions

1
debian/changelog vendored
View File

@ -8,6 +8,7 @@ linux-2.6 (3.2.1-3) UNRELEASED; urgency=low
* Remove modules.*.bin in linux-image postrm script; currently
modules.builtin.bin is left behind
* [alpha] Build with gcc-4.5 (Closes: #657112)
* aufs: Update to aufs3.2-20120109 (fixes FTBFS on m68k)
[ Thorsten Glaser ]
* [m68k] Use gcc-4.6 like (almost) all other architectures

File diff suppressed because it is too large Load Diff

View File

@ -1,10 +1,10 @@
aufs3.x-rcN base patch
aufs3.2 base patch
diff --git a/fs/namei.c b/fs/namei.c
index ac6d214..f72b667 100644
index 5008f01..4cc94cf 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1750,7 +1750,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
@@ -1753,7 +1753,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
* needs parent already locked. Doesn't follow mounts.
* SMP-safe.
*/

View File

@ -1,4 +1,4 @@
aufs3.x-rcN kbuild patch
aufs3.2 kbuild patch
diff --git a/fs/Kconfig b/fs/Kconfig
index 5f4c45d..357a8a6 100644

View File

@ -1,4 +1,4 @@
aufs3.x-rcN standalone patch
aufs3.2 standalone patch
diff --git a/fs/file_table.c b/fs/file_table.c
index c322794..2aad244 100644
@ -26,10 +26,10 @@ index ee4e66b..728042b 100644
/*
* Empty aops. Can be used for the cases where the user does not
diff --git a/fs/namei.c b/fs/namei.c
index f72b667..7a58222 100644
index 4cc94cf..af19e30 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1754,6 +1754,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
@@ -1757,6 +1757,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
@ -38,10 +38,10 @@ index f72b667..7a58222 100644
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
index e5e1c7d..344999b 100644
index cfc6d44..173d15a 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -1509,6 +1509,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
@@ -1506,6 +1506,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -152,10 +152,18 @@ index ee4f848..611fd70 100644
}
+EXPORT_SYMBOL_GPL(cap_file_mmap);
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 4450fbe..2c437e5 100644
index 4450fbe..bc94175 100644
--- a/security/device_cgroup.c
+++ b/security/device_cgroup.c
@@ -500,6 +500,7 @@ found:
@@ -7,6 +7,7 @@
#include <linux/device_cgroup.h>
#include <linux/cgroup.h>
#include <linux/ctype.h>
+#include <linux/export.h>
#include <linux/list.h>
#include <linux/uaccess.h>
#include <linux/seq_file.h>
@@ -500,6 +501,7 @@ found:
return -EPERM;
}
@ -164,7 +172,7 @@ index 4450fbe..2c437e5 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
index 0c6cc69..d58ba1b 100644
index e2f684a..892000c 100644
--- a/security/security.c
+++ b/security/security.c
@@ -411,6 +411,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)