Documentation: Avoid creating man pages in source tree

kernel-doc can currently generate dummy DocBook files using
absolute paths as their titles, which results in man pages being
created in the source tree (and thus going into linux-headers
and linux-source packages).
This commit is contained in:
Ben Hutchings 2015-08-21 18:13:33 +02:00
parent b60f5c4de1
commit 13be7e1afd
3 changed files with 52 additions and 0 deletions

1
debian/changelog vendored
View File

@ -12,6 +12,7 @@ linux (4.2~rc7-1~exp1) UNRELEASED; urgency=medium
* debian/control: Correct build-dependency on xz-utils, needed on all arches
* Fix more issues that prevent a reproducible build:
- Set LC_ALL=C.UTF-8
- Avoid creating man pages in source tree
-- Ben Hutchings <ben@decadent.org.uk> Mon, 17 Aug 2015 10:28:46 +0200

View File

@ -0,0 +1,50 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 21 Aug 2015 18:06:56 +0200
Subject: Documentation: Avoid creating man pages in source tree
Currently kernel-doc generates a dummy DocBook file when asked to
convert a C source file with no structured comments. For an
out-of-tree build (objtree != srctree), the title of the output file
is the absolute path name of the C source file, which later results
in a manual page being created alongside the C source file.
Change the title to be a relative path.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/scripts/kernel-doc
+++ b/scripts/kernel-doc
@@ -2351,12 +2351,13 @@ sub process_file($) {
my $descr;
my $in_purpose = 0;
my $initial_section_counter = $section_counter;
+ my ($orig_file) = @_;
if (defined($ENV{'SRCTREE'})) {
- $file = "$ENV{'SRCTREE'}" . "/" . "@_";
+ $file = "$ENV{'SRCTREE'}" . "/" . $orig_file;
}
else {
- $file = "@_";
+ $file = $orig_file;
}
if (defined($source_map{$file})) {
$file = $source_map{$file};
@@ -2565,7 +2566,7 @@ sub process_file($) {
print "<refentry>\n";
print " <refnamediv>\n";
print " <refname>\n";
- print " ${file}\n";
+ print " ${orig_file}\n";
print " </refname>\n";
print " <refpurpose>\n";
print " Document generation inconsistency\n";
@@ -2579,7 +2580,7 @@ sub process_file($) {
print " <para>\n";
print " The template for this document tried to insert\n";
print " the structured comment from the file\n";
- print " <filename>${file}</filename> at this point,\n";
+ print " <filename>${orig_file}</filename> at this point,\n";
print " but none was found.\n";
print " This dummy section is inserted to allow\n";
print " generation to continue.\n";

View File

@ -75,6 +75,7 @@ bugfix/all/docbook-don-t-store-mtime-or-name-in-compressed-man-.patch
bugfix/all/docbook-generate-consistent-ids.patch
bugfix/all/docbook-fix-non-determinstic-installation-of-duplica.patch
bugfix/all/scripts-kernel-doc-use-kbuild_build_timestamp-as-man.patch
bugfix/all/documentation-avoid-creating-man-pages-in-source-tree.patch
# Miscellaneous features
features/all/efi-autoload-efi-pstore.patch