radeon: Don't check for installed firmware if driver is built-in (Closes: #763305)

svn path=/dists/sid/linux/; revision=21924
This commit is contained in:
Ben Hutchings 2014-09-30 00:22:37 +00:00
parent b5a63113f3
commit 12e7309bf9
2 changed files with 10 additions and 3 deletions

2
debian/changelog vendored
View File

@ -9,6 +9,8 @@ linux (3.16.3-3) UNRELEASED; urgency=low
FB_SIS, FB_3DFX, FB_VOODOO1 back to modules (Closes: #748398)
* udeb: Add pata_rdc to pata-modules (Closes: #633128)
* [s390*] 3215: fix tty output containing tabs (Closes: #758264)
* radeon: Don't check for installed firmware if driver is built-in
(Closes: #763305)
-- Ian Campbell <ijc@debian.org> Sun, 21 Sep 2014 12:09:24 +0100

View File

@ -38,7 +38,7 @@ missing, except for the pre-R600 KMS case.
/*
* KMS wrapper.
* - 2.0.0 - initial interface
@@ -320,6 +323,37 @@ static struct drm_driver driver_old = {
@@ -341,6 +344,42 @@ static struct drm_driver driver_old = {
static struct drm_driver kms_driver;
@ -49,6 +49,10 @@ missing, except for the pre-R600 KMS case.
+ */
+static bool radeon_firmware_installed(void)
+{
+#if IS_BUILTIN(CONFIG_DRM_RADEON)
+ /* It may be too early to tell. Assume it's there. */
+ return true;
+#else
+ struct path path;
+
+ if (kern_path("/lib/firmware/radeon", LOOKUP_DIRECTORY | LOOKUP_FOLLOW,
@ -58,6 +62,7 @@ missing, except for the pre-R600 KMS case.
+ }
+
+ return false;
+#endif
+}
+
+#ifdef CONFIG_DRM_RADEON_UMS
@ -76,7 +81,7 @@ missing, except for the pre-R600 KMS case.
static int radeon_kick_out_firmware_fb(struct pci_dev *pdev)
{
struct apertures_struct *ap;
@@ -346,6 +380,12 @@ static int radeon_pci_probe(struct pci_d
@@ -367,6 +406,12 @@ static int radeon_pci_probe(struct pci_d
{
int ret;
@ -89,7 +94,7 @@ missing, except for the pre-R600 KMS case.
/* Get rid of things like offb */
ret = radeon_kick_out_firmware_fb(pdev);
if (ret)
@@ -577,6 +617,7 @@ static struct pci_driver *pdriver;
@@ -586,6 +631,7 @@ static struct pci_driver *pdriver;
static struct pci_driver radeon_pci_driver = {
.name = DRIVER_NAME,
.id_table = pciidlist,