Readded marvell discovery gigabit ethernet hotplug support.

svn path=/dists/trunk/linux-2.6/; revision=5162
This commit is contained in:
Sven Luther 2006-01-01 16:19:01 +00:00
parent 1644d9cbb2
commit 12ce486b1f
3 changed files with 41 additions and 2 deletions

6
debian/changelog vendored
View File

@ -9,9 +9,11 @@ linux-2.6 (2.6.14+2.6.15-rc7-0experimental.2) UNRELEASED; urgency=low
[ Sven Luther ]
* [powerpc] Readded PReP Motorola PowerStack II Utah IDE interrupt
(Closes: #345424)
(Closes: #345424)
* [powerpc] Readded Marvell gigabit ethernet hotplug support which is not
yet upstream after all, only went to -mm.
-- Sven Luther <luther@debian.org> Sat, 31 Dec 2005 15:05:18 +0000
-- Sven Luther <luther@debian.org> Sun, 1 Jan 2006 16:14:02 +0000
linux-2.6 (2.6.14+2.6.15-rc7-0experimental.1) experimental; urgency=low

View File

@ -0,0 +1,35 @@
#
# Hotplug support patch for mv643xx_eth driver used on pegasos machines.
# Author: Nicolas Det <nicolas.det@bplan-gmbh.de>
# Upstream status: In the process of being submitted, may need a bit of
# cleanup in order to not break embedded arches using this controller, but
# should not be a worry for debian.
#
--- linux-2.6.14-rc1/drivers/net/mv643xx_eth.c 2005-09-14 08:15:11.000065096 +0200
+++ linux-2.6.14-rc1_nico/drivers/net/mv643xx_eth.c 2005-09-15 12:57:50.646269250 +0200
@@ -1533,6 +1533,9 @@
printk(KERN_NOTICE "%s: RX NAPI Enabled \n", dev->name);
#endif
+ if (mp->tx_sram_size > 0)
+ printk(KERN_NOTICE "%s: Using SRAM\n", dev->name);
+
return 0;
out:
@@ -1640,6 +1643,15 @@
" and Dale Farnsworth");
MODULE_DESCRIPTION("Ethernet driver for Marvell MV643XX");
+#include <linux/pci.h>
+
+static struct pci_device_id pci_marvell_mv64360[] = {
+ { PCI_DEVICE(PCI_VENDOR_ID_MARVELL, PCI_DEVICE_ID_MARVELL_MV64360) },
+ { }
+ };
+
+MODULE_DEVICE_TABLE(pci, pci_marvell_mv64360);
+
/*
* The second part is the low level driver of the gigE ethernet ports.
*/

View File

@ -0,0 +1,2 @@
+ powerpc-mv643xx-hotplug-support.patch