add ssb followup fixlet found in F-12 tree

svn path=/dists/sid/linux-2.6/; revision=15459
This commit is contained in:
Maximilian Attems 2010-03-30 21:56:54 +00:00
parent 67d40d322e
commit 12584987f7
3 changed files with 32 additions and 0 deletions

1
debian/changelog vendored
View File

@ -22,6 +22,7 @@ linux-2.6 (2.6.32-11) UNRELEASED; urgency=low
* Update openvz patch to 796e80e5b2ed. (closes: #574598, #575189)
* [x86]: Disable FB_INTEL. (closes: #447575, #503766, #574401)
* ssb: do not read SPROM if it does not exist.
* ssb: Avoid null pointer dereference by aboves.
[ Bastian Blank ]
* Update Xen patch.

View File

@ -0,0 +1,30 @@
From ec032742062ad1b01dfe75cfccdbc5b850837c23 Mon Sep 17 00:00:00 2001
From: John W. Linville <linville@tuxdriver.com>
Date: Tue, 30 Mar 2010 13:47:39 -0400
Subject: [PATCH] ssb: avoid null ptr deref in ssb_is_sprom_available
Some older devices don't have chipcommon, but they do have SPROM.
Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
drivers/ssb/sprom.c | 4 ++++
1 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/drivers/ssb/sprom.c b/drivers/ssb/sprom.c
index 55eb9b0..874d8f1 100644
--- a/drivers/ssb/sprom.c
+++ b/drivers/ssb/sprom.c
@@ -178,6 +178,10 @@ const struct ssb_sprom *ssb_get_fallback_sprom(void)
bool ssb_is_sprom_available(struct ssb_bus *bus)
{
+ /* some older devices don't have chipcommon, but they have sprom */
+ if (!bus->chipco.dev)
+ return true;
+
/* status register only exists on chipcomon rev >= 11 */
if (bus->chipco.dev->id.revision < 11)
return true;
--
1.6.2.5

View File

@ -10,3 +10,4 @@
+ features/all/nouveau-nv50-Implement-ctxprog-state-generation.patch
+ bugfix/all/nouveau-nv50-Make-ctxprog-wait-for-interrupt-handler.patch
+ bugfix/all/nouveau-nv50-Fix-NEWCTX_DONE-flag-number.patch
+ bugfix/all/ssb_check_for_sprom-fix.patch