[armhf] Add patch to fix loading of imx6q-cpufreq module.

This commit is contained in:
Vagrant Cascadian 2018-04-12 01:12:40 -07:00
parent d192eb7555
commit 10b9c6345e
3 changed files with 36 additions and 0 deletions

3
debian/changelog vendored
View File

@ -15,6 +15,9 @@ linux (4.15.11-2) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* wireless: Disable regulatory.db direct loading (see #892229)
[ Vagrant Cascadian ]
* [armhf] Add patch to fix loading of imx6q-cpufreq module.
-- Roger Shimizu <rogershimizu@gmail.com> Fri, 23 Mar 2018 21:10:34 +0900
linux (4.15.11-1) unstable; urgency=medium

View File

@ -0,0 +1,32 @@
From d0404738c687c0ecaa7d6b7c5c39e4c0dac791e6 Mon Sep 17 00:00:00 2001
From: Nicolas Chauvet <kwizart@gmail.com>
Date: Tue, 30 Jan 2018 10:55:26 +0100
Subject: [PATCH] arm: imx: Add MODULE_ALIAS for cpufreq
Without this, the imx6q-cpufreq driver isn't loaded
automatically when built as a module
Tested on wandboard quad with a fedora 27 kernel rpm
Signed-off-by: Nicolas Chauvet <kwizart@gmail.com>
Acked-by: Viresh Kumar <viresh.kumar@linaro.org>
Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
---
drivers/cpufreq/imx6q-cpufreq.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/cpufreq/imx6q-cpufreq.c b/drivers/cpufreq/imx6q-cpufreq.c
index 741f22e5cee3..ff67859948b3 100644
--- a/drivers/cpufreq/imx6q-cpufreq.c
+++ b/drivers/cpufreq/imx6q-cpufreq.c
@@ -504,6 +504,7 @@ static struct platform_driver imx6q_cpufreq_platdrv = {
};
module_platform_driver(imx6q_cpufreq_platdrv);
+MODULE_ALIAS("platform:imx6q-cpufreq");
MODULE_AUTHOR("Shawn Guo <shawn.guo@linaro.org>");
MODULE_DESCRIPTION("Freescale i.MX6Q cpufreq driver");
MODULE_LICENSE("GPL");
--
2.11.0

View File

@ -136,6 +136,7 @@ bugfix/all/cpupower-bump-soname-version.patch
bugfix/all/cpupower-fix-checks-for-cpu-existence.patch
bugfix/all/lockdep-stub-nmi-watchdog-reset.patch
bugfix/arm64/ARM64-dts-meson-reduce-odroid-c2-eMMC-maximum-rate.patch
bugfix/arm/arm-imx-Add-MODULE_ALIAS-for-cpufreq.patch
# Backport patches from linux-next (next-20180103) to support SMP on tegra210 systems
features/arm64/tegra210-smp/0001-arm64-tegra-Add-CPU-and-PSCI-nodes-for-NVIDIA-Tegra2.patch