add stable 2.6.21.1

strange changelog

svn path=/dists/trunk/linux-2.6/; revision=8527
This commit is contained in:
Maximilian Attems 2007-04-28 16:58:14 +00:00
parent b023a2a707
commit 10a1d1b01a
3 changed files with 32 additions and 1 deletions

5
debian/changelog vendored
View File

@ -20,6 +20,9 @@ linux-2.6 (2.6.21-1~experimental.1) UNRELEASED; urgency=low
CONFIG_BLK_DEV_IT8213, CONFIG_BLK_DEV_TC86C001, CONFIG_INPUT_ATLAS_BTNS,
CONFIG_SENSORS_ADM1029, CONFIG_FB_SVGALIB, CONFIG_FB_S3,
CONFIG_USB_KC2190, CONFIG_KS0108.
* Add stable release 2.6.21.1:
- IPV4: Fix OOPS'er added to netlink fib.
- IPV6: Fix for RT0 header ipv6 change.
[ Martin Michlmayr ]
* Add armel (arm with EABI) support. Thanks, Lennert Buytenhek and
@ -30,7 +33,7 @@ linux-2.6 (2.6.21-1~experimental.1) UNRELEASED; urgency=low
* mips/sb1: Don't build CONFIG_ATA into the kernel.
* mips/sb1: Unset CONFIG_USB_{KBD,MOUSE} since the generic HID is used.
-- maximilian attems <maks@debian.org> Tue, 10 Apr 2007 14:42:30 +0200
-- maximilian attems <maks@debian.org> Sat, 28 Apr 2007 18:53:40 +0200
linux-2.6 (2.6.20-3) UNRELEASED; urgency=low

27
debian/patches/bugfix/2.6.21.1 vendored Normal file
View File

@ -0,0 +1,27 @@
diff --git a/net/ipv4/fib_frontend.c b/net/ipv4/fib_frontend.c
index cac06c4..444a56b 100644
--- a/net/ipv4/fib_frontend.c
+++ b/net/ipv4/fib_frontend.c
@@ -777,6 +777,10 @@ static void nl_fib_lookup(struct fib_result_nl *frn, struct fib_table *tb )
.tos = frn->fl_tos,
.scope = frn->fl_scope } } };
+#ifdef CONFIG_IP_MULTIPLE_TABLES
+ res.r = NULL;
+#endif
+
frn->err = -ENOENT;
if (tb) {
local_bh_disable();
diff --git a/net/ipv6/exthdrs.c b/net/ipv6/exthdrs.c
index fb39604..3205ec9 100644
--- a/net/ipv6/exthdrs.c
+++ b/net/ipv6/exthdrs.c
@@ -396,6 +396,7 @@ static int ipv6_rthdr_rcv(struct sk_buff **skbp)
switch (hdr->type) {
#ifdef CONFIG_IPV6_MIP6
+ case IPV6_SRCRT_TYPE_2:
break;
#endif
case IPV6_SRCRT_TYPE_0:

View File

@ -36,3 +36,4 @@
+ bugfix/forcedeth-napi-broken.patch
+ bugfix/powerpc/drivers_macintosh-broken.patch
+ bugfix/ia64/hardcode-arch-script-output.patch
+ bugfix/2.6.21.1