dont apply

svn path=/dists/trunk/linux-2.6/; revision=7586
This commit is contained in:
Martin Michlmayr 2006-10-09 10:19:22 +00:00
parent 1cde678513
commit 1073f401f0
4 changed files with 0 additions and 60 deletions

2
debian/changelog vendored
View File

@ -19,8 +19,6 @@ linux-2.6 (2.6.18-3) UNRELEASED; urgency=low
* [mips] Apply some patches from linux-mips' linux-2.6.18-stable GIT tree:
- The o32 fstatat syscall behaves differently on 32 and 64 bit kernels
- fstatat syscall names
- Have headers_install install <asm/cachectl.h> and <asm/sysmips.h>.
- SB1250: Interrupt handler fixes
- BCM1480: Mask pending interrupts against c0_status.im.
- Cobalt: Time runs too quickly
- Show actual CPU information in /proc/cpuinfo

View File

@ -1,19 +0,0 @@
From: Ralf Baechle <ralf@linux-mips.org>
Date: Sat, 23 Sep 2006 17:08:36 +0000 (+0100)
Subject: [MIPS] Have headers_install install <asm/cachectl.h> and <asm/sysmips.h>.
X-Git-Tag: linux-1.1.68
X-Git-Url: http://www.linux-mips.org/git?p=linux.git;a=commitdiff;h=e70d9b79a35ac822ec5913278d2472aa728d1476
[MIPS] Have headers_install install <asm/cachectl.h> and <asm/sysmips.h>.
Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
(cherry picked from 2ff556ab120549346660fd7e0cd25782ebe5381d commit)
---
--- a/include/asm-mips/Kbuild
+++ b/include/asm-mips/Kbuild
@@ -1,3 +1,3 @@
include include/asm-generic/Kbuild.asm
-header-y += sgidefs.h
+header-y += cachectl.h sgidefs.h sysmips.h

View File

@ -1,37 +0,0 @@
From: Maciej W. Rozycki <macro@linux-mips.org>
Date: Tue, 3 Oct 2006 11:42:02 +0000 (+0100)
Subject: [MIPS] SB1250: Interrupt handler fixes
X-Git-Tag: linux-1.1.68
X-Git-Url: http://www.linux-mips.org/git?p=linux.git;a=commitdiff;h=c9477be2bb9e9a1885630627f439d19d7df6d33a
[MIPS] SB1250: Interrupt handler fixes
Mask cp0.status against cp0.cause. Additionally, spurious interrupts are
not recorded.
Signed-off-by: Maciej W. Rozycki <macro@linux-mips.org>
Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
(cherry picked from 0196782e2ac607a19cfc88d9d2bd3f3f03e5908b commit)
---
--- a/arch/mips/sibyte/sb1250/irq.c
+++ b/arch/mips/sibyte/sb1250/irq.c
@@ -442,7 +442,7 @@ asmlinkage void plat_irq_dispatch(struct
* blasting the high 32 bits.
*/
- pending = read_c0_cause();
+ pending = read_c0_cause() & read_c0_status();
#ifdef CONFIG_SIBYTE_SB1250_PROF
if (pending & CAUSEF_IP7) /* Cpu performance counter interrupt */
@@ -476,5 +476,8 @@ asmlinkage void plat_irq_dispatch(struct
R_IMR_INTERRUPT_STATUS_BASE)));
if (mask)
do_IRQ(fls64(mask) - 1, regs);
- }
+ else
+ spurious_interrupt(regs);
+ } else
+ spurious_interrupt(regs);
}

View File

@ -1,8 +1,6 @@
+ alpha-prctl.patch
+ bugfix/mips/o32_fstatat_syscall.patch
+ bugfix/mips/fstatat_syscall_names.patch
+ bugfix/mips/headers_install-add.patch
+ bugfix/mips/sb1250_interrupt_fixes.patch
+ bugfix/mips/sb1480_interrupt_fixes.patch
+ bugfix/mips/cobalt_hz.patch
+ bugfix/mips/real-cpu-cpuinfo.patch