atl1c: fix issue of transmit queue 0 timed out

svn path=/dists/sid/linux/; revision=19272
This commit is contained in:
Ben Hutchings 2012-07-22 02:37:20 +00:00
parent c0468ba004
commit 1069c39990
3 changed files with 38 additions and 0 deletions

1
debian/changelog vendored
View File

@ -42,6 +42,7 @@ linux (3.2.23-1) UNRELEASED; urgency=low
(Closes: #658662)
* cipso: don't follow a NULL pointer when setsockopt() is called
* [x86] hwmon: Enable SENSORS_SCH5636 as module (Closes: #680934)
* atl1c: fix issue of transmit queue 0 timed out
[ Arnaud Patard ]
* [mipsel] add r8169 to d-i udeb.

View File

@ -0,0 +1,36 @@
From: Cloud Ren <cjren@qca.qualcomm.com>
Date: Tue, 3 Jul 2012 16:51:48 +0000
Subject: atl1c: fix issue of transmit queue 0 timed out
commit b94e52f62683dc0b00c6d1b58b80929a078c0fd5 upstream.
some people report atl1c could cause system hang with following
kernel trace info:
---------------------------------------
WARNING: at.../net/sched/sch_generic.c:258 dev_watchdog+0x1db/0x1d0()
...
NETDEV WATCHDOG: eth0 (atl1c): transmit queue 0 timed out
...
---------------------------------------
This is caused by netif_stop_queue calling when cable Link is down.
So remove netif_stop_queue, because link_watch will take it over.
Signed-off-by: xiong <xiong@qca.qualcomm.com>
Signed-off-by: Cloud Ren <cjren@qca.qualcomm.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
drivers/net/ethernet/atheros/atl1c/atl1c_main.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/net/ethernet/atheros/atl1c/atl1c_main.c b/drivers/net/ethernet/atheros/atl1c/atl1c_main.c
index 9cc1570..1f78b63 100644
--- a/drivers/net/ethernet/atheros/atl1c/atl1c_main.c
+++ b/drivers/net/ethernet/atheros/atl1c/atl1c_main.c
@@ -261,7 +261,6 @@ static void atl1c_check_link_status(struct atl1c_adapter *adapter)
if ((phy_data & BMSR_LSTATUS) == 0) {
/* link down */
netif_carrier_off(netdev);
- netif_stop_queue(netdev);
hw->hibernate = true;
if (atl1c_reset_mac(hw) != 0)
if (netif_msg_hw(adapter))

View File

@ -382,3 +382,4 @@ features/all/fermi-accel/drm-nouveau-bump-version-to-1.0.0.patch
bugfix/all/net-e100-ucode-is-optional-in-some-cases.patch
bugfix/x86/drm-i915-prefer-wide-slow-to-fast-narrow-in-DP-confi.patch
bugfix/all/cipso-don-t-follow-a-NULL-pointer-when-setsockopt-is.patch
bugfix/all/atl1c-fix-issue-of-transmit-queue-0-timed-out.patch