aufs: Update to aufs3.14-20140407 (no functional changes)

svn path=/dists/trunk/linux/; revision=21215
This commit is contained in:
Ben Hutchings 2014-04-08 02:09:26 +00:00
parent 40bb5a4cb2
commit 0fc145e9db
6 changed files with 36 additions and 35 deletions

1
debian/changelog vendored
View File

@ -7,6 +7,7 @@ linux (3.14-1~exp1) UNRELEASED; urgency=medium
NFT_CHAIN_NAT_IPV4, NF_TABLES_ARP, NF_TABLES_IPV6, NFT_CHAIN_ROUTE_IPV6,
NFT_CHAIN_NAT_IPV6 as modules (Closes: #742763)
* udeb: Update sound-modules, thanks to Samuel Thibault (Closes: #743319)
* aufs: Update to aufs3.14-20140407 (no functional changes)
-- Ben Hutchings <ben@decadent.org.uk> Wed, 26 Mar 2014 13:31:44 +0000

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Mar 4 16:25:00 2014 +0900
Subject: aufs3.x-rcN-20140310
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/c8c0d1456c246f69639c9c9c6b62fa389f8b2eb5/tree/
Date: Tue Apr 1 11:01:55 2014 +0900
Subject: aufs3.14-20140407
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/66ac1c999bb00cd649d702e8b0c8e8ab7fa9b352/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch generated by debian/patches/features/all/aufs3/gen-patch
@ -12932,7 +12932,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+#endif /* __KERNEL__ */
+#endif /* __AUFS_FSTYPE_H__ */
--- a/fs/aufs/hfsnotify.c 1970-01-01 01:00:00.000000000 +0100
+++ b/fs/aufs/hfsnotify.c 2014-03-13 00:59:36.876223577 +0000
+++ b/fs/aufs/hfsnotify.c 2014-04-08 03:07:56.519497471 +0100
@@ -0,0 +1,281 @@
+/*
+ * Copyright (C) 2005-2014 Junjiro R. Okajima
@ -13275,7 +13275,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+ }
+}
--- a/fs/aufs/hnotify.c 1970-01-01 01:00:00.000000000 +0100
+++ b/fs/aufs/hnotify.c 2014-03-13 00:59:36.876223577 +0000
+++ b/fs/aufs/hnotify.c 2014-04-08 03:07:56.523497471 +0100
@@ -0,0 +1,710 @@
+/*
+ * Copyright (C) 2005-2014 Junjiro R. Okajima
@ -23938,7 +23938,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+#endif /* __KERNEL__ */
+#endif /* __AUFS_SPL_H__ */
--- a/fs/aufs/super.c 1970-01-01 01:00:00.000000000 +0100
+++ b/fs/aufs/super.c 2014-03-13 00:59:36.876223577 +0000
+++ b/fs/aufs/super.c 2014-03-15 14:34:47.312348618 +0000
@@ -0,0 +1,1001 @@
+/*
+ * Copyright (C) 2005-2014 Junjiro R. Okajima
@ -31674,7 +31674,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+ return err;
+}
--- a/include/uapi/linux/aufs_type.h 1970-01-01 01:00:00.000000000 +0100
+++ b/include/uapi/linux/aufs_type.h 2014-03-13 00:59:36.876223577 +0000
+++ b/include/uapi/linux/aufs_type.h 2014-04-08 03:07:56.523497471 +0100
@@ -0,0 +1,281 @@
+/*
+ * Copyright (C) 2005-2014 Junjiro R. Okajima
@ -31717,7 +31717,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+
+#include <linux/limits.h>
+
+#define AUFS_VERSION "3.x-rcN-20140310"
+#define AUFS_VERSION "3.14-20140407"
+
+/* todo? move this to linux-2.6.19/include/magic.h */
+#define AUFS_SUPER_MAGIC ('a' << 24 | 'u' << 16 | 'f' << 8 | 's')

View File

@ -1,12 +1,12 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Wed Feb 19 01:13:55 2014 +0900
Subject: aufs3.x-rcN base patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/c8c0d1456c246f69639c9c9c6b62fa389f8b2eb5/tree/
Date: Tue Apr 1 11:01:55 2014 +0900
Subject: aufs3.14 base patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/66ac1c999bb00cd649d702e8b0c8e8ab7fa9b352/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch
aufs3.x-rcN base patch
aufs3.14 base patch
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index 66e8c3b..ec278ac 100644
@ -79,10 +79,10 @@ index 12028fa..f26cbaf 100644
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 6082956..f28435e 100644
index 23b2a35..f3f635c 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -2665,6 +2665,7 @@ extern int inode_change_ok(const struct inode *, struct iattr *);
@@ -2669,6 +2669,7 @@ extern int inode_change_ok(const struct inode *, struct iattr *);
extern int inode_newsize_ok(const struct inode *, loff_t offset);
extern void setattr_copy(struct inode *inode, const struct iattr *attr);

View File

@ -1,12 +1,12 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Wed Feb 19 01:13:55 2014 +0900
Subject: aufs3.x-rcN kbuild patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/c8c0d1456c246f69639c9c9c6b62fa389f8b2eb5/tree/
Date: Tue Apr 1 11:01:55 2014 +0900
Subject: aufs3.14 kbuild patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/66ac1c999bb00cd649d702e8b0c8e8ab7fa9b352/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch
aufs3.x-rcN kbuild patch
aufs3.14 kbuild patch
diff --git a/fs/Kconfig b/fs/Kconfig
index 7385e54..d5c769c 100644

View File

@ -1,12 +1,12 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Mar 4 16:25:00 2014 +0900
Subject: aufs3.x-rcN mmap patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/c8c0d1456c246f69639c9c9c6b62fa389f8b2eb5/tree/
Date: Tue Apr 1 11:01:55 2014 +0900
Subject: aufs3.14 mmap patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/66ac1c999bb00cd649d702e8b0c8e8ab7fa9b352/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch
aufs3.x-rcN mmap patch
aufs3.14 mmap patch
diff --git a/fs/buffer.c b/fs/buffer.c
index 27265a8..75427a6 100644
@ -75,7 +75,7 @@ index 678455d..ad0ce45 100644
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index f28f46e..edfbda3 100644
index c1b7414..02036e0 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -18,6 +18,9 @@
@ -88,7 +88,7 @@ index f28f46e..edfbda3 100644
struct mempolicy;
struct anon_vma;
@@ -1142,6 +1145,87 @@ static inline int fixup_user_fault(struct task_struct *tsk,
@@ -1152,6 +1155,87 @@ static inline int fixup_user_fault(struct task_struct *tsk,
}
#endif
@ -223,10 +223,10 @@ index 7a13f6a..f1805df 100644
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/fremap.c b/mm/fremap.c
index bbc4d66..7deee2c 100644
index 34feba6..d857364 100644
--- a/mm/fremap.c
+++ b/mm/fremap.c
@@ -211,7 +211,9 @@ get_write_lock:
@@ -227,7 +227,9 @@ get_write_lock:
/* mmap_region may free vma; grab the info now */
vm_flags = vma->vm_flags;

View File

@ -1,12 +1,12 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Mar 4 16:25:00 2014 +0900
Subject: aufs3.x-rcN standalone patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/c8c0d1456c246f69639c9c9c6b62fa389f8b2eb5/tree/
Date: Tue Apr 1 11:01:55 2014 +0900
Subject: aufs3.14 standalone patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/66ac1c999bb00cd649d702e8b0c8e8ab7fa9b352/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch
aufs3.x-rcN standalone patch
aufs3.14 standalone patch
diff --git a/fs/inode.c b/fs/inode.c
index bc83168..6dd1207 100644
@ -29,10 +29,10 @@ index bc83168..6dd1207 100644
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index 22e5367..6b1b43e 100644
index 2ffc5a2..785a51f 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -425,6 +425,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
@@ -455,6 +455,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
mnt_dec_writers(real_mount(mnt));
preempt_enable();
}
@ -40,7 +40,7 @@ index 22e5367..6b1b43e 100644
/**
* mnt_drop_write - give up write access to a mount
@@ -1509,6 +1510,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
@@ -1555,6 +1556,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -121,7 +121,7 @@ index 923fe4a..176b435 100644
static int fsnotify_mark_destroy(void *ignored)
{
diff --git a/fs/open.c b/fs/open.c
index 4b3e1ed..ce49f2b 100644
index b9ed8b2..3ea66972 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -62,6 +62,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
@ -189,7 +189,7 @@ index d3b6d2c..5076912 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
index 15b6928..ae6eba6 100644
index 919cad9..f9e9e17 100644
--- a/security/security.c
+++ b/security/security.c
@@ -407,6 +407,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)