Remove sparc ABI fix, as we have to bump the ABI number anyway

svn path=/dists/sid/linux/; revision=20448
This commit is contained in:
Ben Hutchings 2013-08-07 12:41:44 +00:00
parent acabcd80cc
commit 0ed1e20322
3 changed files with 0 additions and 27 deletions

2
debian/changelog vendored
View File

@ -71,8 +71,6 @@ linux (3.10.5-1) UNRELEASED; urgency=low
dev_priv->dev_priv->mm.inactive_list
[ Ben Hutchings ]
* [sparc] cpufreq: Convince genksyms that the ABI didn't change
(fixes FTBFS)
* [hppa] udeb: Add core-modules package (Closes: #718270)
* nl80211: fix another nl80211_fam.attrbuf race
* Bump ABI to 2

View File

@ -1,24 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 29 Jul 2013 00:05:51 +0100
Subject: [sparc] cpufreq: Convince genksyms that the ABI didn't change
Forwarded: not-needed
genksyms is really stupid: un-including a header whose definitions
didn't appear in the ABI stil changes symbol versions. So restore the
#include <linux/cpu.h> for symbol version purposes.
(This only seems to affect SPARC; on other architectures
<linux/cpu.h> may still be indirectly included.)
--- a/drivers/cpufreq/cpufreq_governor.c
+++ b/drivers/cpufreq/cpufreq_governor.c
@@ -26,6 +26,9 @@
#include <linux/tick.h>
#include <linux/types.h>
#include <linux/workqueue.h>
+#ifdef __GENKSYMS__
+#include <linux/cpu.h>
+#endif
#include "cpufreq_governor.h"

View File

@ -110,7 +110,6 @@ features/all/iwlwifi-bump-required-firmware-API-version-for-3160-.patch
# m68k Kconfig bugfix
bugfix/m68k/ethernat-kconfig.patch
debian/sparc-cpufreq-convince-genksyms-that-the-abi-didnt-change.patch
bugfix/all/nl80211-fix-another-nl80211_fam-attrbuf-race.patch
bugfix/all/ext4-fix-retry-handling-in-ext4_ext_truncate.patch
bugfix/all/atl1c-Fix-misuse-of-netdev_alloc_skb-in-refilling-rx.patch