hwrng: n2 - Attach on T5/M5, T7/M7 SPARC CPUs (Closes: #809815)

This commit is contained in:
Ben Hutchings 2016-02-06 21:25:49 +00:00
parent 8e44bb11ea
commit 0df8f2e3e7
3 changed files with 39 additions and 0 deletions

1
debian/changelog vendored
View File

@ -136,6 +136,7 @@ linux (4.3.5-1) UNRELEASED; urgency=medium
module (Closes: #813640)
* debian/copyright: Add licence information for drivers/crypto/vmx/*.pl
* udeb: Add hid-logitech-hidpp to input-modules (Closes: #796096)
* hwrng: n2 - Attach on T5/M5, T7/M7 SPARC CPUs (Closes: #809815)
[ Salvatore Bonaccorso ]
* netfilter: nf_nat_redirect: add missing NULL pointer check (CVE-2015-8787)

View File

@ -0,0 +1,37 @@
From: Anatoly Pugachev <matorola@gmail.com>
Date: Tue, 26 Jan 2016 00:19:02 +0300
Subject: hwrng: n2 - Attach on T5/M5, T7/M7 SPARC CPUs
Origin: https://git.kernel.org/cgit/linux/kernel/git/herbert/cryptodev-2.6.git/commit?id=c1e9b3b0eea12899b7749571af21cc60822cf2b6
Bug-Debian: https://bugs.debian.org/809815
n2rng: Attach on T5/M5, T7/M7 SPARC CPUs
(space to tab fixes after variable names)
Signed-off-by: Anatoly Pugachev <matorola@gmail.com>
Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
---
drivers/char/hw_random/n2-drv.c | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/drivers/char/hw_random/n2-drv.c b/drivers/char/hw_random/n2-drv.c
index 843d6f6aee7a..3b06c1d6cfb2 100644
--- a/drivers/char/hw_random/n2-drv.c
+++ b/drivers/char/hw_random/n2-drv.c
@@ -743,6 +743,16 @@ static const struct of_device_id n2rng_match[] = {
.compatible = "SUNW,kt-rng",
.data = (void *) 1,
},
+ {
+ .name = "random-number-generator",
+ .compatible = "ORCL,m4-rng",
+ .data = (void *) 1,
+ },
+ {
+ .name = "random-number-generator",
+ .compatible = "ORCL,m7-rng",
+ .data = (void *) 1,
+ },
{},
};
MODULE_DEVICE_TABLE(of, n2rng_match);

View File

@ -141,3 +141,4 @@ debian/usb-fix-abi-change-in-4.3.5.patch
bugfix/all/rt2x00-fix-monitor-mode-regression.patch
bugfix/all/pipe-limit-the-per-user-amount-of-pages-allocated-in.patch
bugfix/all/user_struct-fix-abi-change-for-cve-2013-4312-fix.patch
features/sparc/hwrng-n2-attach-on-t5-m5-t7-m7-sparc-cpus.patch