[alpha] Use gcc-4.6 (Closes: #685894)

svn path=/dists/sid/linux/; revision=19356
This commit is contained in:
Ben Hutchings 2012-08-28 18:11:27 +00:00
parent 05990430e6
commit 0dc8c8d372
4 changed files with 16 additions and 1 deletions

2
debian/changelog vendored
View File

@ -104,6 +104,8 @@ linux (3.2.28-1) UNRELEASED; urgency=low
* input: Enable TOUCHSCREEN_ATMEL_MXT as module (Closes: #685123)
* usb: Add USB_QUIRK_RESET_RESUME for all Logitech UVC webcams
(Closes: #668211)
* [alpha] Use gcc-4.6 (Closes: #685894)
- Use large data model to work around link failure
[ Bastian Blank ]
* Make xen-linux-system meta-packages depend on xen-system. This allows

View File

@ -1,7 +1,6 @@
[base]
flavours: alpha-generic alpha-smp alpha-legacy
kernel-arch: alpha
compiler: gcc-4.5
[image]
suggests: aboot, fdutils

View File

@ -0,0 +1,13 @@
diff --git a/arch/alpha/Makefile b/arch/alpha/Makefile
index 4759fe7..b5d44bd 100644
--- a/arch/alpha/Makefile
+++ b/arch/alpha/Makefile
@@ -12,7 +12,7 @@ NM := $(NM) -B
LDFLAGS_vmlinux := -static -N #-relax
CHECKFLAGS += -D__alpha__ -m64
-cflags-y := -pipe -mno-fp-regs -ffixed-8 -msmall-data
+cflags-y := -pipe -mno-fp-regs -ffixed-8 -mlarge-data
cflags-y += $(call cc-option, -fno-jump-tables)
cpuflags-$(CONFIG_ALPHA_EV4) := -mcpu=ev4

View File

@ -392,3 +392,4 @@ bugfix/all/media-rc-ite-cir-Initialise-ite_dev-rdev-earlier.patch
features/all/USB-add-USB_VENDOR_AND_INTERFACE_INFO-macro.patch
bugfix/all/usb-Add-quirk-detection-based-on-interface-informati.patch
bugfix/all/usb-Add-USB_QUIRK_RESET_RESUME-for-all-Logitech-UVC-.patch
bugfix/alpha/alpha-use-large-data-model.diff