Update to 3.6.2

Drop ite-cir patch applied upstream.
Drop ARM acard workaround; the problem has been fixed differently upstream.

svn path=/dists/trunk/linux/; revision=19437
This commit is contained in:
Ben Hutchings 2012-10-13 08:57:26 +00:00
parent 8b3f39d46e
commit 0d0f3701f1
5 changed files with 15 additions and 70 deletions

3
debian/changelog vendored
View File

@ -1,8 +1,9 @@
linux (3.6.1-1~experimental.1) UNRELEASED; urgency=low
linux (3.6.2-1~experimental.1) UNRELEASED; urgency=low
* New upstream release: http://kernelnewbies.org/Linux_3.6
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.6.1
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.6.2
[ Ben Hutchings ]
* aufs: Update to aufs3.x-rcN-20120827

View File

@ -1,34 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 12 Aug 2012 22:47:41 +0100
Subject: [media] rc: ite-cir: Initialise ite_dev::rdev earlier
Bug-Debian: http://bugs.debian.org/684441
ite_dev::rdev is currently initialised in ite_probe() after
rc_register_device() returns. If a newly registered device is opened
quickly enough, we may enable interrupts and try to use ite_dev::rdev
before it has been initialised. Move it up to the earliest point we
can, right after calling rc_allocate_device().
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/media/rc/ite-cir.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/drivers/media/rc/ite-cir.c
+++ b/drivers/media/rc/ite-cir.c
@@ -1473,6 +1473,7 @@ static int ite_probe(struct pnp_dev *pde
rdev = rc_allocate_device();
if (!rdev)
goto failure;
+ itdev->rdev = rdev;
ret = -ENODEV;
@@ -1604,7 +1605,6 @@ static int ite_probe(struct pnp_dev *pde
if (ret)
goto failure3;
- itdev->rdev = rdev;
ite_pr(KERN_NOTICE, "driver has been successfully loaded\n");
return 0;

View File

@ -1,20 +0,0 @@
From: Gordon Farquharson <gordonfarquharson@gmail.com>
Subject: [arm] Disable SCSI_ACARD
Date: Mon, 12 Nov 2007 04:08:38 +0000
ERROR: "__bad_udelay" [drivers/scsi/atp870u.ko] undefined!
make[1]: *** [__modpost] Error 1
diff --git a/drivers/scsi/Kconfig b/drivers/scsi/Kconfig
index a7a0813..fa6a4fe 100644
--- a/drivers/scsi/Kconfig
+++ b/drivers/scsi/Kconfig
@@ -396,7 +396,7 @@ config SCSI_7000FASST
config SCSI_ACARD
tristate "ACARD SCSI support"
- depends on PCI && SCSI
+ depends on PCI && SCSI && (!ARM || BROKEN)
help
This driver supports the ACARD SCSI host adapter.
Support Chip <ATP870 ATP876 ATP880 ATP885>

View File

@ -8,7 +8,7 @@ are set.
--- a/Makefile
+++ b/Makefile
@@ -806,7 +806,7 @@
@@ -806,7 +806,7 @@ endif
prepare2: prepare3 outputmakefile asm-generic
prepare1: prepare2 include/linux/version.h include/generated/utsrelease.h \
@ -17,7 +17,7 @@ are set.
$(cmd_crmodverdir)
archprepare: archheaders archscripts prepare1 scripts_basic
@@ -838,12 +838,25 @@
@@ -838,12 +838,25 @@ define filechk_version.h
echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))';)
endef
@ -53,7 +53,7 @@ are set.
#include <asm/uaccess.h>
#include <asm/io.h>
#include <linux/atomic.h>
@@ -164,11 +165,12 @@
@@ -164,11 +165,12 @@ static void show_last_breaking_event(str
*/
void dump_stack(void)
{
@ -68,7 +68,7 @@ are set.
printk("Process %s (pid: %d, task: %p, ksp: %p)\n",
current->comm, current->pid, current,
(void *) current->thread.ksp);
@@ -215,11 +217,12 @@
@@ -215,11 +217,12 @@ void show_registers(struct pt_regs *regs
void show_regs(struct pt_regs *regs)
{
print_modules();
@ -93,7 +93,7 @@ are set.
#include <asm/current.h>
#include <asm/ptrace.h>
#include "sysrq.h"
@@ -16,8 +17,9 @@
@@ -16,8 +17,9 @@ void __show_regs(struct pt_regs *regs)
{
printk("\n");
print_modules();
@ -115,7 +115,7 @@ are set.
#include <asm/cpu.h>
#include <asm/apic.h>
#include <asm/syscalls.h>
@@ -147,11 +148,12 @@
@@ -147,11 +148,12 @@ void show_regs_common(void)
/* Board Name is optional */
board = dmi_get_system_info(DMI_BOARD_NAME);
@ -139,7 +139,7 @@ are set.
#include <asm/stacktrace.h>
@@ -188,11 +189,12 @@
@@ -188,11 +189,12 @@ void dump_stack(void)
unsigned long stack;
bp = stack_frame(current, NULL);
@ -156,15 +156,15 @@ are set.
EXPORT_SYMBOL(dump_stack);
--- a/arch/ia64/kernel/process.c
+++ b/arch/ia64/kernel/process.c
@@ -29,6 +29,7 @@
#include <linux/kdebug.h>
@@ -30,6 +30,7 @@
#include <linux/utsname.h>
#include <linux/tracehook.h>
#include <linux/rcupdate.h>
+#include <generated/package.h>
#include <asm/cpu.h>
#include <asm/delay.h>
@@ -112,9 +113,9 @@
@@ -113,9 +114,9 @@ show_regs (struct pt_regs *regs)
print_modules();
printk("\nPid: %d, CPU %d, comm: %20s\n", task_pid_nr(current),
smp_processor_id(), current->comm);
@ -186,7 +186,7 @@ are set.
#include <asm/cacheflush.h>
#include <asm/leds.h>
@@ -278,11 +279,12 @@
@@ -278,11 +279,12 @@ void __show_regs(struct pt_regs *regs)
unsigned long flags;
char buf[64];
@ -211,7 +211,7 @@ are set.
#include <asm/pgtable.h>
#include <asm/uaccess.h>
@@ -644,8 +645,9 @@
@@ -644,8 +645,9 @@ void show_regs(struct pt_regs * regs)
printk("NIP: "REG" LR: "REG" CTR: "REG"\n",
regs->nip, regs->link, regs->ctr);
@ -233,7 +233,7 @@ are set.
#include <asm/uaccess.h>
#include <asm/mmu_context.h>
#include <asm/fpu.h>
@@ -33,10 +34,11 @@
@@ -33,10 +34,11 @@ void show_regs(struct pt_regs * regs)
{
printk("\n");
printk("Pid : %d, Comm: \t\t%s\n", task_pid_nr(current), current->comm);

View File

@ -17,7 +17,6 @@ features/all/aufs3/mark-as-staging.patch
bugfix/ia64/hardcode-arch-script-output.patch
bugfix/mips/disable-advansys.patch
bugfix/arm/disable-scsi_acard.patch
debian/mips-disable-werror.patch
bugfix/powerpc/lpar-console.patch
@ -44,6 +43,5 @@ features/all/cpu-devices/Partially-revert-cpufreq-Add-support-for-x86-cpuinfo.pa
debian/debugfs-set-default-mode-to-700.patch
bugfix/all/media-rc-ite-cir-Initialise-ite_dev-rdev-earlier.patch
bugfix/alpha/alpha-use-large-data-model.diff
bugfix/all/speakup-lower-default-software-speech-rate.patch