Fix building of liblockdep

This commit is contained in:
Bastian Blank 2018-02-11 09:51:44 +01:00
parent f62cccd9a3
commit 0ce4bbe790
3 changed files with 33 additions and 0 deletions

1
debian/changelog vendored
View File

@ -73,6 +73,7 @@ linux (4.15.1-1~exp1) UNRELEASED; urgency=medium
scsi-modules installer udeb.
* Switch to SLUB as kernel allocator. (Closes: #862718)
- Enable SLUB_DEBUG, SLAB_FREELIST_HARDENED except on armel/marvell.
* Fix building of liblockdep.
[ Uwe Kleine-König ]
* [arm64] enable I2C_PXA for espressobin (Closes: #886983)

View File

@ -0,0 +1,31 @@
From 2b14169744f9aeccd09c30926d9f0b6a80ff6156 Mon Sep 17 00:00:00 2001
From: Bastian Blank <waldi@debian.org>
Date: Sun, 11 Feb 2018 06:24:15 +0000
Subject: [PATCH 3/3] lockdep: Stub NMI watchdog reset
---
tools/include/linux/nmi.h | 12 ++++++++++++
1 file changed, 12 insertions(+)
create mode 100644 tools/include/linux/nmi.h
diff --git a/tools/include/linux/nmi.h b/tools/include/linux/nmi.h
new file mode 100644
index 000000000000..81ffb39343cc
--- /dev/null
+++ b/tools/include/linux/nmi.h
@@ -0,0 +1,12 @@
+/* SPDX-License-Identifier: GPL-2.0 */
+/*
+ * linux/include/linux/nmi.h
+ */
+#ifndef LINUX_NMI_H
+#define LINUX_NMI_H
+
+static inline void touch_nmi_watchdog(void)
+{
+}
+
+#endif
--
2.16.1

View File

@ -135,6 +135,7 @@ bugfix/x86/revert-perf-build-fix-libunwind-feature-detection-on.patch
bugfix/all/tools-build-remove-bpf-run-time-check-at-build-time.patch
bugfix/all/cpupower-bump-soname-version.patch
bugfix/all/cpupower-fix-checks-for-cpu-existence.patch
bugfix/all/lockdep-stub-nmi-watchdog-reset.patch
# Backport patches from linux-next (next-20180103) to support SMP on tegra210 systems
features/arm64/tegra210-smp/0001-arm64-tegra-Add-CPU-and-PSCI-nodes-for-NVIDIA-Tegra2.patch