Update to 3.2-rc4

svn path=/dists/trunk/linux-2.6/; revision=18341
This commit is contained in:
Ben Hutchings 2011-12-02 03:48:40 +00:00
parent 009b172275
commit 0a1d59767e
2 changed files with 5 additions and 5 deletions

2
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux-2.6 (3.2~rc3-1~experimental.1) UNRELEASED; urgency=low
linux-2.6 (3.2~rc4-1~experimental.1) UNRELEASED; urgency=low
* New upstream release candidate

View File

@ -10,7 +10,7 @@ delivery problem for real.
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
Signed-off-by: Ingo Molnar <mingo@elte.hu>
[bwh: Adjust context in __remove_hrtimer() for v3.2-rc4]
---
include/linux/hrtimer.h | 3
kernel/hrtimer.c | 190 ++++++++++++++++++++++++++++++++++++++++++-----
@ -127,9 +127,9 @@ Index: linux-3.2/kernel/hrtimer.c
+ goto out;
+ }
+
if (&timer->node == timerqueue_getnext(&base->active)) {
#ifdef CONFIG_HIGH_RES_TIMERS
/* Reprogram the clock event device. if enabled */
next_timer = timerqueue_getnext(&base->active);
timerqueue_del(&base->active, &timer->node);
if (&timer->node == next_timer) {
@@ -1176,6 +1210,7 @@ static void __hrtimer_init(struct hrtime
base = hrtimer_clockid_to_base(clock_id);