[arm64] Update pinebook/teres-i device-tree patches to 4.19.x:

- Enables the lid to wakeup from suspend.
This commit is contained in:
Vagrant Cascadian 2018-10-18 18:53:53 -07:00
parent 201100ffa3
commit 07cd30904b
4 changed files with 87 additions and 1 deletions

4
debian/changelog vendored
View File

@ -263,6 +263,10 @@ linux (4.18.12-1) UNRELEASED; urgency=medium
[ Romain Perier ]
* [rt] Update to 4.18.12-rt7
[ Vagrant Cascadian ]
* [arm64] Update pinebook/teres-i device-tree patches to 4.19.x:
- Enables the lid to wakeup from suspend.
-- Ben Hutchings <ben@decadent.org.uk> Mon, 08 Oct 2018 19:02:53 +0100
linux (4.18.10-2) unstable; urgency=medium

View File

@ -0,0 +1,33 @@
From e4357c82e3a6e3e7142d0ea17c874e2d0bd623d4 Mon Sep 17 00:00:00 2001
From: Icenowy Zheng <icenowy@aosc.io>
Date: Sat, 23 Jun 2018 00:06:30 +0800
Subject: [PATCH 6/7] arm64: allwinner: a64: change TERES-I DLDO3's name to
start with "vdd"
Originally the name of the DLDO3 regulator on TERES-I is "eDP12", which
is not consistent with other regulator names.
Change it to "vdd-edp", in order to make it more consistent.
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
Signed-off-by: Maxime Ripard <maxime.ripard@bootlin.com>
---
arch/arm64/boot/dts/allwinner/sun50i-a64-teres-i.dts | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-teres-i.dts b/arch/arm64/boot/dts/allwinner/sun50i-a64-teres-i.dts
index d9baab3dc96b..02fecc42440c 100644
--- a/arch/arm64/boot/dts/allwinner/sun50i-a64-teres-i.dts
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-teres-i.dts
@@ -210,7 +210,7 @@
&reg_dldo3 {
regulator-min-microvolt = <1200000>;
regulator-max-microvolt = <1200000>;
- regulator-name = "eDP12";
+ regulator-name = "vdd-edp";
};
&reg_dldo4 {
--
2.11.0

View File

@ -0,0 +1,47 @@
From 48f3e7bf38db6603bf88ef889ade8df408d81cc4 Mon Sep 17 00:00:00 2001
From: Icenowy Zheng <icenowy@aosc.io>
Date: Sat, 23 Jun 2018 00:06:31 +0800
Subject: [PATCH 7/7] arm64: allwinner: a64: allow laptops to wake up from lid
Currently all ARM kernels will have s2idle enabled if CONFIG_SUSPEND is
present. In this case if the lid is closed, systemd-logind will enter
s2idle mode by default; however there's no possible wakeup source
defined, so the system will enter a forever idle.
Add the lid itself as a wakeup source, thus the system can wakeup when
the lid is opened.
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
Signed-off-by: Maxime Ripard <maxime.ripard@bootlin.com>
---
arch/arm64/boot/dts/allwinner/sun50i-a64-pinebook.dts | 1 +
arch/arm64/boot/dts/allwinner/sun50i-a64-teres-i.dts | 1 +
2 files changed, 2 insertions(+)
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-pinebook.dts b/arch/arm64/boot/dts/allwinner/sun50i-a64-pinebook.dts
index 58253d6f9be1..e6e5bf11b759 100644
--- a/arch/arm64/boot/dts/allwinner/sun50i-a64-pinebook.dts
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-pinebook.dts
@@ -49,6 +49,7 @@
linux,input-type = <EV_SW>;
linux,code = <SW_LID>;
linux,can-disable;
+ wakeup-source;
};
};
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-teres-i.dts b/arch/arm64/boot/dts/allwinner/sun50i-a64-teres-i.dts
index 02fecc42440c..33f78e745815 100644
--- a/arch/arm64/boot/dts/allwinner/sun50i-a64-teres-i.dts
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-teres-i.dts
@@ -38,6 +38,7 @@
gpios = <&r_pio 0 8 GPIO_ACTIVE_LOW>; /* PL8 */
linux,input-type = <EV_SW>;
linux,code = <SW_LID>;
+ wakeup-source;
};
};
--
2.11.0

View File

@ -82,12 +82,14 @@ features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch
features/mips/MIPS-Loongson-3-Add-Loongson-LS3A-RS780E-1-way-machi.patch
features/x86/x86-memtest-WARN-if-bad-RAM-found.patch
features/x86/x86-make-x32-syscall-support-conditional.patch
# Add device-tree for Pinebook from linux next-20180625
# Add device-tree for Pinebook from linux 4.19.x
features/arm64/pinebook/0001-arm64-allwinner-a64-Add-RTC-clock-to-phandle-32kHz-e.patch
features/arm64/pinebook/0002-arm64-dts-allwinner-a64-add-R_I2C-controller.patch
features/arm64/pinebook/0003-arm64-dts-allwinner-a64-Add-PWM-controllers.patch
features/arm64/pinebook/0004-arm64-dts-allwinner-add-support-for-Pinebook.patch
features/arm64/pinebook/0005-arm64-dts-allwinner-a64-add-SRAM-controller-device-t.patch
features/arm64/pinebook/0006-arm64-allwinner-a64-change-TERES-I-DLDO3-s-name-to-s.patch
features/arm64/pinebook/0007-arm64-allwinner-a64-allow-laptops-to-wake-up-from-li.patch
features/powerpc/mtd-powernv_flash-set-of_node-in-mtd-s-dev.patch
# Miscellaneous bug fixes