aufs: Update to aufs3.x-rcN-20120827

svn path=/dists/trunk/linux/; revision=19427
This commit is contained in:
Ben Hutchings 2012-10-10 01:36:42 +00:00
parent b8b95c0608
commit 07053da62e
6 changed files with 211 additions and 355 deletions

3
debian/changelog vendored
View File

@ -4,6 +4,9 @@ linux (3.6.1-1~experimental.1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.6.1
[ Ben Hutchings ]
* aufs: Update to aufs3.x-rcN-20120827
-- Bastian Blank <waldi@debian.org> Thu, 04 Oct 2012 17:50:39 +0200
linux (3.5.5-1~experimental.1) experimental; urgency=low

File diff suppressed because it is too large Load Diff

View File

@ -1,7 +1,7 @@
aufs3.5 base patch
aufs3.x-rcN base patch
diff --git a/fs/inode.c b/fs/inode.c
index c99163b..7f772fd 100644
index ac8d904..7b2c8fa 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1491,7 +1491,7 @@ static int relatime_need_update(struct vfsmount *mnt, struct inode *inode,
@ -13,24 +13,11 @@ index c99163b..7f772fd 100644
{
if (inode->i_op->update_time)
return inode->i_op->update_time(inode, time, flags);
diff --git a/fs/namei.c b/fs/namei.c
index 7d69419..18c9782 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1864,7 +1864,7 @@ int vfs_path_lookup(struct dentry *dentry, struct vfsmount *mnt,
* needs parent already locked. Doesn't follow mounts.
* SMP-safe.
*/
-static struct dentry *lookup_hash(struct nameidata *nd)
+struct dentry *lookup_hash(struct nameidata *nd)
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
diff --git a/fs/splice.c b/fs/splice.c
index 7bf08fa..e3c40b5 100644
index 41514dd..663b402 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -1090,8 +1090,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
@@ -1093,8 +1093,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
/*
* Attempt to initiate a splice from pipe to file.
*/
@ -41,7 +28,7 @@ index 7bf08fa..e3c40b5 100644
{
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
loff_t *, size_t, unsigned int);
@@ -1118,9 +1118,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
@@ -1121,9 +1121,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
/*
* Attempt to initiate a splice from a file to a pipe.
*/
@ -55,10 +42,10 @@ index 7bf08fa..e3c40b5 100644
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 17fd887..9c75a47 100644
index aa11047..9116d2e 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -2591,6 +2591,7 @@ extern int inode_change_ok(const struct inode *, struct iattr *);
@@ -2741,6 +2741,7 @@ extern int inode_change_ok(const struct inode *, struct iattr *);
extern int inode_newsize_ok(const struct inode *, loff_t offset);
extern void setattr_copy(struct inode *inode, const struct iattr *attr);
@ -66,18 +53,6 @@ index 17fd887..9c75a47 100644
extern int file_update_time(struct file *file);
extern int generic_show_options(struct seq_file *m, struct dentry *root);
diff --git a/include/linux/namei.h b/include/linux/namei.h
index ffc0213..ef35a31 100644
--- a/include/linux/namei.h
+++ b/include/linux/namei.h
@@ -85,6 +85,7 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry *dentry,
int (*open)(struct inode *, struct file *));
+extern struct dentry *lookup_hash(struct nameidata *nd);
extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
extern int follow_down_one(struct path *);
diff --git a/include/linux/splice.h b/include/linux/splice.h
index 09a545a..1ac5727 100644
--- a/include/linux/splice.h

View File

@ -1,4 +1,4 @@
aufs3.5 kbuild patch
aufs3.x-rcN kbuild patch
diff --git a/fs/Kconfig b/fs/Kconfig
index f95ae3a..6d8a9a5 100644
@ -22,7 +22,7 @@ index 2fb9779..abefac5 100644
obj-$(CONFIG_PSTORE) += pstore/
+obj-$(CONFIG_AUFS_FS) += aufs/
diff --git a/include/linux/Kbuild b/include/linux/Kbuild
index 8760be3..a1b8446 100644
index fa21760..ee029e3 100644
--- a/include/linux/Kbuild
+++ b/include/linux/Kbuild
@@ -66,6 +66,7 @@ header-y += atmppp.h

View File

@ -1,10 +1,10 @@
aufs3.5 standalone patch
aufs3.x-rcN standalone patch
diff --git a/fs/file_table.c b/fs/file_table.c
index a305d9e..6a768be 100644
index 701985e..a9fe741 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -35,6 +35,7 @@ struct files_stat_struct files_stat = {
@@ -37,6 +37,7 @@ struct files_stat_struct files_stat = {
};
DEFINE_LGLOCK(files_lglock);
@ -12,7 +12,7 @@ index a305d9e..6a768be 100644
/* SLAB cache for file structures */
static struct kmem_cache *filp_cachep __read_mostly;
@@ -441,6 +442,8 @@ void file_sb_list_del(struct file *file)
@@ -509,6 +510,8 @@ void file_sb_list_del(struct file *file)
}
}
@ -22,7 +22,7 @@ index a305d9e..6a768be 100644
/*
diff --git a/fs/inode.c b/fs/inode.c
index 7f772fd..e789d2f 100644
index 7b2c8fa..0c4318d 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -56,6 +56,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
@ -41,20 +41,8 @@ index 7f772fd..e789d2f 100644
/**
* touch_atime - update the access time
diff --git a/fs/namei.c b/fs/namei.c
index 18c9782..f09edf3 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1868,6 +1868,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
+EXPORT_SYMBOL_GPL(lookup_hash);
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
index 1e4a5fe..06aa768 100644
index 4d31f73..fe1eca1 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -50,6 +50,7 @@ EXPORT_SYMBOL_GPL(fs_kobj);
@ -65,7 +53,7 @@ index 1e4a5fe..06aa768 100644
static inline unsigned long hash(struct vfsmount *mnt, struct dentry *dentry)
{
@@ -1341,6 +1342,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
@@ -1401,6 +1402,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -135,7 +123,7 @@ index f104d56..54f36db 100644
static int fsnotify_mark_destroy(void *ignored)
{
diff --git a/fs/open.c b/fs/open.c
index 1540632..2463289 100644
index e1f2cdb..2804cd6 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -60,6 +60,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
@ -147,10 +135,10 @@ index 1540632..2463289 100644
static long do_sys_truncate(const char __user *pathname, loff_t length)
{
diff --git a/fs/splice.c b/fs/splice.c
index e3c40b5..3afc547 100644
index 663b402..51e1deb 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -1114,6 +1114,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
@@ -1117,6 +1117,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return splice_write(pipe, out, ppos, len, flags);
}
@ -158,7 +146,7 @@ index e3c40b5..3afc547 100644
/*
* Attempt to initiate a splice from a file to a pipe.
@@ -1140,6 +1141,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
@@ -1143,6 +1144,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return splice_read(in, ppos, pipe, len, flags);
}

10
debian/patches/series vendored
View File

@ -8,12 +8,12 @@ features/all/sound-pci-cs46xx-request_firmware.patch
# Patches and source files from aufs3 repository, imported with
# debian/patches/features/all/aufs3/gen-patch.
#features/all/aufs3/aufs3-base.patch
#features/all/aufs3/aufs3-standalone.patch
#features/all/aufs3/aufs3-kbuild.patch
#features/all/aufs3/aufs3-add.patch
features/all/aufs3/aufs3-base.patch
features/all/aufs3/aufs3-standalone.patch
features/all/aufs3/aufs3-kbuild.patch
features/all/aufs3/aufs3-add.patch
# mark as staging/crap
#features/all/aufs3/mark-as-staging.patch
features/all/aufs3/mark-as-staging.patch
bugfix/ia64/hardcode-arch-script-output.patch
bugfix/mips/disable-advansys.patch