input: Add 4 additional exports for modular speakup and braille support.

add the patch by Samuel Thibault <samuel.thibault@ens-lyon.org>

svn path=/dists/trunk/linux-2.6/; revision=10980
This commit is contained in:
Maximilian Attems 2008-03-27 20:12:35 +00:00
parent 9cc8c05668
commit 06fffa8469
3 changed files with 51 additions and 0 deletions

1
debian/changelog vendored
View File

@ -35,6 +35,7 @@ linux-2.6 (2.6.25~rc7-1~experimental.1) UNRELEASED; urgency=low
* topconfig: Centralize old IEEE80211 stack options. (closes: #470558)
* control.source.in: Newer standard version without changes.
* copyright: adapt to latest lintian recommendation.
* input: Add 4 additional exports for modular speakup and braille support.
[ Martin Michlmayr ]
* [arm/armel] Add a kernel for Orion based devices, such as the QNAP

View File

@ -0,0 +1,49 @@
From: Samuel Thibault <samuel.thibault@ens-lyon.org>
Date: Thu, 27 Mar 2008 17:57:07 +0100
Subject: modular braille + speakup support
- Vanilla 2.6.24 has keyboard/VT notifier support
- both braille module and speakup need additional 4 exports to work
diff -puN drivers/char/consolemap.c~basic-braille-screen-reader-support drivers/char/consolemap.c
--- a/drivers/char/consolemap.c~basic-braille-screen-reader-support
+++ a/drivers/char/consolemap.c
@@ -277,6 +277,7 @@ u16 inverse_translate(struct vc_data *co
return p->inverse_translations[m][glyph];
}
}
+EXPORT_SYMBOL_GPL(inverse_translate);
static void update_user_maps(void)
{
diff -puN drivers/char/keyboard.c~basic-braille-screen-reader-support drivers/char/keyboard.c
--- a/drivers/char/keyboard.c~basic-braille-screen-reader-support
+++ a/drivers/char/keyboard.c
@@ -109,6 +109,7 @@ const int max_vals[] = {
const int NR_TYPES = ARRAY_SIZE(max_vals);
struct kbd_struct kbd_table[MAX_NR_CONSOLES];
+EXPORT_SYMBOL_GPL(kbd_table);
static struct kbd_struct *kbd = kbd_table;
struct vt_spawn_console vt_spawn_con = {
@@ -259,6 +260,7 @@ void kd_mksound(unsigned int hz, unsigne
} else
kd_nosound(0);
}
+EXPORT_SYMBOL_GPL(kd_mksound);
/*
* Setting the keyboard rate.
diff -puN drivers/char/vt.c~basic-braille-screen-reader-support drivers/char/vt.c
--- a/drivers/char/vt.c~basic-braille-screen-reader-support
+++ a/drivers/char/vt.c
@@ -4003,6 +4003,7 @@ u16 screen_glyph(struct vc_data *vc, int
c |= 0x100;
return c;
}
+EXPORT_SYMBOL_GPL(screen_glyph);
/* used by vcs - note the word offset */
unsigned short *screen_pos(struct vc_data *vc, int w_offset, int viewed)

View File

@ -11,6 +11,7 @@
+ debian/dfsg/drivers-net-bnx2-request_firmware-1.patch
+ features/all/export-gfs2-locking-symbols.patch
+ features/all/export-unionfs-symbols.patch
+ features/all/export-input-braille.patch
#+ bugfix/powerpc/mv643xx-hotplug-support.patch
+ bugfix/powerpc/oldworld-boot-fix.patch