Update to 4.18-rc5

This commit is contained in:
Ben Hutchings 2018-07-16 01:41:49 +01:00
parent 9042698478
commit 05d36f23b0
2 changed files with 6 additions and 4 deletions

4
debian/changelog vendored
View File

@ -1,4 +1,6 @@
linux (4.18~rc4-1~exp2) UNRELEASED; urgency=medium
linux (4.18~rc5-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate
[ John Paul Adrian Glaubitz ]
* [m68k] net: Enable CONFIG_XSURF100 as module.

View File

@ -29,12 +29,12 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/scripts/Kbuild.include
+++ b/scripts/Kbuild.include
@@ -207,7 +207,7 @@ hdr-inst := -f $(srctree)/scripts/Makefi
@@ -215,7 +215,7 @@ hdr-inst := -f $(srctree)/scripts/Makefi
# Prefix -I with $(srctree) if it is not an absolute path.
# skip if -I has no parameter
addtree = $(if $(patsubst -I%,%,$(1)), \
-$(if $(filter-out -I/% -I./% -I../%,$(1)),$(patsubst -I%,-I$(srctree)/%,$(1)),$(1)))
+$(if $(filter-out -I/% -I./% -I../%,$(subst $(quote),,$(subst $(squote),,$(1)))),$(patsubst -I%,-I$(srctree)/%,$(1)),$(1)))
-$(if $(filter-out -I/% -I./% -I../%,$(1)),$(patsubst -I%,-I$(srctree)/%,$(1)),$(1)),$(1))
+$(if $(filter-out -I/% -I./% -I../%,$(subst $(quote),,$(subst $(squote),,$(1)))),$(patsubst -I%,-I$(srctree)/%,$(1)),$(1)),$(1))
# Find all -I options and call addtree
flags = $(foreach o,$($(1)),$(if $(filter -I%,$(o)),$(call addtree,$(o)),$(o)))