New patch to include compiler.h in barrier.h, barrier() is used in non-SMP case.

svn path=/dists/trunk/linux-2.6/; revision=4684
This commit is contained in:
Norbert Tretkowski 2005-10-28 17:45:22 +00:00
parent 41c53b127a
commit 0466428e3b
3 changed files with 16 additions and 1 deletions

6
debian/changelog vendored
View File

@ -8,7 +8,11 @@ linux-2.6 (2.6.14-2) UNRELEASED; urgency=low
[ dann frazier ]
* Update hppa.diff to 2.6.14-pa0
-- dann frazier <dannf@debian.org> Fri, 28 Oct 2005 08:56:10 -0600
[ Norbert Tretkowski ]
* [alpha] New patch to include compiler.h in barrier.h, barrier() is used in
non-SMP case.
-- Norbert Tretkowski <nobse@debian.org> Fri, 28 Oct 2005 19:26:34 +0200
linux-2.6 (2.6.14-1) unstable; urgency=low

View File

@ -0,0 +1,10 @@
--- 2.6.14-rc5-git6/include/asm-alpha/barrier.h Wed Oct 26 14:43:16 2005
+++ linux/include/asm-alpha/barrier.h Wed Oct 26 15:03:47 2005
@@ -1,6 +1,8 @@
#ifndef __BARRIER_H
#define __BARRIER_H
+#include <asm/compiler.h>
+
#define mb() \
__asm__ __volatile__("mb": : :"memory")

1
debian/patches-debian/series/2.6.14-2 vendored Normal file
View File

@ -0,0 +1 @@
+ alpha-compile-fix.patch