[SCSI] fix scsi_wait_scan (Closes: #647436)

svn path=/dists/sid/linux-2.6/; revision=19051
This commit is contained in:
Ben Hutchings 2012-06-01 03:47:59 +00:00
parent 303c65230f
commit 041284f401
3 changed files with 43 additions and 0 deletions

1
debian/changelog vendored
View File

@ -31,6 +31,7 @@ linux-2.6 (3.2.19-1) UNRELEASED; urgency=low
* [x86] mm: pmd_read_atomic: fix 32bit PAE pmd walk vs pmd_populate SMP race
condition (CVE-2012-2373)
* hugetlb: fix resv_map leak in error path (CVE-2012-2390)
* [SCSI] fix scsi_wait_scan (Closes: #647436)
-- Ben Hutchings <ben@decadent.org.uk> Sun, 27 May 2012 01:12:44 +0100

View File

@ -0,0 +1,40 @@
From: James Bottomley <jbottomley@parallels.com>
Date: Wed, 30 May 2012 09:45:39 +0000
Subject: [SCSI] fix scsi_wait_scan
commit 1ff2f40305772b159a91c19590ee159d3a504afc upstream.
Commit c751085943362143f84346d274e0011419c84202
Author: Rafael J. Wysocki <rjw@sisk.pl>
Date: Sun Apr 12 20:06:56 2009 +0200
PM/Hibernate: Wait for SCSI devices scan to complete during resume
Broke the scsi_wait_scan module in 2.6.30. Apparently debian still uses it so
fix it and backport to stable before removing it in 3.6.
The breakage is caused because the function template in
include/scsi/scsi_scan.h is defined to be a nop unless SCSI is built in.
That means that in the modular case (which is every distro), the
scsi_wait_scan module does a simple async_synchronize_full() instead of
waiting for scans.
Signed-off-by: James Bottomley <JBottomley@Parallels.com>
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/scsi/scsi_wait_scan.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/scsi/scsi_wait_scan.c b/drivers/scsi/scsi_wait_scan.c
index 74708fc..ae78148 100644
--- a/drivers/scsi/scsi_wait_scan.c
+++ b/drivers/scsi/scsi_wait_scan.c
@@ -12,7 +12,7 @@
#include <linux/module.h>
#include <linux/device.h>
-#include <scsi/scsi_scan.h>
+#include "scsi_priv.h"
static int __init wait_scan_init(void)
{

View File

@ -307,3 +307,5 @@
+ bugfix/all/hugetlb-fix-resv_map-leak-in-error-path.patch
+ bugfix/all/mm-fix-vma_resv_map-null-pointer.patch
+ bugfix/all/hugepages-fix-use-after-free-bug-in-quota-handling.patch
+ bugfix/all/fix-scsi_wait_scan.patch